summaryrefslogtreecommitdiff
path: root/meta/packages/python/python-2.5.2/autohell.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/python/python-2.5.2/autohell.patch')
-rw-r--r--meta/packages/python/python-2.5.2/autohell.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/packages/python/python-2.5.2/autohell.patch b/meta/packages/python/python-2.5.2/autohell.patch
new file mode 100644
index 000000000..32977955d
--- /dev/null
+++ b/meta/packages/python/python-2.5.2/autohell.patch
@@ -0,0 +1,50 @@
+Index: Python-2.5.2/configure.in
+===================================================================
+--- Python-2.5.2.orig/configure.in
++++ Python-2.5.2/configure.in
+@@ -3410,45 +3410,6 @@ esac
+
+
+
+-AC_MSG_CHECKING(for %zd printf() format support)
+-AC_TRY_RUN([#include <stdio.h>
+-#include <stddef.h>
+-#include <string.h>
+-
+-#ifdef HAVE_SYS_TYPES_H
+-#include <sys/types.h>
+-#endif
+-
+-#ifdef HAVE_SSIZE_T
+-typedef ssize_t Py_ssize_t;
+-#elif SIZEOF_VOID_P == SIZEOF_LONG
+-typedef long Py_ssize_t;
+-#else
+-typedef int Py_ssize_t;
+-#endif
+-
+-int main()
+-{
+- char buffer[256];
+-
+- if(sprintf(buffer, "%zd", (size_t)123) < 0)
+- return 1;
+-
+- if (strcmp(buffer, "123"))
+- return 1;
+-
+- if (sprintf(buffer, "%zd", (Py_ssize_t)-123) < 0)
+- return 1;
+-
+- if (strcmp(buffer, "-123"))
+- return 1;
+-
+- return 0;
+-}],
+-[AC_MSG_RESULT(yes)
+- AC_DEFINE(PY_FORMAT_SIZE_T, "z", [Define to printf format modifier for Py_ssize_t])],
+- AC_MSG_RESULT(no))
+-
+ AC_CHECK_TYPE(socklen_t,,
+ AC_DEFINE(socklen_t,int,
+ Define to `int' if <sys/socket.h> does not define.),[