summaryrefslogtreecommitdiff
path: root/meta/packages/python/python-2.5.2/fix-tkinter-detection.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/python/python-2.5.2/fix-tkinter-detection.patch')
-rw-r--r--meta/packages/python/python-2.5.2/fix-tkinter-detection.patch41
1 files changed, 0 insertions, 41 deletions
diff --git a/meta/packages/python/python-2.5.2/fix-tkinter-detection.patch b/meta/packages/python/python-2.5.2/fix-tkinter-detection.patch
deleted file mode 100644
index 93bd34338..000000000
--- a/meta/packages/python/python-2.5.2/fix-tkinter-detection.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
-Index: Python-2.5.1/setup.py
-===================================================================
---- Python-2.5.1.orig/setup.py
-+++ Python-2.5.1/setup.py
-@@ -1227,7 +1227,7 @@ class PyBuildExt(build_ext):
- dotversion = dotversion[:-1] + '.' + dotversion[-1]
- tcl_include_sub = []
- tk_include_sub = []
-- for dir in inc_dirs:
-+ for dir in [os.getenv("STAGING_INCDIR")]:
- tcl_include_sub += [dir + os.sep + "tcl" + dotversion]
- tk_include_sub += [dir + os.sep + "tk" + dotversion]
- tk_include_sub += tcl_include_sub
-@@ -1246,22 +1246,6 @@ class PyBuildExt(build_ext):
- if dir not in include_dirs:
- include_dirs.append(dir)
-
-- # Check for various platform-specific directories
-- if platform == 'sunos5':
-- include_dirs.append('/usr/openwin/include')
-- added_lib_dirs.append('/usr/openwin/lib')
-- elif os.path.exists('/usr/X11R6/include'):
-- include_dirs.append('/usr/X11R6/include')
-- added_lib_dirs.append('/usr/X11R6/lib64')
-- added_lib_dirs.append('/usr/X11R6/lib')
-- elif os.path.exists('/usr/X11R5/include'):
-- include_dirs.append('/usr/X11R5/include')
-- added_lib_dirs.append('/usr/X11R5/lib')
-- else:
-- # Assume default location for X11
-- include_dirs.append('/usr/X11/include')
-- added_lib_dirs.append('/usr/X11/lib')
--
- # If Cygwin, then verify that X is installed before proceeding
- if platform == 'cygwin':
- x11_inc = find_file('X11/Xlib.h', [], include_dirs)