summaryrefslogtreecommitdiff
path: root/meta/packages/python/python-native_2.6.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/python/python-native_2.6.5.bb')
-rw-r--r--meta/packages/python/python-native_2.6.5.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/packages/python/python-native_2.6.5.bb b/meta/packages/python/python-native_2.6.5.bb
new file mode 100644
index 000000000..d766853c1
--- /dev/null
+++ b/meta/packages/python/python-native_2.6.5.bb
@@ -0,0 +1,31 @@
+require python.inc
+DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native sqlite3-native"
+PR = "${INC_PR}.3"
+
+SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
+ file://00-fix-bindir-libdir-for-cross.patch \
+ file://04-default-is-optimized.patch \
+ file://05-enable-ctypes-cross-build.patch \
+ file://10-distutils-fix-swig-parameter.patch \
+ file://11-distutils-never-modify-shebang-line.patch \
+ file://12-distutils-prefix-is-inside-staging-area.patch \
+ file://debug.patch \
+ file://nohostlibs.patch"
+S = "${WORKDIR}/Python-${PV}"
+
+inherit native
+
+EXTRA_OEMAKE = '\
+ BUILD_SYS="" \
+ HOST_SYS="" \
+ LIBC="" \
+ STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
+ STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
+'
+
+NATIVE_INSTALL_WORKS = "1"
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${bindir}/
+ install -m 0755 Parser/pgen ${D}${bindir}/
+}