summaryrefslogtreecommitdiff
path: root/meta/packages/qemu/qemu-git/fix-nogl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/qemu/qemu-git/fix-nogl.patch')
-rw-r--r--meta/packages/qemu/qemu-git/fix-nogl.patch31
1 files changed, 16 insertions, 15 deletions
diff --git a/meta/packages/qemu/qemu-git/fix-nogl.patch b/meta/packages/qemu/qemu-git/fix-nogl.patch
index 6cb812f00..68efab3a1 100644
--- a/meta/packages/qemu/qemu-git/fix-nogl.patch
+++ b/meta/packages/qemu/qemu-git/fix-nogl.patch
@@ -1,20 +1,21 @@
-Index: git/Makefile.target
+Index: qemu/Makefile.target
===================================================================
---- git.orig/Makefile.target 2009-06-09 22:05:27.000000000 +0100
-+++ git/Makefile.target 2009-06-09 22:05:28.000000000 +0100
-@@ -155,6 +155,8 @@
+--- qemu.orig/Makefile.target 2010-05-11 16:53:34.545811866 -0400
++++ qemu/Makefile.target 2010-05-11 16:53:37.743809704 -0400
+@@ -47,6 +47,9 @@ libobj-$(CONFIG_NOSOFTFLOAT) += fpu/soft
+ libobj-y += op_helper.o helper.o
+ libobj-$(CONFIG_NEED_MMU) += mmu.o
+ libobj-$(TARGET_I386) += helper_opengl.o opengl_exec.o
++libobj-$(TARGET_X86_64) += helper_opengl.o opengl_exec.o
++libobj-$(TARGET_ARM) += dummygl.o
++libobj-$(TARGET_MIPS) += dummygl.o
+ libobj-$(TARGET_ARM) += neon_helper.o iwmmxt_helper.o
+ libobj-$(TARGET_ALPHA) += alpha_palcode.o
- ifeq ($(TARGET_BASE_ARCH), i386)
- LIBOBJS+=helper_opengl.o opengl_exec.o
-+else
-+LIBOBJS+=dummygl.o
- endif
-
- ifeq ($(TARGET_BASE_ARCH), arm)
-Index: git/target-arm/dummygl.c
+Index: qemu/target-arm/dummygl.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ git/target-arm/dummygl.c 2009-06-09 22:15:55.000000000 +0100
++++ qemu/target-arm/dummygl.c 2010-05-11 16:53:37.743809704 -0400
@@ -0,0 +1,22 @@
+#include <string.h>
+#include <stdlib.h>
@@ -38,10 +39,10 @@ Index: git/target-arm/dummygl.c
+{
+
+}
-Index: git/target-mips/dummygl.c
+Index: qemu/target-mips/dummygl.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ git/target-mips/dummygl.c 2009-06-09 22:15:55.000000000 +0100
++++ qemu/target-mips/dummygl.c 2010-05-11 16:53:37.744811919 -0400
@@ -0,0 +1,22 @@
+#include <string.h>
+#include <stdlib.h>