summaryrefslogtreecommitdiff
path: root/meta/packages/web/web-webkit/link-with-g++.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/web/web-webkit/link-with-g++.patch')
-rw-r--r--meta/packages/web/web-webkit/link-with-g++.patch19
1 files changed, 16 insertions, 3 deletions
diff --git a/meta/packages/web/web-webkit/link-with-g++.patch b/meta/packages/web/web-webkit/link-with-g++.patch
index 946d950cf..50d6e9379 100644
--- a/meta/packages/web/web-webkit/link-with-g++.patch
+++ b/meta/packages/web/web-webkit/link-with-g++.patch
@@ -1,7 +1,8 @@
----
- src/Makefile.am | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
+The main webkit library links against stdc++ so we need to use g++ for
+linking. The easiest way to achieve this is to add a dummy cpp file.
+This also means we have to add AC_PROG_CXX else libtool 2.2.2 gets upset.
+RP - 14/4/08
--- webkit.orig/src/Makefile.am
+++ webkit/src/Makefile.am
@@ -1,11 +1,11 @@
@@ -17,3 +18,15 @@
MAINTAINERCLEANFILES = config.h.in Makefile.in
uidir = $(pkgdatadir)
+Index: webkit/configure.ac
+===================================================================
+--- webkit.orig/configure.ac 2008-04-14 22:15:25.000000000 +0100
++++ webkit/configure.ac 2008-04-14 22:16:31.000000000 +0100
+@@ -7,6 +7,7 @@
+
+ AC_ISC_POSIX
+ AC_PROG_CC
++AC_PROG_CXX
+ AC_STDC_HEADERS
+ AC_PROG_LIBTOOL
+