summaryrefslogtreecommitdiff
path: root/meta/packages/xlibs/libxfont
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/xlibs/libxfont')
-rw-r--r--meta/packages/xlibs/libxfont/autofoo.patch18
-rw-r--r--meta/packages/xlibs/libxfont/scalable.patch27
2 files changed, 45 insertions, 0 deletions
diff --git a/meta/packages/xlibs/libxfont/autofoo.patch b/meta/packages/xlibs/libxfont/autofoo.patch
new file mode 100644
index 000000000..4998625c2
--- /dev/null
+++ b/meta/packages/xlibs/libxfont/autofoo.patch
@@ -0,0 +1,18 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- libXfont-1.4.2/configure.ac~autofoo 2004-05-06 20:19:03.000000000 -0400
++++ libXfont-1.4.2/configure.ac 2005-01-16 12:14:14.042598720 -0500
+@@ -35,9 +35,9 @@
+ dnl Yes, it is a pain to synchronize version numbers. Unfortunately, it's
+ dnl not possible to extract the version number here from Xfont.h
+ dnl
++AC_CONFIG_AUX_DIR(.)
+ AM_INIT_AUTOMAKE([dist-bzip2])
+ AM_CONFIG_HEADER(config.h)
+-AC_CONFIG_AUX_DIR(.)
+ AC_CONFIG_HEADERS([include/X11/fonts/fontconf.h])
+
+ # Check for progs
diff --git a/meta/packages/xlibs/libxfont/scalable.patch b/meta/packages/xlibs/libxfont/scalable.patch
new file mode 100644
index 000000000..7f97b9a8f
--- /dev/null
+++ b/meta/packages/xlibs/libxfont/scalable.patch
@@ -0,0 +1,27 @@
+Index: fontfile/fontdir.c
+===================================================================
+RCS file: /cvs/xlibs/Xfont/fontfile/fontdir.c,v
+retrieving revision 3.22
+diff -u -r3.22 fontdir.c
+--- xfont/fontfile/fontdir.c 7 Jul 2003 16:40:11 -0000 3.22
++++ xfont/fontfile/fontdir.c 30 Dec 2004 20:37:12 -0000
+@@ -699,6 +699,11 @@
+ */
+ if (isscale)
+ {
++ /* If the fontname says it is scalable, make sure that the
++ * renderer supports OpenScalable and GetInfoScalable.
++ */
++ if (renderer->OpenScalable && renderer->GetInfoScalable)
++ {
+ if (vals.values_supplied & SIZE_SPECIFY_MASK)
+ {
+ bzero((char *)&zeroVals, sizeof(zeroVals));
+@@ -798,6 +803,7 @@
+ bitmap->name.name);
+ }
+ }
++ }
+ }
+ return TRUE;
+ }