summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/clutter/moblin-proto/fix.patch22
-rw-r--r--meta/packages/clutter/moblin-proto/paths.patch15
-rw-r--r--meta/packages/clutter/moblin-proto_git.bb8
3 files changed, 21 insertions, 24 deletions
diff --git a/meta/packages/clutter/moblin-proto/fix.patch b/meta/packages/clutter/moblin-proto/fix.patch
index 802b8c4b6..8bde67762 100644
--- a/meta/packages/clutter/moblin-proto/fix.patch
+++ b/meta/packages/clutter/moblin-proto/fix.patch
@@ -20,25 +20,3 @@ Index: git/Makefile
#$(BINARY): $(CFILES)
# $(LD) $(CFLAGS) $(INCS) $(CFILES) $(LIBS) -o $@
-Index: git/moblin-desktop.c
-===================================================================
---- git.orig/moblin-desktop.c 2008-08-11 22:49:49.000000000 +0100
-+++ git/moblin-desktop.c 2008-08-12 12:14:44.000000000 +0100
-@@ -620,17 +620,10 @@
-
- attach_reactivate_on_press (old_app);
-
--<<<<<<< HEAD:moblin-desktop.c
- shuttle = clutter_group_new ();
- clutter_group_add (CLUTTER_GROUP(desktop->mainstuff), shuttle);
- copy_geometry (desktop->middle, shuttle);
- clutter_actor_reparent (old_app, shuttle);
--=======
-- box = clutter_group_new ();
-- clutter_group_add (CLUTTER_GROUP(desktop->stage), box);
-- copy_geometry (desktop->middle, box);
-- clutter_actor_reparent (old_app, box);
-->>>>>>> Removed now unneeded forcible shows of apps.:moblin-desktop.c
-
- {
- gint x, y;
diff --git a/meta/packages/clutter/moblin-proto/paths.patch b/meta/packages/clutter/moblin-proto/paths.patch
new file mode 100644
index 000000000..d241c8ff7
--- /dev/null
+++ b/meta/packages/clutter/moblin-proto/paths.patch
@@ -0,0 +1,15 @@
+diff --git a/moblin-desktop.h b/moblin-desktop.h
+index 880a9ad..3d51a14 100644
+--- a/moblin-desktop.h
++++ b/moblin-desktop.h
+@@ -29,8 +29,8 @@
+ #define __MAIN_H__
+
+
+-#define ASSET_ROOT "./assets/"
+-#define JSON_ROOT "./layouts/"
++#define ASSET_ROOT "/usr/share/moblin-proto/assets/"
++#define JSON_ROOT "/usr/share/moblin-proto/layouts/"
+
+ typedef struct
+ {
diff --git a/meta/packages/clutter/moblin-proto_git.bb b/meta/packages/clutter/moblin-proto_git.bb
index 00b5b5e3f..8ce97bbea 100644
--- a/meta/packages/clutter/moblin-proto_git.bb
+++ b/meta/packages/clutter/moblin-proto_git.bb
@@ -1,14 +1,18 @@
-
DEPENDS = "clutter-box2d"
PV = "0.0+git${SRCREV}"
+PR = "r1"
SRC_URI = "git://moblin.org/repos/users/pippin/prototype.git/;protocol=http \
- file://fix.patch;patch=1"
+ file://paths.patch;patch=1"
S = "${WORKDIR}/git"
do_install () {
install -d ${D}${bindir}
install ${S}/moblin-proto ${D}${bindir}
+
+ install -d ${D}${datadir}/moblin-proto/
+ cp -a ${S}/assets ${D}${datadir}/moblin-proto/
+ cp -a ${S}/layouts ${D}${datadir}/moblin-proto/
}