summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/ipkg/files/ipkg_bugfix.patch44
-rw-r--r--meta/packages/ipkg/ipkg-native_0.99.154.bb2
-rw-r--r--meta/packages/ipkg/ipkg.inc3
-rw-r--r--meta/packages/ipkg/ipkg_0.99.154.bb2
4 files changed, 48 insertions, 3 deletions
diff --git a/meta/packages/ipkg/files/ipkg_bugfix.patch b/meta/packages/ipkg/files/ipkg_bugfix.patch
new file mode 100644
index 000000000..51eccbb2b
--- /dev/null
+++ b/meta/packages/ipkg/files/ipkg_bugfix.patch
@@ -0,0 +1,44 @@
+Index: C/ipkg_conf.c
+===================================================================
+--- C.orig/ipkg_conf.c 2005-06-21 13:59:32.000000000 +0000
++++ C/ipkg_conf.c 2007-11-27 01:11:17.000000000 +0000
+@@ -423,6 +423,7 @@
+ nv_pair_t *nv_pair;
+ pkg_dest_t *dest;
+ char *root_dir;
++ char *list_dir2;
+
+ for (iter = nv_pair_list->head; iter; iter = iter->next) {
+ nv_pair = iter->data;
+@@ -432,8 +433,14 @@
+ } else {
+ root_dir = strdup(nv_pair->value);
+ }
+- dest = pkg_dest_list_append(&conf->pkg_dest_list, nv_pair->name, root_dir, lists_dir);
++ if (conf->offline_root) {
++ sprintf_alloc(&list_dir2, "%s%s", conf->offline_root, lists_dir);
++ } else {
++ list_dir2 = strdup(lists_dir);
++ }
++ dest = pkg_dest_list_append(&conf->pkg_dest_list, nv_pair->name, root_dir, list_dir2);
+ free(root_dir);
++ free(list_dir2);
+ if (dest == NULL) {
+ continue;
+ }
+@@ -562,13 +569,13 @@
+ } else if (strcmp(type, "dest") == 0) {
+ nv_pair_list_append(tmp_dest_nv_pair_list, name, value);
+ } else if (strcmp(type, "lists_dir") == 0) {
+- *lists_dir = realloc(*lists_dir,strlen(value)+1);
++ *lists_dir = realloc(*lists_dir,strlen(name)+1);
+ if (*lists_dir == NULL) {
+ ipkg_message(conf, IPKG_ERROR, "ERROR: Not enough memory\n");
+ free(options);
+ return EINVAL;
+ }
+- sprintf (*lists_dir,"%s",value);
++ sprintf (*lists_dir,"%s", name);
+ } else if (strcmp(type, "arch") == 0) {
+ ipkg_message(conf, IPKG_INFO, "supported arch %s priority (%s)\n", name, value);
+ if (!value) {
diff --git a/meta/packages/ipkg/ipkg-native_0.99.154.bb b/meta/packages/ipkg/ipkg-native_0.99.154.bb
index 20ec07a63..9e5185fe2 100644
--- a/meta/packages/ipkg/ipkg-native_0.99.154.bb
+++ b/meta/packages/ipkg/ipkg-native_0.99.154.bb
@@ -1,4 +1,4 @@
require ipkg.inc
require ipkg-native.inc
-PR = "r1"
+PR = "r2"
diff --git a/meta/packages/ipkg/ipkg.inc b/meta/packages/ipkg/ipkg.inc
index 8965a0f45..c3195c8c5 100644
--- a/meta/packages/ipkg/ipkg.inc
+++ b/meta/packages/ipkg/ipkg.inc
@@ -11,7 +11,8 @@ AUTO_LIBNAME_PKGS = "libipkg"
SRC_URI = "${HANDHELDS_CVS};module=familiar/dist/ipkg;tag=${@'V' + bb.data.getVar('PV',d,1).replace('.', '-')} \
file://fix_tar_extension.patch;patch=1 \
- file://terse.patch;patch=1 \
+ file://terse.patch;patch=1 \
+ file://ipkg_bugfix.patch;patch=1 \
file://noupdalt.patch;patch=1"
S = "${WORKDIR}/ipkg/C"
diff --git a/meta/packages/ipkg/ipkg_0.99.154.bb b/meta/packages/ipkg/ipkg_0.99.154.bb
index 8f4e4aaaf..27992c3ef 100644
--- a/meta/packages/ipkg/ipkg_0.99.154.bb
+++ b/meta/packages/ipkg/ipkg_0.99.154.bb
@@ -1,4 +1,4 @@
require ipkg.inc
-PR = "r8"
+PR = "r9"
RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_update-alternatives}"