summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/matchbox-sato/matchbox-sato_0.1.bb9
-rw-r--r--meta/packages/matchbox-wm/matchbox-wm_1.2.bb9
-rw-r--r--meta/packages/matchbox-wm/matchbox-wm_svn.bb8
3 files changed, 21 insertions, 5 deletions
diff --git a/meta/packages/matchbox-sato/matchbox-sato_0.1.bb b/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
index e2f4aeb82..b8d6d7151 100644
--- a/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
+++ b/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
@@ -3,11 +3,18 @@ LICENSE = "GPL"
SECTION = "x11"
RDEPENDS = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato initscripts"
RCONFLICTS = "matchbox-common"
-PR = "r20"
+PR = "r21"
SRC_URI = "file://etc file://matchbox-session"
S = ${WORKDIR}
+inherit update-alternatives
+
+ALTERNATIVE_NAME = "x-session-manager"
+ALTERNATIVE_LINK = "${bindir}/x-session-manager"
+ALTERNATIVE_PATH = "${bindir}/matchbox-session"
+ALTERNATIVE_PRIORITY = "10"
+
do_install() {
install -d ${D}/${bindir}
install -m 0755 ${S}/matchbox-session ${D}/${bindir}
diff --git a/meta/packages/matchbox-wm/matchbox-wm_1.2.bb b/meta/packages/matchbox-wm/matchbox-wm_1.2.bb
index 745493522..f68eb2b4a 100644
--- a/meta/packages/matchbox-wm/matchbox-wm_1.2.bb
+++ b/meta/packages/matchbox-wm/matchbox-wm_1.2.bb
@@ -2,7 +2,7 @@ SECTION = "x11/wm"
DESCRIPTION = "Matchbox window manager"
LICENSE = "GPL"
DEPENDS = "libmatchbox virtual/libx11 libxext libxcomposite libxfixes xdamage libxrender startup-notification expat"
-PR="r3"
+PR = "r4"
SRC_URI = "http://matchbox-project.org/sources/matchbox-window-manager/1.2/matchbox-window-manager-${PV}.tar.bz2 \
file://configure_fix.patch;patch=1 \
@@ -25,7 +25,12 @@ ALTERNATIVE_LINK = "${bindir}/x-session-manager"
ALTERNATIVE_PATH = "${bindir}/matchbox-session"
ALTERNATIVE_PRIORITY = "10"
-EXTRA_OECONF = " --enable-startup-notification --disable-xrm --with-expat-lib=${STAGING_LIBDIR} --with-expat-includes=${STAGING_INCDIR}"
+EXTRA_OECONF = " --enable-startup-notification \
+ --disable-xrm \
+ --enable-expat \
+ --with-expat-lib=${STAGING_LIBDIR} \
+ --with-expat-includes=${STAGING_INCDIR}"
+
do_configure_prepend () {
cp ${WORKDIR}/gconf-2.m4 ${S}/
diff --git a/meta/packages/matchbox-wm/matchbox-wm_svn.bb b/meta/packages/matchbox-wm/matchbox-wm_svn.bb
index fc1e09e50..d8a48e2ce 100644
--- a/meta/packages/matchbox-wm/matchbox-wm_svn.bb
+++ b/meta/packages/matchbox-wm/matchbox-wm_svn.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Matchbox window manager"
LICENSE = "GPL"
DEPENDS = "libmatchbox virtual/libx11 libxext libxrender startup-notification expat gconf"
PV = "1.2+svnr${SRCREV}"
-PR = "r2"
+PR = "r3"
SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager;proto=http \
file://configure_fix.patch;patch=1;maxrev=1818 \
@@ -25,7 +25,11 @@ FILES_${PN} = "${bindir}/* \
${datadir}/themes/Default/matchbox \
${datadir}/themes/MBOpus/matchbox"
-EXTRA_OECONF = " --enable-startup-notification --disable-xrm --with-expat-lib=${STAGING_LIBDIR} --with-expat-includes=${STAGING_INCDIR} --enable-expat"
+EXTRA_OECONF = " --enable-startup-notification \
+ --disable-xrm \
+ --enable-expat \
+ --with-expat-lib=${STAGING_LIBDIR} \
+ --with-expat-includes=${STAGING_INCDIR}"
do_install_prepend() {
install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig