summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/gcc/gcc-4.6.0/gcc-4_6-branch-backports/0345-2011-05-25-Paolo-Carlini-paolo.carlini-oracle.com.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc-4.6.0/gcc-4_6-branch-backports/0345-2011-05-25-Paolo-Carlini-paolo.carlini-oracle.com.patch')
-rw-r--r--meta/recipes-devtools/gcc/gcc-4.6.0/gcc-4_6-branch-backports/0345-2011-05-25-Paolo-Carlini-paolo.carlini-oracle.com.patch78
1 files changed, 78 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-4.6.0/gcc-4_6-branch-backports/0345-2011-05-25-Paolo-Carlini-paolo.carlini-oracle.com.patch b/meta/recipes-devtools/gcc/gcc-4.6.0/gcc-4_6-branch-backports/0345-2011-05-25-Paolo-Carlini-paolo.carlini-oracle.com.patch
new file mode 100644
index 000000000..336f91c15
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc-4.6.0/gcc-4_6-branch-backports/0345-2011-05-25-Paolo-Carlini-paolo.carlini-oracle.com.patch
@@ -0,0 +1,78 @@
+From 8d80c4587462bb26e116a229978e1682e2099557 Mon Sep 17 00:00:00 2001
+From: paolo <paolo@138bc75d-0d04-0410-961f-82ee72b054a4>
+Date: Thu, 26 May 2011 00:15:58 +0000
+Subject: [PATCH] 2011-05-25 Paolo Carlini <paolo.carlini@oracle.com>
+
+ * config/abi/pre/gnu.ver: Correct last change, export instead
+ at the existing @3.4.16.
+ * configure.ac: Revert last change.
+ * testsuite/util/testsuite_abi.cc: Likewise.
+ * configure: Regenerate.
+
+
+git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/branches/gcc-4_6-branch@174247 138bc75d-0d04-0410-961f-82ee72b054a4
+
+index 778b826..57744a4 100644
+--- a/libstdc++-v3/config/abi/pre/gnu.ver
++++ b/libstdc++-v3/config/abi/pre/gnu.ver
+@@ -1270,10 +1270,6 @@ GLIBCXX_3.4.16 {
+ _ZNSs10_S_compareE[jmy][jmy];
+ _ZNSbIwSt11char_traitsIwESaIwEE10_S_compareE[jmy][jmy];
+
+-} GLIBCXX_3.4.15;
+-
+-GLIBCXX_3.4.17 {
+-
+ # basic_streambuf<>::__safe_gbump, __safe_pbump
+ _ZNSt15basic_streambufI[cw]St11char_traitsI[cw]EE12__safe_gbumpE*;
+ _ZNSt15basic_streambufI[cw]St11char_traitsI[cw]EE12__safe_pbumpE*;
+@@ -1281,7 +1277,7 @@ GLIBCXX_3.4.17 {
+ # basic_stringbuf<>::_M_pbump
+ _ZNSt15basic_stringbufI[cw]St11char_traitsI[cw]ESaI[cw]EE8_M_pbumpE*;
+
+-} GLIBCXX_3.4.16;
++} GLIBCXX_3.4.15;
+
+ # Symbols in the support library (libsupc++) have their own tag.
+ CXXABI_1.3 {
+diff --git a/libstdc++-v3/configure b/libstdc++-v3/configure
+index 9032695..c321e76 100755
+--- a/libstdc++-v3/configure
++++ b/libstdc++-v3/configure
+@@ -2825,7 +2825,7 @@ ac_config_headers="$ac_config_headers config.h"
+ ### am handles this now? ORIGINAL_LD_FOR_MULTILIBS=$LD
+
+ # For libtool versioning info, format is CURRENT:REVISION:AGE
+-libtool_VERSION=6:17:0
++libtool_VERSION=6:16:0
+
+
+ # Find the rest of the source tree framework.
+diff --git a/libstdc++-v3/configure.ac b/libstdc++-v3/configure.ac
+index 61158c2..ccf1230 100644
+--- a/libstdc++-v3/configure.ac
++++ b/libstdc++-v3/configure.ac
+@@ -12,7 +12,7 @@ AC_CONFIG_HEADER(config.h)
+ ### am handles this now? ORIGINAL_LD_FOR_MULTILIBS=$LD
+
+ # For libtool versioning info, format is CURRENT:REVISION:AGE
+-libtool_VERSION=6:17:0
++libtool_VERSION=6:16:0
+ AC_SUBST(libtool_VERSION)
+
+ # Find the rest of the source tree framework.
+diff --git a/libstdc++-v3/testsuite/util/testsuite_abi.cc b/libstdc++-v3/testsuite/util/testsuite_abi.cc
+index f1f5ad6..ea100b6 100644
+--- a/libstdc++-v3/testsuite/util/testsuite_abi.cc
++++ b/libstdc++-v3/testsuite/util/testsuite_abi.cc
+@@ -194,7 +194,6 @@ check_version(symbol& test, bool added)
+ known_versions.push_back("GLIBCXX_3.4.14");
+ known_versions.push_back("GLIBCXX_3.4.15");
+ known_versions.push_back("GLIBCXX_3.4.16");
+- known_versions.push_back("GLIBCXX_3.4.17");
+ known_versions.push_back("GLIBCXX_LDBL_3.4");
+ known_versions.push_back("GLIBCXX_LDBL_3.4.7");
+ known_versions.push_back("GLIBCXX_LDBL_3.4.10");
+--
+1.7.0.4
+