summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/gcc/gcc-4.6/gcc-flags-for-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc-4.6/gcc-flags-for-build.patch')
-rw-r--r--meta/recipes-devtools/gcc/gcc-4.6/gcc-flags-for-build.patch97
1 files changed, 53 insertions, 44 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-4.6/gcc-flags-for-build.patch b/meta/recipes-devtools/gcc/gcc-4.6/gcc-flags-for-build.patch
index 9cba50dcc..5eaeb0508 100644
--- a/meta/recipes-devtools/gcc/gcc-4.6/gcc-flags-for-build.patch
+++ b/meta/recipes-devtools/gcc/gcc-4.6/gcc-flags-for-build.patch
@@ -1,10 +1,10 @@
Upstream-Status: Pending
-Index: gcc-4.6.0/Makefile.def
+Index: gcc-4_6-branch/Makefile.def
===================================================================
---- gcc-4.6.0.orig/Makefile.def
-+++ gcc-4.6.0/Makefile.def
-@@ -243,6 +243,7 @@ flags_to_pass = { flag= AWK ; };
+--- gcc-4_6-branch.orig/Makefile.def 2012-03-03 01:08:03.000000000 -0800
++++ gcc-4_6-branch/Makefile.def 2012-03-04 09:19:02.430607447 -0800
+@@ -242,6 +242,7 @@
flags_to_pass = { flag= BISON ; };
flags_to_pass = { flag= CC_FOR_BUILD ; };
flags_to_pass = { flag= CFLAGS_FOR_BUILD ; };
@@ -12,11 +12,11 @@ Index: gcc-4.6.0/Makefile.def
flags_to_pass = { flag= CXX_FOR_BUILD ; };
flags_to_pass = { flag= EXPECT ; };
flags_to_pass = { flag= FLEX ; };
-Index: gcc-4.6.0/gcc/Makefile.in
+Index: gcc-4_6-branch/gcc/Makefile.in
===================================================================
---- gcc-4.6.0.orig/gcc/Makefile.in
-+++ gcc-4.6.0/gcc/Makefile.in
-@@ -770,7 +770,7 @@ BUILD_LINKERFLAGS = $(BUILD_CFLAGS)
+--- gcc-4_6-branch.orig/gcc/Makefile.in 2012-03-03 01:03:17.000000000 -0800
++++ gcc-4_6-branch/gcc/Makefile.in 2012-03-04 09:19:02.430607447 -0800
+@@ -770,7 +770,7 @@
# Native linker and preprocessor flags. For x-fragment overrides.
BUILD_LDFLAGS=@BUILD_LDFLAGS@
@@ -25,11 +25,11 @@ Index: gcc-4.6.0/gcc/Makefile.in
# Actual name to use when installing a native compiler.
GCC_INSTALL_NAME := $(shell echo gcc|sed '$(program_transform_name)')
-Index: gcc-4.6.0/gcc/configure.ac
+Index: gcc-4_6-branch/gcc/configure.ac
===================================================================
---- gcc-4.6.0.orig/gcc/configure.ac
-+++ gcc-4.6.0/gcc/configure.ac
-@@ -1784,16 +1784,18 @@ AC_SUBST(inhibit_libc)
+--- gcc-4_6-branch.orig/gcc/configure.ac 2012-03-03 01:17:45.000000000 -0800
++++ gcc-4_6-branch/gcc/configure.ac 2012-03-04 09:19:02.430607447 -0800
+@@ -1774,16 +1774,18 @@
# Also, we cannot run fixincludes.
# These are the normal (build=host) settings:
@@ -52,11 +52,11 @@ Index: gcc-4.6.0/gcc/configure.ac
fi
# Expand extra_headers to include complete path.
-Index: gcc-4.6.0/Makefile.in
+Index: gcc-4_6-branch/Makefile.in
===================================================================
---- gcc-4.6.0.orig/Makefile.in
-+++ gcc-4.6.0/Makefile.in
-@@ -338,6 +338,7 @@ AR_FOR_BUILD = @AR_FOR_BUILD@
+--- gcc-4_6-branch.orig/Makefile.in 2012-03-03 01:08:03.000000000 -0800
++++ gcc-4_6-branch/Makefile.in 2012-03-04 09:19:02.446607448 -0800
+@@ -338,6 +338,7 @@
AS_FOR_BUILD = @AS_FOR_BUILD@
CC_FOR_BUILD = @CC_FOR_BUILD@
CFLAGS_FOR_BUILD = @CFLAGS_FOR_BUILD@
@@ -64,7 +64,7 @@ Index: gcc-4.6.0/Makefile.in
CXXFLAGS_FOR_BUILD = @CXXFLAGS_FOR_BUILD@
CXX_FOR_BUILD = @CXX_FOR_BUILD@
DLLTOOL_FOR_BUILD = @DLLTOOL_FOR_BUILD@
-@@ -691,6 +692,7 @@ BASE_FLAGS_TO_PASS = \
+@@ -691,6 +692,7 @@
"BISON=$(BISON)" \
"CC_FOR_BUILD=$(CC_FOR_BUILD)" \
"CFLAGS_FOR_BUILD=$(CFLAGS_FOR_BUILD)" \
@@ -72,11 +72,11 @@ Index: gcc-4.6.0/Makefile.in
"CXX_FOR_BUILD=$(CXX_FOR_BUILD)" \
"EXPECT=$(EXPECT)" \
"FLEX=$(FLEX)" \
-Index: gcc-4.6.0/gcc/configure
+Index: gcc-4_6-branch/gcc/configure
===================================================================
---- gcc-4.6.0.orig/gcc/configure
-+++ gcc-4.6.0/gcc/configure
-@@ -703,6 +703,7 @@ SED
+--- gcc-4_6-branch.orig/gcc/configure 2012-03-03 01:17:45.000000000 -0800
++++ gcc-4_6-branch/gcc/configure 2012-03-04 09:19:15.638608087 -0800
+@@ -703,6 +703,7 @@
LIBTOOL
collect2
STMP_FIXINC
@@ -84,7 +84,16 @@ Index: gcc-4.6.0/gcc/configure
BUILD_LDFLAGS
BUILD_CFLAGS
CC_FOR_BUILD
-@@ -11382,6 +11383,7 @@ fi
+@@ -4842,7 +4843,7 @@
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $acx_cv_cc_gcc_supports_ada" >&5
+ $as_echo "$acx_cv_cc_gcc_supports_ada" >&6; }
+
+-if test x$GNATBIND != xno && test x$GNATMAKE != xno && test x$acx_cv_cc_gcc_supports_ada != xno; then
++if test "x$GNATBIND" != xno && test "x$GNATMAKE" != xno && test x$acx_cv_cc_gcc_supports_ada != xno; then
+ have_gnat=yes
+ else
+ have_gnat=no
+@@ -11372,6 +11373,7 @@
CC_FOR_BUILD='$(CC)'
BUILD_CFLAGS='$(ALL_CFLAGS)'
BUILD_LDFLAGS='$(LDFLAGS)'
@@ -92,7 +101,7 @@ Index: gcc-4.6.0/gcc/configure
STMP_FIXINC=stmp-fixinc
# And these apply if build != host, or we are generating coverage data
-@@ -11389,6 +11391,7 @@ if test x$build != x$host || test "x$cov
+@@ -11379,6 +11381,7 @@
then
BUILD_CFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)'
BUILD_LDFLAGS='$(LDFLAGS_FOR_BUILD)'
@@ -100,29 +109,29 @@ Index: gcc-4.6.0/gcc/configure
fi
# Expand extra_headers to include complete path.
-@@ -17505,7 +17508,7 @@ else
+@@ -17495,7 +17498,7 @@
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 17508 "configure"
-+#line 17511 "configure"
+-#line 17498 "configure"
++#line 17501 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
-@@ -17611,7 +17614,7 @@ else
+@@ -17601,7 +17604,7 @@
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 17614 "configure"
-+#line 17617 "configure"
+-#line 17604 "configure"
++#line 17607 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
-Index: gcc-4.6.0/Makefile.tpl
+Index: gcc-4_6-branch/Makefile.tpl
===================================================================
---- gcc-4.6.0.orig/Makefile.tpl
-+++ gcc-4.6.0/Makefile.tpl
-@@ -341,6 +341,7 @@ AR_FOR_BUILD = @AR_FOR_BUILD@
+--- gcc-4_6-branch.orig/Makefile.tpl 2012-03-03 01:08:03.000000000 -0800
++++ gcc-4_6-branch/Makefile.tpl 2012-03-04 09:19:02.454607448 -0800
+@@ -341,6 +341,7 @@
AS_FOR_BUILD = @AS_FOR_BUILD@
CC_FOR_BUILD = @CC_FOR_BUILD@
CFLAGS_FOR_BUILD = @CFLAGS_FOR_BUILD@
@@ -130,11 +139,11 @@ Index: gcc-4.6.0/Makefile.tpl
CXXFLAGS_FOR_BUILD = @CXXFLAGS_FOR_BUILD@
CXX_FOR_BUILD = @CXX_FOR_BUILD@
DLLTOOL_FOR_BUILD = @DLLTOOL_FOR_BUILD@
-Index: gcc-4.6.0/configure.ac
+Index: gcc-4_6-branch/configure.ac
===================================================================
---- gcc-4.6.0.orig/configure.ac
-+++ gcc-4.6.0/configure.ac
-@@ -3154,6 +3154,7 @@ esac
+--- gcc-4_6-branch.orig/configure.ac 2012-03-03 01:17:45.000000000 -0800
++++ gcc-4_6-branch/configure.ac 2012-03-04 09:19:02.454607448 -0800
+@@ -3123,6 +3123,7 @@
# our build compiler if desired.
if test x"${build}" = x"${host}" ; then
CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-${CFLAGS}}
@@ -142,7 +151,7 @@ Index: gcc-4.6.0/configure.ac
CXXFLAGS_FOR_BUILD=${CXXFLAGS_FOR_BUILD-${CXXFLAGS}}
LDFLAGS_FOR_BUILD=${LDFLAGS_FOR_BUILD-${LDFLAGS}}
fi
-@@ -3220,6 +3221,7 @@ AC_SUBST(AR_FOR_BUILD)
+@@ -3189,6 +3190,7 @@
AC_SUBST(AS_FOR_BUILD)
AC_SUBST(CC_FOR_BUILD)
AC_SUBST(CFLAGS_FOR_BUILD)
@@ -150,11 +159,11 @@ Index: gcc-4.6.0/configure.ac
AC_SUBST(CXXFLAGS_FOR_BUILD)
AC_SUBST(CXX_FOR_BUILD)
AC_SUBST(DLLTOOL_FOR_BUILD)
-Index: gcc-4.6.0/configure
+Index: gcc-4_6-branch/configure
===================================================================
---- gcc-4.6.0.orig/configure
-+++ gcc-4.6.0/configure
-@@ -617,6 +617,7 @@ GCJ_FOR_BUILD
+--- gcc-4_6-branch.orig/configure 2012-03-03 01:17:45.000000000 -0800
++++ gcc-4_6-branch/configure 2012-03-04 09:19:02.458607448 -0800
+@@ -617,6 +617,7 @@
DLLTOOL_FOR_BUILD
CXX_FOR_BUILD
CXXFLAGS_FOR_BUILD
@@ -162,7 +171,7 @@ Index: gcc-4.6.0/configure
CFLAGS_FOR_BUILD
CC_FOR_BUILD
AS_FOR_BUILD
-@@ -7675,6 +7676,7 @@ esac
+@@ -7644,6 +7645,7 @@
# our build compiler if desired.
if test x"${build}" = x"${host}" ; then
CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-${CFLAGS}}
@@ -170,7 +179,7 @@ Index: gcc-4.6.0/configure
CXXFLAGS_FOR_BUILD=${CXXFLAGS_FOR_BUILD-${CXXFLAGS}}
LDFLAGS_FOR_BUILD=${LDFLAGS_FOR_BUILD-${LDFLAGS}}
fi
-@@ -7740,6 +7742,7 @@ done
+@@ -7709,6 +7711,7 @@