summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/gcc/gcc-4.6/gcc-poison-system-directories.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc-4.6/gcc-poison-system-directories.patch')
-rw-r--r--meta/recipes-devtools/gcc/gcc-4.6/gcc-poison-system-directories.patch80
1 files changed, 40 insertions, 40 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-4.6/gcc-poison-system-directories.patch b/meta/recipes-devtools/gcc/gcc-4.6/gcc-poison-system-directories.patch
index 3902a352a..a44e86ca4 100644
--- a/meta/recipes-devtools/gcc/gcc-4.6/gcc-poison-system-directories.patch
+++ b/meta/recipes-devtools/gcc/gcc-4.6/gcc-poison-system-directories.patch
@@ -27,11 +27,11 @@ Upstream-Status: Inappropriate [distribution: codesourcery]
ENABLE_POISON_SYSTEM_DIRECTORIES defined, warn for use of
/usr/include, /usr/local/include or /usr/X11R6/include.
-Index: gcc-4.6.0/gcc/common.opt
+Index: gcc-4_6-branch/gcc/common.opt
===================================================================
---- gcc-4.6.0.orig/gcc/common.opt
-+++ gcc-4.6.0/gcc/common.opt
-@@ -558,6 +558,10 @@ Wpadded
+--- gcc-4_6-branch.orig/gcc/common.opt 2012-03-03 01:03:17.000000000 -0800
++++ gcc-4_6-branch/gcc/common.opt 2012-03-04 09:24:54.410624483 -0800
+@@ -567,6 +567,10 @@
Common Var(warn_padded) Warning
Warn when padding is required to align structure members
@@ -42,10 +42,10 @@ Index: gcc-4.6.0/gcc/common.opt
Wshadow
Common Var(warn_shadow) Warning
Warn when one local variable shadows another
-Index: gcc-4.6.0/gcc/config.in
+Index: gcc-4_6-branch/gcc/config.in
===================================================================
---- gcc-4.6.0.orig/gcc/config.in
-+++ gcc-4.6.0/gcc/config.in
+--- gcc-4_6-branch.orig/gcc/config.in 2012-03-03 01:03:17.000000000 -0800
++++ gcc-4_6-branch/gcc/config.in 2012-03-04 09:24:54.410624483 -0800
@@ -144,6 +144,12 @@
#endif
@@ -59,11 +59,11 @@ Index: gcc-4.6.0/gcc/config.in
/* Define if you want all operations on RTL (the basic data structure of the
optimizer and back end) to be checked for dynamic type safety at runtime.
This is quite expensive. */
-Index: gcc-4.6.0/gcc/configure.ac
+Index: gcc-4_6-branch/gcc/configure.ac
===================================================================
---- gcc-4.6.0.orig/gcc/configure.ac
-+++ gcc-4.6.0/gcc/configure.ac
-@@ -4694,6 +4694,16 @@ else
+--- gcc-4_6-branch.orig/gcc/configure.ac 2012-03-04 09:22:07.000000000 -0800
++++ gcc-4_6-branch/gcc/configure.ac 2012-03-04 09:24:54.410624483 -0800
+@@ -4692,6 +4692,16 @@
fi)
AC_SUBST(slibdir)
@@ -80,11 +80,11 @@ Index: gcc-4.6.0/gcc/configure.ac
# Substitute configuration variables
AC_SUBST(subdirs)
AC_SUBST(srcdir)
-Index: gcc-4.6.0/gcc/doc/invoke.texi
+Index: gcc-4_6-branch/gcc/doc/invoke.texi
===================================================================
---- gcc-4.6.0.orig/gcc/doc/invoke.texi
-+++ gcc-4.6.0/gcc/doc/invoke.texi
-@@ -257,6 +257,7 @@ Objective-C and Objective-C++ Dialects}.
+--- gcc-4_6-branch.orig/gcc/doc/invoke.texi 2012-03-03 00:46:39.000000000 -0800
++++ gcc-4_6-branch/gcc/doc/invoke.texi 2012-03-04 09:24:54.414624482 -0800
+@@ -257,6 +257,7 @@
-Woverlength-strings -Wpacked -Wpacked-bitfield-compat -Wpadded @gol
-Wparentheses -Wpedantic-ms-format -Wno-pedantic-ms-format @gol
-Wpointer-arith -Wno-pointer-to-int-cast @gol
@@ -92,7 +92,7 @@ Index: gcc-4.6.0/gcc/doc/invoke.texi
-Wredundant-decls @gol
-Wreturn-type -Wsequence-point -Wshadow @gol
-Wsign-compare -Wsign-conversion -Wstack-protector @gol
-@@ -3773,6 +3774,14 @@ headers---for that, @option{-Wunknown-pr
+@@ -3782,6 +3783,14 @@
for most targets, it is made up of code and thus requires the stack
to be made executable in order for the program to work properly.
@@ -107,11 +107,11 @@ Index: gcc-4.6.0/gcc/doc/invoke.texi
@item -Wfloat-equal
@opindex Wfloat-equal
@opindex Wno-float-equal
-Index: gcc-4.6.0/gcc/gcc.c
+Index: gcc-4_6-branch/gcc/gcc.c
===================================================================
---- gcc-4.6.0.orig/gcc/gcc.c
-+++ gcc-4.6.0/gcc/gcc.c
-@@ -659,6 +659,8 @@ proper position among the other output f
+--- gcc-4_6-branch.orig/gcc/gcc.c 2012-03-03 01:03:17.000000000 -0800
++++ gcc-4_6-branch/gcc/gcc.c 2012-03-04 09:24:54.418624482 -0800
+@@ -659,6 +659,8 @@
%{flto} %{flto=*} %l " LINK_PIE_SPEC \
"%X %{o*} %{e*} %{N} %{n} %{r}\
%{s} %{t} %{u*} %{z} %{Z} %{!nostdlib:%{!nostartfiles:%S}}\
@@ -120,11 +120,11 @@ Index: gcc-4.6.0/gcc/gcc.c
%{static:} %{L*} %(mfwrap) %(link_libgcc) %o\
%{fopenmp|ftree-parallelize-loops=*:%:include(libgomp.spec)%(link_gomp)}\
%(mflib) " STACK_SPLIT_SPEC "\
-Index: gcc-4.6.0/gcc/incpath.c
+Index: gcc-4_6-branch/gcc/incpath.c
===================================================================
---- gcc-4.6.0.orig/gcc/incpath.c
-+++ gcc-4.6.0/gcc/incpath.c
-@@ -353,6 +353,24 @@ merge_include_chains (const char *sysroo
+--- gcc-4_6-branch.orig/gcc/incpath.c 2012-03-03 01:03:17.000000000 -0800
++++ gcc-4_6-branch/gcc/incpath.c 2012-03-04 09:24:54.418624482 -0800
+@@ -353,6 +353,24 @@
}
fprintf (stderr, _("End of search list.\n"));
}
@@ -149,11 +149,11 @@ Index: gcc-4.6.0/gcc/incpath.c
}
/* Use given -I paths for #include "..." but not #include <...>, and
-Index: gcc-4.6.0/gcc/Makefile.in
+Index: gcc-4_6-branch/gcc/Makefile.in
===================================================================
---- gcc-4.6.0.orig/gcc/Makefile.in
-+++ gcc-4.6.0/gcc/Makefile.in
-@@ -2179,7 +2179,7 @@ attribs.o : attribs.c $(CONFIG_H) $(SYST
+--- gcc-4_6-branch.orig/gcc/Makefile.in 2012-03-04 09:22:05.000000000 -0800
++++ gcc-4_6-branch/gcc/Makefile.in 2012-03-04 09:24:54.418624482 -0800
+@@ -2179,7 +2179,7 @@
incpath.o: incpath.c incpath.h $(CONFIG_H) $(SYSTEM_H) $(CPPLIB_H) \
intl.h prefix.h coretypes.h $(TM_H) cppdefault.h $(TARGET_H) \
@@ -162,11 +162,11 @@ Index: gcc-4.6.0/gcc/Makefile.in
prefix.o: prefix.c $(CONFIG_H) $(SYSTEM_H) coretypes.h $(TM_H) prefix.h \
Makefile $(BASEVER)
-Index: gcc-4.6.0/gcc/configure
+Index: gcc-4_6-branch/gcc/configure
===================================================================
---- gcc-4.6.0.orig/gcc/configure
-+++ gcc-4.6.0/gcc/configure
-@@ -912,6 +912,7 @@ with_system_zlib
+--- gcc-4_6-branch.orig/gcc/configure 2012-03-04 09:22:07.000000000 -0800
++++ gcc-4_6-branch/gcc/configure 2012-03-04 09:25:31.502626277 -0800
+@@ -912,6 +912,7 @@
enable_maintainer_mode
enable_version_specific_runtime_libs
with_slibdir
@@ -174,7 +174,7 @@ Index: gcc-4.6.0/gcc/configure
enable_plugin
enable_libquadmath_support
'
-@@ -1623,6 +1624,8 @@ Optional Features:
+@@ -1623,6 +1624,8 @@
--enable-version-specific-runtime-libs
specify that runtime libraries should be
installed in a compiler-specific directory
@@ -183,25 +183,25 @@ Index: gcc-4.6.0/gcc/configure
--enable-plugin enable plugin support
--disable-libquadmath-support
disable libquadmath support for Fortran
-@@ -17508,7 +17511,7 @@ else
+@@ -17498,7 +17501,7 @@
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 17511 "configure"
-+#line 17514 "configure"
+-#line 17501 "configure"
++#line 17504 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
-@@ -17614,7 +17617,7 @@ else
+@@ -17604,7 +17607,7 @@
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 17617 "configure"
-+#line 17620 "configure"
+-#line 17607 "configure"
++#line 17610 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
-@@ -26127,6 +26130,19 @@ fi
+@@ -26125,6 +26128,19 @@