summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/gcc/gcc-cross_4.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc-cross_4.7.bb')
-rw-r--r--meta/recipes-devtools/gcc/gcc-cross_4.7.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-cross_4.7.bb b/meta/recipes-devtools/gcc/gcc-cross_4.7.bb
index 75679d1b0..d60523513 100644
--- a/meta/recipes-devtools/gcc/gcc-cross_4.7.bb
+++ b/meta/recipes-devtools/gcc/gcc-cross_4.7.bb
@@ -5,4 +5,10 @@ EXTRA_OECONF += "--disable-libunwind-exceptions \
--with-mpfr=${STAGING_DIR_NATIVE}${prefix_native} \
--with-system-zlib "
+EXTRA_OECONF_PATHS = " \
+ --with-gxx-include-dir=${STAGING_DIR_TARGET}${target_includedir}/c++ \
+ --with-sysroot=${STAGING_DIR_TARGET} \
+ --with-build-sysroot=${STAGING_DIR_TARGET}"
+
+
ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}"