summaryrefslogtreecommitdiff
path: root/meta/recipes-graphics/mesa/qemugl
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/qemugl')
-rw-r--r--meta/recipes-graphics/mesa/qemugl/remove-x11r6-lib-dir.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/qemugl/remove-x11r6-lib-dir.patch b/meta/recipes-graphics/mesa/qemugl/remove-x11r6-lib-dir.patch
new file mode 100644
index 000000000..d14ce891c
--- /dev/null
+++ b/meta/recipes-graphics/mesa/qemugl/remove-x11r6-lib-dir.patch
@@ -0,0 +1,19 @@
+Remove X11R6 lib directory
+
+"-L/usr/X11R6/lib" is obsolate in poky. Poky currently use Xserver from X.org (X11R7.x), which puts lib in standard /usr/lib, so no need to specify the extra -L/usr/X11R6/lib. Meanwhile, the -L/usr/X11R6/lib will cause warning: library search path "/usr/X11R6/lib" is unsafe for cross-compilation. so better to remove it.
+
+Signed-off-by: Yu Ke <ke.yu@intel.com>
+
+diff --git a/Makefile b/Makefile
+index 9e5a8ea..f3a082a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,7 +3,7 @@ GL_CFLAGS := -Wall -g -O2 -fno-strict-aliasing
+ all: libGL.so.1.2
+
+ libGL.so.1.2: client_stub.c opengl_client.c glgetv_cst.h opengl_func.h opengl_utils.h opengl_client_xfonts.c mesa_gl.h mesa_glext.h mesa_glx.h mesa_glxext.h
+- $(CC) -fPIC $(GL_CFLAGS) opengl_client.c -shared -o libGL.so.1.2 -lX11 -lXfixes -lm -L$(D)/usr/X11R6/lib -lpthread -I.
++ $(CC) -fPIC $(GL_CFLAGS) opengl_client.c -shared -o libGL.so.1.2 -lX11 -lXfixes -lm -lpthread -I.
+
+ opengl_func.h: gl_func.h
+