summaryrefslogtreecommitdiff
path: root/meta/recipes-kernel/module-init-tools
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/module-init-tools')
-rw-r--r--meta/recipes-kernel/module-init-tools/files/PD.patch8
-rw-r--r--meta/recipes-kernel/module-init-tools/files/disable_man.patch25
-rw-r--r--meta/recipes-kernel/module-init-tools/files/grab_module_memset.patch21
-rwxr-xr-xmeta/recipes-kernel/module-init-tools/files/modutils.sh36
-rw-r--r--meta/recipes-kernel/module-init-tools/files/modutils_extension.patch25
-rw-r--r--meta/recipes-kernel/module-init-tools/module-init-tools-cross_3.16.bb10
-rw-r--r--meta/recipes-kernel/module-init-tools/module-init-tools.inc24
-rw-r--r--meta/recipes-kernel/module-init-tools/module-init-tools_3.16.bb42
-rw-r--r--meta/recipes-kernel/module-init-tools/modutils-initscripts.bb20
9 files changed, 0 insertions, 211 deletions
diff --git a/meta/recipes-kernel/module-init-tools/files/PD.patch b/meta/recipes-kernel/module-init-tools/files/PD.patch
deleted file mode 100644
index 21ac49cbd..000000000
--- a/meta/recipes-kernel/module-init-tools/files/PD.patch
+++ /dev/null
@@ -1,8 +0,0 @@
-Upstream-Status: Inappropriate [licensing]
-
-Index: modutils-initscripts-1.0/LICENSE
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ modutils-initscripts-1.0/LICENSE 2010-12-06 14:26:03.570339002 -0800
-@@ -0,0 +1 @@
-+Public Domain
diff --git a/meta/recipes-kernel/module-init-tools/files/disable_man.patch b/meta/recipes-kernel/module-init-tools/files/disable_man.patch
deleted file mode 100644
index 95ad9cf92..000000000
--- a/meta/recipes-kernel/module-init-tools/files/disable_man.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-# disable man page build
-#
-# by Kevin Tian <kevin.tian@intel.com>, 2010-07-21
-
-Upstream-Status: Inappropriate [disable feature]
-
-diff --git a/Makefile.am b/Makefile.am
-index 6f83c12..32972a8 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -39,13 +39,12 @@ modindex_LDADD = $(LDADD) libmodtools.a
- MAN5 = modprobe.conf.5 modules.dep.5 depmod.conf.5 modprobe.d.5
- MAN8 = depmod.8 insmod.8 lsmod.8 rmmod.8 modprobe.8 modinfo.8
- SGML = $(addprefix doc/, $(MAN5:%.5=%.sgml) $(MAN8:%.8=%.sgml))
--dist_man_MANS = $(MAN5) $(MAN8)
- # If they haven't overridden mandir, fix it (never /man!)
- mandir =$(shell if [ @mandir@ = $(prefix)/man ]; then if [ $(prefix) = / ]; then echo /usr/share/man; else echo $(prefix)/share/man; fi; else echo @mandir@; fi)
-
- TESTSUITE := $(shell test -e @srcdir@/tests && find @srcdir@/tests -type f ! -name '*~')
-
--EXTRA_DIST = generate-modprobe.conf FAQ CODING stress_modules.sh install-with-care $(SGML) $(man_MANS) $(TESTSUITE)
-+EXTRA_DIST = generate-modprobe.conf FAQ CODING stress_modules.sh install-with-care
-
- sbin_PROGRAMS = insmod modprobe rmmod depmod modinfo
- if BUILD_STATIC_UTILS
diff --git a/meta/recipes-kernel/module-init-tools/files/grab_module_memset.patch b/meta/recipes-kernel/module-init-tools/files/grab_module_memset.patch
deleted file mode 100644
index 31dc0e96b..000000000
--- a/meta/recipes-kernel/module-init-tools/files/grab_module_memset.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-# this patch is from Mark Hatle <mark.hatle@windriver.com>, who ran into
-# a random segfault using the latest module-init-tools (3.12) and finally
-# trace back to depmod.c:grab_module, which appears that the new malloc(...)
-# setups up things, but never clears the memory that was just allocated.
-#
-# Kevin Tian <kevin.tian@intel.com>, 2010-08-06
-
-Upstream-Status: Pending
-
-diff --git a/depmod.c b/depmod.c
-index 647e5e6..46e03e0 100644
---- a/depmod.c
-+++ b/depmod.c
-@@ -313,6 +313,7 @@ static struct module *grab_module(const char *dirname, const char *filename)
-
- new = NOFAIL(malloc(sizeof(*new)
- + strlen(dirname?:"") + 1 + strlen(filename) + 1));
-+ memset(new, 0x00, sizeof(*new) + strlen(dirname?:"") + 1 + strlen(filename) + 1);
- if (dirname)
- sprintf(new->pathname, "%s/%s", dirname, filename);
- else
diff --git a/meta/recipes-kernel/module-init-tools/files/modutils.sh b/meta/recipes-kernel/module-init-tools/files/modutils.sh
deleted file mode 100755
index 9049bbb8a..000000000
--- a/meta/recipes-kernel/module-init-tools/files/modutils.sh
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/bin/sh
-### BEGIN INIT INFO
-# Provides: module-init-tools
-# Required-Start:
-# Required-Stop:
-# Should-Start: checkroot
-# Should-stop:
-# Default-Start: S
-# Default-Stop:
-# Short-Description: Process /etc/modules.
-# Description: Load the modules listed in /etc/modules.
-### END INIT INFO
-
-LOAD_MODULE=modprobe
-[ -f /proc/modules ] || exit 0
-[ -f /etc/modules ] || exit 0
-[ -e /sbin/modprobe ] || LOAD_MODULE=insmod
-
-if [ ! -f /lib/modules/`uname -r`/modules.dep ]; then
- [ "$VERBOSE" != no ] && echo "Calculating module dependencies ..."
- depmod -Ae
-fi
-
-[ "$VERBOSE" != no ] && echo -n "Loading modules: "
-(cat /etc/modules; echo; ) |
-while read module args
-do
- case "$module" in
- \#*|"") continue ;;
- esac
- [ "$VERBOSE" != no ] && echo -n "$module "
- eval "$LOAD_MODULE $module $args >/dev/null 2>&1"
-done
-[ "$VERBOSE" != no ] && echo
-
-exit 0
diff --git a/meta/recipes-kernel/module-init-tools/files/modutils_extension.patch b/meta/recipes-kernel/module-init-tools/files/modutils_extension.patch
deleted file mode 100644
index 4a6e0fedc..000000000
--- a/meta/recipes-kernel/module-init-tools/files/modutils_extension.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-# poky uses new name to differentiate from modutils, so reflect this new name in source
-#
-# comment added by Kevin Tian <kevin.tian@intel.com>, 2010-07-21
-
-Upstream-Status: Inappropriate [embedded specific]
-
---- module-init-tools-3.0-pre10.orig/generate-modprobe.conf
-+++ module-init-tools-3.0-pre10/generate-modprobe.conf
-@@ -45,12 +45,12 @@
- cp $TESTING_MODPROBE_CONF $MODPROBECONF
- elif [ "$STDIN" = "1" ]; then
- cat > $MODPROBECONF
--elif [ -x /sbin/modprobe.old ]; then
-+elif [ -x /sbin/modprobe.24 ]; then
- # In sbin.
-- /sbin/modprobe.old -c > $MODPROBECONF || modprobe_abort
--elif modprobe.old -c >/dev/null 2>&1; then
-+ /sbin/modprobe.24 -c > $MODPROBECONF || modprobe_abort
-+elif modprobe.24 -c >/dev/null 2>&1; then
- # Somewhere in path.
-- modprobe.old -c > $MODPROBECONF || modprobe_abort
-+ modprobe.24 -c > $MODPROBECONF || modprobe_abort
- elif /sbin/modprobe -V 2>/dev/null | grep -q 'modprobe version'; then
- # Running /sbin/modprobe gives old version.
- /sbin/modprobe -c > $MODPROBECONF || modprobe_abort
diff --git a/meta/recipes-kernel/module-init-tools/module-init-tools-cross_3.16.bb b/meta/recipes-kernel/module-init-tools/module-init-tools-cross_3.16.bb
deleted file mode 100644
index dee163da4..000000000
--- a/meta/recipes-kernel/module-init-tools/module-init-tools-cross_3.16.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-require module-init-tools.inc
-PR = "r0"
-inherit cross
-PROVIDES += "virtual/${TARGET_PREFIX}depmod"
-RDEPENDS_${PN} = ""
-
-SRC_URI[md5sum] = "bc44832c6e41707b8447e2847d2019f5"
-SRC_URI[sha256sum] = "e1f2cdcae64a8effc25e545a5e0bdaf312f816ebbcd0916e4e87450755fab64b"
-
-EXTRA_OECONF_append = " --program-prefix=${TARGET_PREFIX} --disable-static-utils"
diff --git a/meta/recipes-kernel/module-init-tools/module-init-tools.inc b/meta/recipes-kernel/module-init-tools/module-init-tools.inc
deleted file mode 100644
index c290c4f7f..000000000
--- a/meta/recipes-kernel/module-init-tools/module-init-tools.inc
+++ /dev/null
@@ -1,24 +0,0 @@
-SUMMARY = "Kernel Module Utilities"
-DESCRIPTION = "This package contains a set of programs for loading, inserting, and removing kernel modules for Linux (versions 2.5.48 and above). It serves the same function that the modutils package serves for Linux 2.4"
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
- file://lsmod.c;md5=743c873ec42632d2ce37d3c440f366dd"
-SECTION = "base"
-
-PACKAGES =+ "module-init-tools-insmod-static module-init-tools-depmod"
-RDEPENDS_${PN} += "module-init-tools-depmod"
-
-FILES_module-init-tools-depmod = "${sbindir}/depmod.26"
-FILES_module-init-tools-insmod-static = "${sbindir}/insmod.static"
-
-SRC_URI = "${KERNELORG_MIRROR}/linux/utils/kernel/module-init-tools/module-init-tools-${PV}.tar.bz2 \
- file://modutils_extension.patch \
- file://disable_man.patch \
- file://grab_module_memset.patch"
-
-inherit autotools
-
-# module-init-tools uses AX_ENABLE_BUILDDIR to move rest of configuration steps
-# into a subdir. However this macro is not quite cross friendly. Instead of
-# mangling that macro, a easier way is to take the disable option
-EXTRA_OECONF = "--disable-builddir"
diff --git a/meta/recipes-kernel/module-init-tools/module-init-tools_3.16.bb b/meta/recipes-kernel/module-init-tools/module-init-tools_3.16.bb
deleted file mode 100644
index 0248b464c..000000000
--- a/meta/recipes-kernel/module-init-tools/module-init-tools_3.16.bb
+++ /dev/null
@@ -1,42 +0,0 @@
-require module-init-tools.inc
-PR = "r0"
-
-# autotools set prefix to /usr, however we want them in /bin and /sbin
-bindir = "/bin"
-sbindir = "/sbin"
-
-do_install() {
- autotools_do_install
- for f in bin/lsmod sbin/insmod sbin/rmmod sbin/modprobe sbin/modinfo sbin/depmod; do
- mv ${D}/$f ${D}/$f.26
- done
-}
-
-pkg_postinst_module-init-tools() {
- for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/modinfo; do
- bn=`basename $f`
- update-alternatives --install /$f $bn /$f.26 60
- done
- update-alternatives --install /bin/lsmod bin-lsmod /bin/lsmod.26 60
- update-alternatives --install /sbin/lsmod lsmod /bin/lsmod.26 60
-}
-
-pkg_prerm_module-init-tools() {
- for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/modinfo; do
- bn=`basename $f`
- update-alternatives --remove $bn /$f.26
- done
- update-alternatives --remove bin-lsmod /bin/lsmod.26
- update-alternatives --remove lsmod /bin/lsmod.26
-}
-
-pkg_postinst_module-init-tools-depmod() {
- update-alternatives --install /sbin/depmod depmod /sbin/depmod.26 60
-}
-
-pkg_prerm_module-init-tools-depmod() {
- update-alternatives --remove depmod /sbin/depmod.26
-}
-
-SRC_URI[md5sum] = "bc44832c6e41707b8447e2847d2019f5"
-SRC_URI[sha256sum] = "e1f2cdcae64a8effc25e545a5e0bdaf312f816ebbcd0916e4e87450755fab64b"
diff --git a/meta/recipes-kernel/module-init-tools/modutils-initscripts.bb b/meta/recipes-kernel/module-init-tools/modutils-initscripts.bb
deleted file mode 100644
index 89d38cff4..000000000
--- a/meta/recipes-kernel/module-init-tools/modutils-initscripts.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-SECTION = "base"
-DESCRIPTION = "modutils configuration files"
-LICENSE = "PD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=7bf87fc37976e93ec66ad84fac58c098"
-SRC_URI = "file://modutils.sh \
- file://PD.patch"
-PR = "r6"
-
-INITSCRIPT_NAME = "modutils.sh"
-INITSCRIPT_PARAMS = "start 4 S ."
-
-inherit update-rc.d
-
-do_compile () {
-}
-
-do_install () {
- install -d ${D}${sysconfdir}/init.d/
- install -m 0755 ${WORKDIR}/modutils.sh ${D}${sysconfdir}/init.d/
-}