summaryrefslogtreecommitdiff
path: root/meta/recipes-kernel/modutils/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/modutils/files')
-rw-r--r--meta/recipes-kernel/modutils/files/armeb.patch16
-rw-r--r--meta/recipes-kernel/modutils/files/configure.patch34
-rw-r--r--meta/recipes-kernel/modutils/files/gcc4.patch93
-rw-r--r--meta/recipes-kernel/modutils/files/lex.l.diff35
-rw-r--r--meta/recipes-kernel/modutils/files/modules0
-rw-r--r--meta/recipes-kernel/modutils/files/modules.conf0
-rw-r--r--meta/recipes-kernel/modutils/files/modutils-notest.patch16
-rw-r--r--meta/recipes-kernel/modutils/files/program_prefix.patch71
8 files changed, 0 insertions, 265 deletions
diff --git a/meta/recipes-kernel/modutils/files/armeb.patch b/meta/recipes-kernel/modutils/files/armeb.patch
deleted file mode 100644
index 319855342..000000000
--- a/meta/recipes-kernel/modutils/files/armeb.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Upstream-Status: Pending
-
---- modutils-2.4.27/include/elf_arm.h.orig 2004-09-21 18:37:00.000000000 -0400
-+++ modutils-2.4.27/include/elf_arm.h 2004-09-21 18:38:18.000000000 -0400
-@@ -1,7 +1,11 @@
- /* Machine-specific elf macros for ARM. */
-
- #define ELFCLASSM ELFCLASS32
-+#ifdef __ARMEB__
-+#define ELFDATAM ELFDATA2MSB
-+#else
- #define ELFDATAM ELFDATA2LSB
-+#endif
-
- #define MATCH_MACHINE(x) (x == EM_ARM)
-
diff --git a/meta/recipes-kernel/modutils/files/configure.patch b/meta/recipes-kernel/modutils/files/configure.patch
deleted file mode 100644
index 63e80d719..000000000
--- a/meta/recipes-kernel/modutils/files/configure.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Upstream-Status: Pending
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- modutils-2.4.25/./configure.in~configure
-+++ modutils-2.4.25/./configure.in
-@@ -1,4 +1,5 @@
--AC_INIT(insmod/insmod.c)
-+AC_INIT
-+AC_CONFIG_SRCDIR([insmod/insmod.c])
- AC_PREFIX_DEFAULT(/usr)
-
- # Canonical system uses CC_FOR_BUILD while Linux may use BUILDCC
-@@ -15,7 +16,7 @@
- BUILDCC="$CC_FOR_BUILD"
- export CC_FOR_BUILD
-
--AC_CANONICAL_SYSTEM
-+AC_CANONICAL_TARGET([])
-
- # Handle target_cpu for compatibility.
- if test "$host_cpu" != "$target_cpu"; then
-@@ -350,6 +351,7 @@
- fi
- fi
-
--AC_OUTPUT(Makefile Makefile.common depmod/Makefile genksyms/Makefile
-+AC_CONFIG_FILES([Makefile Makefile.common depmod/Makefile genksyms/Makefile
- insmod/Makefile $kerneld_Makefiles obj/Makefile util/Makefile
-- man/Makefile)
-+ man/Makefile])
-+AC_OUTPUT
diff --git a/meta/recipes-kernel/modutils/files/gcc4.patch b/meta/recipes-kernel/modutils/files/gcc4.patch
deleted file mode 100644
index 4507b0338..000000000
--- a/meta/recipes-kernel/modutils/files/gcc4.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-Upstream-Status: Pending
-
-Index: modutils-2.4.27/depmod/depmod.c
-===================================================================
---- modutils-2.4.27.orig/depmod/depmod.c
-+++ modutils-2.4.27/depmod/depmod.c
-@@ -1133,7 +1133,7 @@ static int addksyms(char *file_syms)
-
- for (ksym = ksyms; so_far < nksyms; ++so_far, ksym++) {
- if (strncmp((char *)ksym->name, "GPLONLY_", 8) == 0)
-- ((char *)ksym->name) += 8;
-+ ksym->name += 8;
- assert(n_syms < MAX_MAP_SYM);
- symtab[n_syms++] = addsym((char *)ksym->name, mod, SYM_DEFINED, 0);
- }
-Index: modutils-2.4.27/genksyms/genksyms.c
-===================================================================
---- modutils-2.4.27.orig/genksyms/genksyms.c
-+++ modutils-2.4.27/genksyms/genksyms.c
-@@ -45,7 +45,7 @@ char *cur_filename, *output_directory;
- int flag_debug, flag_dump_defs, flag_warnings;
- int checksum_version = 1, kernel_version = version(2,0,0);
-
--static int errors;
-+int errors;
- static int nsyms;
-
- static struct symbol *expansion_trail;
-Index: modutils-2.4.27/insmod/insmod.c
-===================================================================
---- modutils-2.4.27.orig/insmod/insmod.c
-+++ modutils-2.4.27/insmod/insmod.c
-@@ -275,7 +275,7 @@ static int add_symbols_from(struct obj_f
- if (strncmp((char *)s->name, "GPLONLY_", 8) == 0) {
- gplonly_seen = 1;
- if (gpl)
-- ((char *)s->name) += 8;
-+ s->name += 8;
- else
- continue;
- }
-Index: modutils-2.4.27/obj/obj_kallsyms.c
-===================================================================
---- modutils-2.4.27.orig/obj/obj_kallsyms.c
-+++ modutils-2.4.27/obj/obj_kallsyms.c
-@@ -200,7 +200,7 @@ obj_kallsyms (struct obj_file *fin, stru
-
- /* Initial contents, header + one entry per input section. No strings. */
- osec->header.sh_size = sizeof(*a_hdr) + loaded*sizeof(*a_sec);
-- a_hdr = (struct kallsyms_header *) osec->contents =
-+ a_hdr = osec->contents =
- xmalloc(osec->header.sh_size);
- memset(osec->contents, 0, osec->header.sh_size);
- a_hdr->size = sizeof(*a_hdr);
-@@ -275,7 +275,7 @@ obj_kallsyms (struct obj_file *fin, stru
- a_hdr->symbol_off +
- a_hdr->symbols*a_hdr->symbol_size +
- strings_size - strings_left;
-- a_hdr = (struct kallsyms_header *) osec->contents =
-+ a_hdr = osec->contents =
- xrealloc(a_hdr, a_hdr->total_size);
- p = (char *)a_hdr + a_hdr->symbol_off;
- memcpy(p, symbols, a_hdr->symbols*a_hdr->symbol_size);
-Index: modutils-2.4.27/obj/obj_mips.c
-===================================================================
---- modutils-2.4.27.orig/obj/obj_mips.c
-+++ modutils-2.4.27/obj/obj_mips.c
-@@ -244,7 +244,9 @@ arch_archdata (struct obj_file *f, struc
- archdata_sec->header.sh_size = 0;
- sec = obj_find_section(f, "__dbe_table");
- if (sec) {
-- ad = (struct archdata *) (archdata_sec->contents) = xmalloc(sizeof(*ad));
-+/* ad = (struct archdata *) (archdata_sec->contents) = xmalloc(sizeof(*ad));*/
-+ archdata_sec->contents = xmalloc(sizeof(*ad));
-+ ad = (struct archdata *) (archdata_sec->contents);
- memset(ad, 0, sizeof(*ad));
- archdata_sec->header.sh_size = sizeof(*ad);
- ad->__start___dbe_table = sec->header.sh_addr;
-Index: modutils-2.4.27/obj/obj_ppc.c
-===================================================================
---- modutils-2.4.27.orig/obj/obj_ppc.c
-+++ modutils-2.4.27/obj/obj_ppc.c
-@@ -255,7 +255,9 @@ arch_archdata (struct obj_file *f, struc
- archdata_sec->header.sh_size = 0;
- sec = obj_find_section(f, "__ftr_fixup");
- if (sec) {
-- ad = (struct archdata *) (archdata_sec->contents) = xmalloc(sizeof(*ad));
-+ /* ad = (struct archdata *) (archdata_sec->contents) = xmalloc(sizeof(*ad)); */
-+ archdata_sec->contents = xmalloc(sizeof(*ad));
-+ ad = (struct archdata *) (archdata_sec->contents);
- memset(ad, 0, sizeof(*ad));
- archdata_sec->header.sh_size = sizeof(*ad);
- ad->__start___ftr_fixup = sec->header.sh_addr;
diff --git a/meta/recipes-kernel/modutils/files/lex.l.diff b/meta/recipes-kernel/modutils/files/lex.l.diff
deleted file mode 100644
index b2419a481..000000000
--- a/meta/recipes-kernel/modutils/files/lex.l.diff
+++ /dev/null
@@ -1,35 +0,0 @@
-Upstream-Status: Pending
-
---- modutils-2.4.26.orig/genksyms/lex.l
-+++ modutils-2.4.26/genksyms/lex.l
-@@ -130,6 +130,7 @@
-
- static int suppress_type_lookup, dont_want_brace_phrase;
- static struct string_list *next_node;
-+ static int next_token = 0;
-
- int token, count = 0;
- struct string_list *cur_node;
-@@ -144,7 +145,12 @@
- }
-
- repeat:
-- token = yylex1();
-+ if (next_token != 0) {
-+ token = next_token;
-+ next_token = 0;
-+ }
-+ else
-+ token = yylex1();
-
- if (token == 0)
- return 0;
-@@ -425,7 +431,7 @@
- {
- /* Put back the token we just read so's we can find it again
- after registering the expression. */
-- unput(token);
-+ next_token = token;
-
- lexstate = ST_NORMAL;
- token = EXPRESSION_PHRASE;
diff --git a/meta/recipes-kernel/modutils/files/modules b/meta/recipes-kernel/modutils/files/modules
deleted file mode 100644
index e69de29bb..000000000
--- a/meta/recipes-kernel/modutils/files/modules
+++ /dev/null
diff --git a/meta/recipes-kernel/modutils/files/modules.conf b/meta/recipes-kernel/modutils/files/modules.conf
deleted file mode 100644
index e69de29bb..000000000
--- a/meta/recipes-kernel/modutils/files/modules.conf
+++ /dev/null
diff --git a/meta/recipes-kernel/modutils/files/modutils-notest.patch b/meta/recipes-kernel/modutils/files/modutils-notest.patch
deleted file mode 100644
index ab100f2dc..000000000
--- a/meta/recipes-kernel/modutils/files/modutils-notest.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-This test disables the annoying
- Note: /etc/modules.conf is more recent than /lib/modules/2.4.19-rmk6-pxa1/modules.dep
-message.
-
-Upstream-Status: Inappropriate [disable feature]
-
---- modutils-2.4.6/insmod/modprobe.c~notest Mon Feb 26 02:07:17 2001
-+++ modutils-2.4.6/insmod/modprobe.c Wed Feb 19 14:31:52 2003
-@@ -785,7 +785,6 @@
- return -1;
- }
-
--#define EXTREMELY_CAUTIOUS
- #ifdef EXTREMELY_CAUTIOUS
- if (fstat(fileno(fin), &statbuf) != 0)
- error("Could not stat %s", depfile);
diff --git a/meta/recipes-kernel/modutils/files/program_prefix.patch b/meta/recipes-kernel/modutils/files/program_prefix.patch
deleted file mode 100644
index 973705ee2..000000000
--- a/meta/recipes-kernel/modutils/files/program_prefix.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-Upstream-Status: Pending
-
---- modutils-2.4.25/Makefile.common.in Sun Nov 24 21:23:35 2002
-+++ modutils-2.4.25/Makefile.common.in Thu Jan 29 17:16:30 2004
-@@ -7,6 +7,7 @@
- mandir = @mandir@
- prefix = @prefix@
- sbindir = @sbindir@
-+transform = @program_transform_name@
-
- AR = @AR@
- ARCH = @ARCH@
---- modutils-2.4.25/configure.in Thu Jan 29 17:24:10 2004
-+++ modutils-2.4.25/configure.in Thu Jan 29 17:13:59 2004
-@@ -17,6 +17,7 @@
- export CC_FOR_BUILD
-
- AC_CANONICAL_TARGET([])
-+AC_ARG_PROGRAM
-
- # Handle target_cpu for compatibility.
- if test "$host_cpu" != "$target_cpu"; then
---- modutils-2.4.25/depmod/Makefile.in Fri Mar 28 17:54:20 2003
-+++ modutils-2.4.25/depmod/Makefile.in Thu Jan 29 17:16:41 2004
-@@ -60,7 +60,7 @@
-
- install install-bin: all
- $(MKDIR) $(DESTDIR)$(sbindir)
-- $(INSTALL) $(STRIP) depmod $(DESTDIR)$(sbindir)
-+ $(INSTALL) $(STRIP) depmod $(DESTDIR)$(sbindir)/`echo depmod | sed -e'$(transform)'`
-
- dep depend .depend: depmod.c
- $(CC) -M $(CFLAGS) $(DEFSNOARCH) $(DEFS) $^ > .depend
---- modutils-2.4.25/genksyms/Makefile.in Sun Nov 24 21:23:35 2002
-+++ modutils-2.4.25/genksyms/Makefile.in Thu Jan 29 17:17:07 2004
-@@ -62,7 +62,7 @@
-
- install install-bin: all
- $(MKDIR) $(DESTDIR)$(sbindir)
-- $(INSTALL) $(STRIP) genksyms $(DESTDIR)$(sbindir)
-+ $(INSTALL) $(STRIP) genksyms $(DESTDIR)$(sbindir)/`echo genksyms | sed -e'$(transform)'`
-
- # auto-generated dependancies are almost redundant once we add all the
- # rules to get the generated files built first.
---- modutils-2.4.25/insmod/Makefile.in Fri Mar 28 17:54:20 2003
-+++ modutils-2.4.25/insmod/Makefile.in Thu Jan 29 17:21:10 2004
-@@ -120,16 +120,19 @@
- @set -ex;\
- for i in $(TARGETS_REAL); do \
- $(MKDIR) $(DESTDIR)$(sbindir); \
-- $(INSTALL) $(STRIP) $$i $(DESTDIR)$(sbindir); done;
-+ f=`echo $$i|sed -e'$(transform)'`; \
-+ $(INSTALL) $(STRIP) $$i $(DESTDIR)$(sbindir)/$$f; done;
- set -e; \
-- for i in $(srcdir)/insmod_ksymoops_clean $(srcdir)/kernelversion; do \
-+ for i in insmod_ksymoops_clean kernelversion; do \
- $(MKDIR) $(DESTDIR)$(sbindir); \
-- $(INSTALL) $$i $(DESTDIR)$(sbindir); done;
-+ f=`echo $$i|sed -e'$(transform)'`; \
-+ $(INSTALL) $$i $(DESTDIR)$(sbindir)/$$f; done;
- set -e; \
- for i in $(COMB); do \
-- ln -sf insmod $(DESTDIR)$(sbindir)/$$i; \
-+ f=`echo $$i|sed -e'$(transform)'`; \
-+ ln -sf `echo insmod|sed -e'$(transform)'` $(DESTDIR)$(sbindir)/$$f; \
- (test "$(insmod_static)" = yes && \
-- ln -sf insmod.static $(DESTDIR)$(sbindir)/$$i.static) || true; \
-+ ln -sf `echo insmod.static|sed -e'$(transform)'` $(DESTDIR)$(sbindir)/$$f.static) || true; \
- done
-
- clean: