summaryrefslogtreecommitdiff
path: root/meta/recipes-kernel/modutils
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/modutils')
-rw-r--r--meta/recipes-kernel/modutils/files/PD.patch8
-rwxr-xr-xmeta/recipes-kernel/modutils/files/modutils.sh36
-rw-r--r--meta/recipes-kernel/modutils/modutils-initscripts.bb20
3 files changed, 0 insertions, 64 deletions
diff --git a/meta/recipes-kernel/modutils/files/PD.patch b/meta/recipes-kernel/modutils/files/PD.patch
deleted file mode 100644
index 21ac49cbd..000000000
--- a/meta/recipes-kernel/modutils/files/PD.patch
+++ /dev/null
@@ -1,8 +0,0 @@
-Upstream-Status: Inappropriate [licensing]
-
-Index: modutils-initscripts-1.0/LICENSE
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ modutils-initscripts-1.0/LICENSE 2010-12-06 14:26:03.570339002 -0800
-@@ -0,0 +1 @@
-+Public Domain
diff --git a/meta/recipes-kernel/modutils/files/modutils.sh b/meta/recipes-kernel/modutils/files/modutils.sh
deleted file mode 100755
index 9049bbb8a..000000000
--- a/meta/recipes-kernel/modutils/files/modutils.sh
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/bin/sh
-### BEGIN INIT INFO
-# Provides: module-init-tools
-# Required-Start:
-# Required-Stop:
-# Should-Start: checkroot
-# Should-stop:
-# Default-Start: S
-# Default-Stop:
-# Short-Description: Process /etc/modules.
-# Description: Load the modules listed in /etc/modules.
-### END INIT INFO
-
-LOAD_MODULE=modprobe
-[ -f /proc/modules ] || exit 0
-[ -f /etc/modules ] || exit 0
-[ -e /sbin/modprobe ] || LOAD_MODULE=insmod
-
-if [ ! -f /lib/modules/`uname -r`/modules.dep ]; then
- [ "$VERBOSE" != no ] && echo "Calculating module dependencies ..."
- depmod -Ae
-fi
-
-[ "$VERBOSE" != no ] && echo -n "Loading modules: "
-(cat /etc/modules; echo; ) |
-while read module args
-do
- case "$module" in
- \#*|"") continue ;;
- esac
- [ "$VERBOSE" != no ] && echo -n "$module "
- eval "$LOAD_MODULE $module $args >/dev/null 2>&1"
-done
-[ "$VERBOSE" != no ] && echo
-
-exit 0
diff --git a/meta/recipes-kernel/modutils/modutils-initscripts.bb b/meta/recipes-kernel/modutils/modutils-initscripts.bb
deleted file mode 100644
index 89d38cff4..000000000
--- a/meta/recipes-kernel/modutils/modutils-initscripts.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-SECTION = "base"
-DESCRIPTION = "modutils configuration files"
-LICENSE = "PD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=7bf87fc37976e93ec66ad84fac58c098"
-SRC_URI = "file://modutils.sh \
- file://PD.patch"
-PR = "r6"
-
-INITSCRIPT_NAME = "modutils.sh"
-INITSCRIPT_PARAMS = "start 4 S ."
-
-inherit update-rc.d
-
-do_compile () {
-}
-
-do_install () {
- install -d ${D}${sysconfdir}/init.d/
- install -m 0755 ${WORKDIR}/modutils.sh ${D}${sysconfdir}/init.d/
-}