summaryrefslogtreecommitdiff
path: root/meta/recipes-multimedia/alsa/alsa-utils-1.0.24.2/ncursesfix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/alsa/alsa-utils-1.0.24.2/ncursesfix.patch')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-utils-1.0.24.2/ncursesfix.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-utils-1.0.24.2/ncursesfix.patch b/meta/recipes-multimedia/alsa/alsa-utils-1.0.24.2/ncursesfix.patch
new file mode 100644
index 000000000..9936dedf1
--- /dev/null
+++ b/meta/recipes-multimedia/alsa/alsa-utils-1.0.24.2/ncursesfix.patch
@@ -0,0 +1,44 @@
+Rebase the patch to fit 1.0.24.2
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+
+diff -ruN alsa-utils-1.0.24.2-orig//configure.in alsa-utils-1.0.24.2/configure.in
+--- alsa-utils-1.0.24.2-orig//configure.in 2011-04-13 13:51:20.337665010 +0800
++++ alsa-utils-1.0.24.2/configure.in 2011-04-13 13:51:54.437664986 +0800
+@@ -127,34 +127,16 @@
+ NCURSESLIBSUFFIX=""
+ CURSES_NLS="no"
+ if test "$curseslib" = "ncursesw" -o \( "$curseslib" = "auto" -a "$USE_NLS" = "yes" \); then
+- AC_CHECK_PROG([ncursesw5_config], [ncursesw5-config], [yes])
+- if test "$ncursesw5_config" = "yes"; then
+- CURSESINC="<ncurses.h>"
+- CURSESLIB=`ncursesw5-config --libs`
+- CURSESLIBDIR=`ncursesw5-config --libdir`
+- CURSES_CFLAGS=`ncursesw5-config --cflags`
+- curseslib="ncursesw"
+- else
+ AC_CHECK_LIB(ncursesw, initscr,
+ [ CURSESINC='<ncurses.h>'; CURSESLIB='-lncursesw'; curseslib="ncursesw"])
+- fi
+ if test -n "$CURSESINC"; then
+ NCURSESLIBSUFFIX="w"
+ CURSES_NLS="yes"
+ fi
+ fi
+ if test "$curseslib" = "ncurses" -o "$curseslib" = "auto"; then
+- AC_CHECK_PROG([ncurses5_config], [ncurses5-config], [yes])
+- if test "$ncurses5_config" = "yes"; then
+- CURSESINC="<ncurses.h>"
+- CURSESLIB=`ncurses5-config --libs`
+- CURSESLIBDIR=`ncurses5-config --libdir`
+- CURSES_CFLAGS=`ncurses5-config --cflags`
+- curseslib="ncurses"
+- else
+ AC_CHECK_LIB(ncurses, initscr,
+ [ CURSESINC='<ncurses.h>'; CURSESLIB='-lncurses'; curseslib="ncurses"])
+- fi
+ fi
+ if test "$curseslib" = "curses" -o "$curseslib" = "auto"; then
+ AC_CHECK_LIB(curses, initscr,