summaryrefslogtreecommitdiff
path: root/meta/recipes-multimedia/gstreamer/gst-ffmpeg-0.10.13
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gst-ffmpeg-0.10.13')
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-ffmpeg-0.10.13/configure-fix.patch20
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-ffmpeg-0.10.13/lower-rank.diff16
2 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gst-ffmpeg-0.10.13/configure-fix.patch b/meta/recipes-multimedia/gstreamer/gst-ffmpeg-0.10.13/configure-fix.patch
new file mode 100644
index 000000000..81029ca6e
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gst-ffmpeg-0.10.13/configure-fix.patch
@@ -0,0 +1,20 @@
+Disable yasm for libav when --disable-yasm
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Shane Wang <shane.wang@intel.com>
+
+diff -r f2f8f74c6e30 configure.ac
+--- a/configure.ac Thu Dec 22 23:56:09 2011 +0800
++++ b/configure.ac Thu Dec 22 23:57:37 2011 +0800
+@@ -325,6 +325,10 @@
+ --enable-gpl"
+ fi
+
++ if test "x$disable_yasm" != "xyes"; then
++ embffmpeg_configure_args="$embffmpeg_configure_args --disable-yasm"
++ fi
++
+ # if we are cross-compiling, tell ffmpeg so
+ target_os=`echo $host_os | sed 's/-gnu//'`
+ if test "x$cross_compiling" = xyes; then
diff --git a/meta/recipes-multimedia/gstreamer/gst-ffmpeg-0.10.13/lower-rank.diff b/meta/recipes-multimedia/gstreamer/gst-ffmpeg-0.10.13/lower-rank.diff
new file mode 100644
index 000000000..5f08afe59
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gst-ffmpeg-0.10.13/lower-rank.diff
@@ -0,0 +1,16 @@
+Lower the rank of ffmpeg plugin so codecs that hook into accelerated pieces (e.g. dsp or hw engines) can get picked over this
+Derived from OE by Dongxiao Xu <dongxiao.xu@intel.com>
+
+Upstream-Status: Inappropriate [embedded specific]
+
+--- /tmp/gstffmpegdec.c 2009-03-05 09:31:15.000000000 +0100
++++ gst-ffmpeg-0.10.6/ext/ffmpeg/gstffmpegdec.c 2009-03-05 09:33:09.000000000 +0100
+@@ -2588,7 +2588,7 @@
+ case CODEC_ID_MSMPEG4V3:
+ case CODEC_ID_H264:
+ case CODEC_ID_COOK:
+- rank = GST_RANK_PRIMARY;
++ rank = GST_RANK_SECONDARY;
+ break;
+ case CODEC_ID_DVVIDEO:
+ /* we have a good dv decoder, fast on both ppc as well as x86. they say