summaryrefslogtreecommitdiff
path: root/meta/recipes-support/gnutls/gnutls-2.10.4
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/gnutls/gnutls-2.10.4')
-rw-r--r--meta/recipes-support/gnutls/gnutls-2.10.4/configure-fix.patch66
-rw-r--r--meta/recipes-support/gnutls/gnutls-2.10.4/gnutls-openssl.patch126
-rw-r--r--meta/recipes-support/gnutls/gnutls-2.10.4/gnutls-texinfo-euro.patch18
3 files changed, 0 insertions, 210 deletions
diff --git a/meta/recipes-support/gnutls/gnutls-2.10.4/configure-fix.patch b/meta/recipes-support/gnutls/gnutls-2.10.4/configure-fix.patch
deleted file mode 100644
index 2ce3f5567..000000000
--- a/meta/recipes-support/gnutls/gnutls-2.10.4/configure-fix.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-Upstream-Status: Inappropriate [distribution]
-
-rebased from original configure_madness.patch
-
-libtasn1 provides an .pc file in upstream,
-and a libgcrypt.pc is added in libgcrypt recipe,
-so use Requires.private for these two.
-
-against 2.8.6
-
-07/02/2010 - qhe
-
----
-diff --git a/lib/configure.ac b/lib/configure.ac
-index 80d3375..1a486f7 100644
---- a/lib/configure.ac
-+++ b/lib/configure.ac
-@@ -81,8 +81,8 @@ fi
-
- lgl_INIT
-
--LIBGNUTLS_LIBS="-L${libdir} -lgnutls $LIBS"
--LIBGNUTLS_CFLAGS="-I${includedir}"
-+LIBGNUTLS_LIBS="-lgnutls $LIBS"
-+LIBGNUTLS_CFLAGS=""
- AC_SUBST(LIBGNUTLS_LIBS)
- AC_SUBST(LIBGNUTLS_CFLAGS)
-
-diff --git a/lib/gnutls.pc.in b/lib/gnutls.pc.in
-index 3b01c17..de31469 100644
---- a/lib/gnutls.pc.in
-+++ b/lib/gnutls.pc.in
-@@ -20,6 +20,6 @@ Name: GnuTLS
- Description: Transport Security Layer implementation for the GNU system
- URL: http://www.gnu.org/software/gnutls/
- Version: @VERSION@
-+Requires.private: libgcrypt, libtasn1
- Libs: -L${libdir} -lgnutls
--Libs.private: @LIBGNUTLS_LIBS@ @LTLIBTASN1@
- Cflags: -I${includedir}
-diff --git a/libextra/configure.ac b/libextra/configure.ac
-index c08e73f..3313886 100644
---- a/libextra/configure.ac
-+++ b/libextra/configure.ac
-@@ -40,8 +40,8 @@ LIBGNUTLS_EXTRA_HOOKS
-
- xgl_INIT
-
--LIBGNUTLS_EXTRA_LIBS="-L${libdir} -lgnutls-extra $LZO_LIBS $LIBGNUTLS_LIBS"
--LIBGNUTLS_EXTRA_CFLAGS="-I${includedir}"
-+LIBGNUTLS_EXTRA_LIBS="-lgnutls-extra $LZO_LIBS $LIBGNUTLS_LIBS"
-+LIBGNUTLS_EXTRA_CFLAGS=""
- AC_SUBST(LIBGNUTLS_EXTRA_LIBS)
- AC_SUBST(LIBGNUTLS_EXTRA_CFLAGS)
-
-diff --git a/libextra/gnutls-extra.pc.in b/libextra/gnutls-extra.pc.in
-index 9e7b8f6..e228ec9 100644
---- a/libextra/gnutls-extra.pc.in
-+++ b/libextra/gnutls-extra.pc.in
-@@ -21,5 +21,5 @@ URL: http://www.gnu.org/software/gnutls/
- Requires: gnutls
- Version: @VERSION@
- Libs: -L${libdir} -lgnutls-extra
--Libs.private: @LIBGNUTLS_EXTRA_LIBS@
-+Libs.private: -llzo2
- Cflags: -I${includedir}
diff --git a/meta/recipes-support/gnutls/gnutls-2.10.4/gnutls-openssl.patch b/meta/recipes-support/gnutls/gnutls-2.10.4/gnutls-openssl.patch
deleted file mode 100644
index ef7067488..000000000
--- a/meta/recipes-support/gnutls/gnutls-2.10.4/gnutls-openssl.patch
+++ /dev/null
@@ -1,126 +0,0 @@
-Upstream-Status: Backport
-
-Index: gnutls-1.6.0/libextra/gnutls_openssl.c
-===================================================================
---- gnutls-1.6.0.orig/libextra/gnutls_openssl.c 2006-08-13 22:34:09.000000000 +0200
-+++ gnutls-1.6.0/libextra/gnutls_openssl.c 2006-12-12 15:07:59.002227000 +0100
-@@ -256,12 +256,17 @@
- ssl->rfd = (gnutls_transport_ptr_t) - 1;
- ssl->wfd = (gnutls_transport_ptr_t) - 1;
-
-+ ssl->ssl_peek_buffer = NULL;
-+ ssl->ssl_peek_buffer_size = ssl->ssl_peek_avail = 0;
-+
- return ssl;
- }
-
- void
- SSL_free (SSL * ssl)
- {
-+ if (ssl->ssl_peek_buffer)
-+ free(ssl->ssl_peek_buffer);
- gnutls_certificate_free_credentials (ssl->gnutls_cred);
- gnutls_deinit (ssl->gnutls_state);
- free (ssl);
-@@ -285,6 +290,7 @@
- SSL_set_fd (SSL * ssl, int fd)
- {
- gnutls_transport_set_ptr (ssl->gnutls_state, GNUTLS_INT_TO_POINTER (fd));
-+ ssl->rfd = ssl->wfd = fd;
- return 1;
- }
-
-@@ -310,6 +316,17 @@
- return 1;
- }
-
-+int SSL_get_rfd(SSL *ssl)
-+{
-+ return ssl->rfd;
-+}
-+
-+int SSL_get_wfd(SSL *ssl)
-+{
-+ return ssl->wfd;
-+}
-+
-+
- void
- SSL_set_bio (SSL * ssl, BIO * rbio, BIO * wbio)
- {
-@@ -325,6 +342,8 @@
- int
- SSL_pending (SSL * ssl)
- {
-+ if (ssl->ssl_peek_avail)
-+ return ssl->ssl_peek_avail;
- return gnutls_record_check_pending (ssl->gnutls_state);
- }
-
-@@ -480,11 +499,50 @@
- return 1;
- }
-
-+int SSL_peek(SSL *ssl, void *buf, int len)
-+{
-+ if (len > ssl->ssl_peek_buffer_size) {
-+ ssl->ssl_peek_buffer = realloc (ssl->ssl_peek_buffer, len);
-+ ssl->ssl_peek_buffer_size = len;
-+ }
-+
-+ if (ssl->ssl_peek_avail == 0) {
-+
-+ int ret;
-+
-+ ret = gnutls_record_recv(ssl->gnutls_state, ssl->ssl_peek_buffer, len);
-+ ssl->last_error = ret;
-+
-+ if (ret > 0)
-+ ssl->ssl_peek_avail += ret;
-+ }
-+
-+ if (len > ssl->ssl_peek_avail)
-+ len = ssl->ssl_peek_avail;
-+
-+ memcpy (buf, ssl->ssl_peek_buffer, len);
-+
-+ return len;
-+}
-+
- int
- SSL_read (SSL * ssl, void *buf, int len)
- {
- int ret;
-
-+ if (ssl->ssl_peek_avail) {
-+ int n = (ssl->ssl_peek_avail > len) ? len : ssl->ssl_peek_avail;
-+
-+ memcpy (buf, ssl->ssl_peek_buffer, n);
-+
-+ if (ssl->ssl_peek_avail > n)
-+ memmove (ssl->ssl_peek_buffer, ssl->ssl_peek_buffer + n, ssl->ssl_peek_avail - n);
-+
-+ ssl->ssl_peek_avail -= n;
-+
-+ return n;
-+ }
-+
- ret = gnutls_record_recv (ssl->gnutls_state, buf, len);
- ssl->last_error = ret;
-
-Index: gnutls-1.6.0/includes/gnutls/openssl.h
-===================================================================
---- gnutls-1.6.0.orig/libextra/includes/gnutls/openssl.h 2006-03-08 11:44:58.000000000 +0100
-+++ gnutls-1.6.0/libextra/includes/gnutls/openssl.h 2006-12-12 15:07:26.032227000 +0100
-@@ -164,6 +164,11 @@
-
- gnutls_transport_ptr_t rfd;
- gnutls_transport_ptr_t wfd;
-+
-+ char *ssl_peek_buffer;
-+ size_t ssl_peek_buffer_size;
-+ size_t ssl_peek_avail;
-+
- };
-
- #define rbio gnutls_state
diff --git a/meta/recipes-support/gnutls/gnutls-2.10.4/gnutls-texinfo-euro.patch b/meta/recipes-support/gnutls/gnutls-2.10.4/gnutls-texinfo-euro.patch
deleted file mode 100644
index 10e377407..000000000
--- a/meta/recipes-support/gnutls/gnutls-2.10.4/gnutls-texinfo-euro.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Upstream-Status: Backport
-
-The version of texinfo in Debian Sarge does not understand the @euro{} command.
-This patch replaces the @euro{} command with the word "euro".
-
---- gnutls-1.3.5/doc/gnutls.texi.orig 2006-04-26 08:06:40.918268000 +0930
-+++ gnutls-1.3.5/doc/gnutls.texi 2006-04-26 08:06:52.446515440 +0930
-@@ -11,8 +11,8 @@
- long as it is difficult enough to generate two different messages with
- the same hash algorithm output. In that case the same signature could
- be used as a proof for both messages. Nobody wants to sign an innocent
--message of donating 1 @euro{} to Greenpeace and find out that he
--donated 1.000.000 @euro{} to Bad Inc.
-+message of donating 1 euro to Greenpeace and find out that he
-+donated 1.000.000 euro to Bad Inc.
-
- For a hash algorithm to be called cryptographic the following three
- requirements must hold