summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/kf/files/gcc4.patch30
-rwxr-xr-xmeta/packages/kf/kf_0.5.4.1.bb13
2 files changed, 37 insertions, 6 deletions
diff --git a/meta/packages/kf/files/gcc4.patch b/meta/packages/kf/files/gcc4.patch
new file mode 100644
index 000000000..58727ea0e
--- /dev/null
+++ b/meta/packages/kf/files/gcc4.patch
@@ -0,0 +1,30 @@
+Index: kf-0.5.4.1/src/jispman.c
+===================================================================
+--- kf-0.5.4.1.orig/src/jispman.c 2006-12-03 15:33:47.000000000 +0100
++++ kf-0.5.4.1/src/jispman.c 2006-12-03 15:35:01.000000000 +0100
+@@ -25,12 +25,6 @@
+ #include "emoticons.h"
+ #include "kf.h"
+
+-struct _KfJispManager {
+- GHashTable *jisps; /** A hash-table of all JISP pachages managed by this object, indexed by their filename */
+- GList *patterns; /** A list of patterns */
+-};
+-
+-
+ /**
+ * \brief create a new instance of KfJispManager
+ * \return a new instance of KfJispManager
+Index: kf-0.5.4.1/src/jispman.h
+===================================================================
+--- kf-0.5.4.1.orig/src/jispman.h 2006-12-03 15:33:47.000000000 +0100
++++ kf-0.5.4.1/src/jispman.h 2006-12-03 15:34:37.000000000 +0100
+@@ -25,6 +25,8 @@
+ #include "jisp.h"
+
+ typedef struct _KfJispManager {
++ GHashTable *jisps; /** A hash-table of all JISP pachages managed by this object, indexed by their filename */
++ GList *patterns; /** A list of patterns */
+ } KfJispManager;
+
+ /**
diff --git a/meta/packages/kf/kf_0.5.4.1.bb b/meta/packages/kf/kf_0.5.4.1.bb
index cd4feffa6..f171bb8b8 100755
--- a/meta/packages/kf/kf_0.5.4.1.bb
+++ b/meta/packages/kf/kf_0.5.4.1.bb
@@ -1,15 +1,16 @@
-LICENSE = "GPL"
-DEPENDS = "libxml2 glib-2.0 gtk+ loudmouth libglade"
DESCRIPTION = "Kf is a GTK+ instant messaging client."
-PR = "r2"
+LICENSE = "GPL"
+DEPENDS = "libxml2 glib-2.0 gtk+ loudmouth"
+PR = "r3"
SRC_URI = "http://jabberstudio.2nw.net/${PN}/${PN}-${PV}.tar.gz \
file://fix-configure.patch;patch=1 \
- file://fix-desktop-file.patch;patch=0"
+ file://fix-desktop-file.patch;patch=0 \
+ file://gcc4.patch;patch=1"
inherit autotools pkgconfig
-export PKG_CONFIG="${STAGING_BINDIR_NATIVE}/pkg-config"
-
EXTRA_OECONF = "--disable-binreloc"
+export PKG_CONFIG="${STAGING_BINDIR_NATIVE}/pkg-config"
+