summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/pcmanfm/files/desktop.patch19
-rw-r--r--meta/packages/pcmanfm/files/no-warnings.patch53
-rw-r--r--meta/packages/pcmanfm/files/owl-window-menu.patch58
-rw-r--r--meta/packages/pcmanfm/pcmanfm_0.5.bb (renamed from meta/packages/pcmanfm/pcmanfm_0.3.2.2.bb)5
4 files changed, 77 insertions, 58 deletions
diff --git a/meta/packages/pcmanfm/files/desktop.patch b/meta/packages/pcmanfm/files/desktop.patch
index 1806cc2b9..93cdd8703 100644
--- a/meta/packages/pcmanfm/files/desktop.patch
+++ b/meta/packages/pcmanfm/files/desktop.patch
@@ -1,12 +1,15 @@
---- pcmanfm-0.3.2-beta/pcmanfm.desktop.in.old 2006-09-25 11:43:07.000000000 +0100
-+++ pcmanfm-0.3.2-beta/pcmanfm.desktop.in 2006-09-25 11:44:59.000000000 +0100
-@@ -1,7 +1,6 @@
+Index: pcmanfm-0.5/pcmanfm.desktop.in
+===================================================================
+--- pcmanfm-0.5.orig/pcmanfm.desktop.in
++++ pcmanfm-0.5/pcmanfm.desktop.in
+@@ -1,8 +1,7 @@
[Desktop Entry]
--Categories=Application;System;Utility;Core;GTK;
-+Categories=System;Utility;Core;GTK;
+ Version=1.0
-Encoding=UTF-8
-Name=PCMan File Manager
+-Categories=Application;System;Utility;Core;GTK;
+Name=File Manager
- Name[zh_TW]=PCMan 檔案管理程式
- Name[pl]=Przeglądarka plików z zakładkami
- Exec=pcmanfm %f
++Categories=System;Utility;Core;GTK;
+ Name[zh_TW]=檔案總管
+ Exec=pcmanfm %F
+ Icon=pcmanfm
diff --git a/meta/packages/pcmanfm/files/no-warnings.patch b/meta/packages/pcmanfm/files/no-warnings.patch
index 2e0d92bd7..b1570a0d9 100644
--- a/meta/packages/pcmanfm/files/no-warnings.patch
+++ b/meta/packages/pcmanfm/files/no-warnings.patch
@@ -1,47 +1,60 @@
---- pcmanfm-0.3.2-beta/src/main.c.old 2006-09-25 11:51:51.000000000 +0100
-+++ pcmanfm-0.3.2-beta/src/main.c 2006-09-25 11:51:55.000000000 +0100
-@@ -173,7 +173,7 @@
+Index: pcmanfm-0.5/src/main.c
+===================================================================
+--- pcmanfm-0.5.orig/src/main.c
++++ pcmanfm-0.5/src/main.c
+@@ -118,7 +118,7 @@
+
+ static void init_folder();
+ static void init_daemon_or_desktop();
+-static void check_icon_theme();
++/*static void check_icon_theme();*/
+
+ static gboolean handle_parsed_commandline_args();
+
+@@ -322,7 +322,7 @@
gtk_widget_show ( GTK_WIDGET( main_window ) );
return main_window;
}
-
+#if 0
- static void check_icon_theme()
+ void check_icon_theme()
{
GtkSettings * settings;
-@@ -212,7 +212,7 @@
+@@ -361,7 +361,7 @@
}
g_free( theme );
}
-
+#endif
- int
- main ( int argc, char *argv[] )
- {
-@@ -274,7 +274,7 @@
- vfs_file_info_set_thumbnail_size( appSettings.bigIconSize,
- appSettings.smallIconSize );
+ #ifdef _DEBUG_THREAD
+
+ G_LOCK_DEFINE(gdk_lock);
+@@ -405,7 +405,7 @@
+ vfs_file_info_set_thumbnail_size( app_settings.big_icon_size,
+ app_settings.small_icon_size );
- check_icon_theme();
+/* check_icon_theme();*/
+ folder_initialized = TRUE;
+ }
- if( appSettings.showDesktop )
- fm_desktop_init();
---- pcmanfm-0.3.2-beta/src/main-window.c.old 2006-09-25 11:47:45.000000000 +0100
-+++ pcmanfm-0.3.2-beta/src/main-window.c 2006-09-25 11:50:32.000000000 +0100
-@@ -496,6 +496,7 @@
- gtk_window_add_accel_group ( GTK_WINDOW ( main_window ), main_window->accel_group );
+Index: pcmanfm-0.5/src/main-window.c
+===================================================================
+--- pcmanfm-0.5.orig/src/main-window.c
++++ pcmanfm-0.5/src/main-window.c
+@@ -633,6 +633,7 @@
gtk_widget_grab_focus ( GTK_WIDGET( main_window->address_bar ) );
+ #ifdef SUPER_USER_CHECKS
+#if 0
/* Create warning bar for super user */
if ( geteuid() == 0 ) /* Run as super user! */
{
-@@ -510,6 +511,7 @@
- gtk_box_pack_start ( GTK_BOX ( main_window->main_vbox ),
+@@ -648,6 +649,7 @@
main_window->status_bar, FALSE, FALSE, 2 );
}
+ #endif
+#endif
/* Create client area */
- main_window->notebook = GTK_NOTEBOOK( gtk_notebook_new () );
+ main_window->notebook = gtk_notebook_new();
diff --git a/meta/packages/pcmanfm/files/owl-window-menu.patch b/meta/packages/pcmanfm/files/owl-window-menu.patch
index 7db68f4b1..d11140cf4 100644
--- a/meta/packages/pcmanfm/files/owl-window-menu.patch
+++ b/meta/packages/pcmanfm/files/owl-window-menu.patch
@@ -1,26 +1,26 @@
-Index: pcmanfm-0.3.2-beta/configure.in
+Index: pcmanfm-0.5/configure.in
===================================================================
---- pcmanfm-0.3.2-beta.orig/configure.in 2007-04-26 09:09:33.000000000 +0100
-+++ pcmanfm-0.3.2-beta/configure.in 2007-04-26 09:12:41.000000000 +0100
-@@ -15,6 +15,12 @@
- libstartup-notification-1.0"
-
- PKG_CHECK_MODULES(PACKAGE, [$pkg_modules])
+--- pcmanfm-0.5.orig/configure.in
++++ pcmanfm-0.5/configure.in
+@@ -25,6 +25,12 @@
+ gtk_modules="gtk+-2.0 >= 2.6.0 \
+ gthread-2.0"
+ PKG_CHECK_MODULES(GTK, [$gtk_modules])
+
+OWL_CFLAGS=""
+OWL_LIBS="-lowl"
-+PACKAGE_CFLAGS="$PACKAGE_CFLAGS $OWL_CFLAGS"
-+PACKAGE_LIBS="$PACKAGE_LIBS $OWL_LIBS"
++GTK_CFLAGS="$GTK_CFLAGS $OWL_CFLAGS"
++GTK_LIBS="$GTK_LIBS $OWL_LIBS"
+
- AC_SUBST(PACKAGE_CFLAGS)
- AC_SUBST(PACKAGE_LIBS)
+ AC_SUBST(GTK_CFLAGS)
+ AC_SUBST(GTK_LIBS)
-Index: pcmanfm-0.3.2-beta/src/main-window.c
+Index: pcmanfm-0.5/src/main-window.c
===================================================================
---- pcmanfm-0.3.2-beta.orig/src/main-window.c 2007-04-26 09:09:15.000000000 +0100
-+++ pcmanfm-0.3.2-beta/src/main-window.c 2007-04-26 09:10:51.000000000 +0100
-@@ -414,9 +414,7 @@
- main_window->splitter_pos = appSettings.splitterPos;
+--- pcmanfm-0.5.orig/src/main-window.c
++++ pcmanfm-0.5/src/main-window.c
+@@ -534,9 +534,7 @@
+ main_window->splitter_pos = app_settings.splitter_pos;
/* Create menu bar */
- main_window->menu_bar = gtk_menu_bar_new ();
@@ -29,23 +29,23 @@ Index: pcmanfm-0.3.2-beta/src/main-window.c
+ main_window->menu_bar = gtk_menu_new ();
main_window->accel_group = gtk_accel_group_new ();
- fm_side_pane_menu[ 0 ].ret = ( GtkWidget** ) & main_window->open_side_pane_menu;
-Index: pcmanfm-0.3.2-beta/src/main.c
+ fm_side_pane_menu[ 0 ].ret = ( GtkWidget** ) (GtkWidget*) & main_window->open_side_pane_menu;
+Index: pcmanfm-0.5/src/main.c
===================================================================
---- pcmanfm-0.3.2-beta.orig/src/main.c 2007-04-26 09:09:15.000000000 +0100
-+++ pcmanfm-0.3.2-beta/src/main.c 2007-04-26 09:21:40.000000000 +0100
-@@ -32,6 +32,8 @@
- #include "glade-support.h"
- #include "settings.h"
+--- pcmanfm-0.5.orig/src/main.c
++++ pcmanfm-0.5/src/main.c
+@@ -48,6 +48,8 @@
+
+ #include "desktop.h"
+#include "libowl/owlwindowmenu.h"
+
- static char* init_path = NULL;
-
- static int sock;
-@@ -171,6 +173,10 @@
- gtk_window_set_default_size( GTK_WINDOW( main_window ),
- appSettings.width, appSettings.height );
+ typedef enum{
+ CMD_OPEN = 1,
+ CMD_OPEN_TAB,
+@@ -320,6 +322,10 @@
+ gtk_window_maximize( GTK_WINDOW( main_window ) );
+ }
gtk_widget_show ( GTK_WIDGET( main_window ) );
+ gtk_widget_show_all (main_window->menu_bar);
+ owl_set_window_menu (GTK_WINDOW(main_window),
diff --git a/meta/packages/pcmanfm/pcmanfm_0.3.2.2.bb b/meta/packages/pcmanfm/pcmanfm_0.5.bb
index 0576c32f5..e253d79fb 100644
--- a/meta/packages/pcmanfm/pcmanfm_0.3.2.2.bb
+++ b/meta/packages/pcmanfm/pcmanfm_0.5.bb
@@ -3,13 +3,16 @@ HOMEPAGE = "http://pcmanfm.sourceforge.net/"
BUGTRACKER = ""
LICENSE = "GPLv2 & GPLv2+ & LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
+ file://src/pcmanfm.h;endline=22;md5=0fa9129ee918f493e573154f6ec43fb7 \
+ file://src/find-files.c;endline=26;md5=9a92e8f329c97de94e90976a37dde5a5"
SECTION = "x11"
PRIORITY = "optional"
DEPENDS = "gtk+ startup-notification"
DEPENDS_append_poky = " libowl"
-PR = "r5"
+PR = "r0"
COMPATIBLE_HOST = '(x86_64|i.86.*|arm.*|mips.*|powerpc.*)-(linux|freebsd.*)'