summaryrefslogtreecommitdiff
path: root/openembedded/packages/contacts/contacts_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages/contacts/contacts_0.1.bb')
-rwxr-xr-xopenembedded/packages/contacts/contacts_0.1.bb21
1 files changed, 7 insertions, 14 deletions
diff --git a/openembedded/packages/contacts/contacts_0.1.bb b/openembedded/packages/contacts/contacts_0.1.bb
index f2b81cbd8..cf025259f 100755
--- a/openembedded/packages/contacts/contacts_0.1.bb
+++ b/openembedded/packages/contacts/contacts_0.1.bb
@@ -3,29 +3,22 @@ SECTION = "x11"
DEPENDS = "glib-2.0 gtk+ libglade eds-dbus"
MAINTAINER = "Chris Lord <chris@openedhand.com>"
DESCRIPTION = "Contacts is an address-book application."
+PR = "r1"
SRC_URI = "svn://svn.o-hand.com/repos/${PN}/tags;module=release-0.1;proto=http \
file://stock_contact.png \
- file://stock_person.png \
- file://index.theme"
+ file://stock_person.png"
inherit autotools pkgconfig
S = "${WORKDIR}/release-0.1"
do_install_append () {
- install -d ${D}/${datadir}/icons/hicolor/48x48/stock/net
- install -d ${D}/${datadir}/icons/hicolor/48x48/stock/generic
-
- install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/icons/hicolor/48x48/stock/net
- install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/icons/hicolor/48x48/stock/generic
- install -m 0644 ${WORKDIR}/index.theme ${D}/${datadir}/icons/hicolor
+ install -d ${D}/${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/pixmaps
}
-FILES_${PN} += "${datadir}/icons/hicolor/48x48/stock/*/*.png \
- ${datadir}/icons/hicolor/index.theme"
-
-pkg_postinst_${PN} () {
- gtk-update-icon-cache /usr/share/icons/hicolor
-}
+FILES_${PN} += "${datadir}/pixmaps/stock_contact.png \
+ ${datadir}/pixmaps/stock_person.png"