summaryrefslogtreecommitdiff
path: root/openembedded/packages/db
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages/db')
-rw-r--r--openembedded/packages/db/db_4.1.25.bb (renamed from openembedded/packages/db/db_4.3.27.bb)11
1 files changed, 7 insertions, 4 deletions
diff --git a/openembedded/packages/db/db_4.3.27.bb b/openembedded/packages/db/db_4.1.25.bb
index 518fddee9..168dde478 100644
--- a/openembedded/packages/db/db_4.3.27.bb
+++ b/openembedded/packages/db/db_4.1.25.bb
@@ -73,17 +73,20 @@ do_stage() {
# Install, for the moment, into include/db4 to avoid
# interfering with the db3 headers (which have the same
# name). -I${STAGING_INCDIR}/db4 to use db4, as opposed
- # to db3.
+ # to db3
+
rm -rf ${STAGE_TEMP}
mkdir -p ${STAGE_TEMP}
- oe_runmake DESTDIR="${STAGE_TEMP}" install_include
+ oe_runmake DESTDIR="${STAGE_TEMP}" includedir="${STAGE_TEMP}${includedir}" install_include
mkdir -p ${STAGING_INCDIR}/db4
cp -pPRf ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}/db4
rm -rf ${STAGE_TEMP}
- oe_libinstall -so -C .libs libdb-4.3 ${STAGING_LIBDIR}
+ oe_libinstall -so -C .libs libdb-4.1 ${STAGING_LIBDIR}
}
-do_install_append() {
+do_install() {
+ oe_runmake includedir="${D}${includedir}" libdir="${D}${libdir}" bindir="${D}${bindir}" docdir="${D}${docdir}" install
+
# The docs end up in /usr/docs - not right.
if test -d "${D}/${prefix}/docs"
then