summaryrefslogtreecommitdiff
path: root/openembedded/packages/eds/eds-dbus
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages/eds/eds-dbus')
-rw-r--r--openembedded/packages/eds/eds-dbus/external_libdb.patch4
-rw-r--r--openembedded/packages/eds/eds-dbus/no_iconv_test.patch4
2 files changed, 4 insertions, 4 deletions
diff --git a/openembedded/packages/eds/eds-dbus/external_libdb.patch b/openembedded/packages/eds/eds-dbus/external_libdb.patch
index 50b9e9b48..635f4cb5e 100644
--- a/openembedded/packages/eds/eds-dbus/external_libdb.patch
+++ b/openembedded/packages/eds/eds-dbus/external_libdb.patch
@@ -6,8 +6,8 @@ Index: trunk/Makefile.am
endif
if ENABLE_DBUS
--SUBDIRS = libdb libedataserver $(CAMEL_DIR) addressbook calendar docs art po
-+SUBDIRS = libedataserver $(CAMEL_DIR) addressbook calendar docs art po
+-SUBDIRS = libdb libedataserver $(CAMEL_DIR) addressbook calendar libedataserverui docs art po
++SUBDIRS = libedataserver $(CAMEL_DIR) addressbook calendar libedataserverui docs art po
else
-SUBDIRS = libdb libedataserver servers $(CAMEL_DIR) addressbook calendar libedataserverui src docs art po
+SUBDIRS = libedataserver servers $(CAMEL_DIR) addressbook calendar libedataserverui src docs art po
diff --git a/openembedded/packages/eds/eds-dbus/no_iconv_test.patch b/openembedded/packages/eds/eds-dbus/no_iconv_test.patch
index 0589bdb88..6e33c7889 100644
--- a/openembedded/packages/eds/eds-dbus/no_iconv_test.patch
+++ b/openembedded/packages/eds/eds-dbus/no_iconv_test.patch
@@ -17,7 +17,7 @@ Index: trunk/configure.in
-int main (int argc, char **argv)
-{
- const char *from = "Some Text \xA4";
-- const char *utf8 = "Some Text \xE2\x82\xAC";
+- const char *utf8 = "Some Text \xC2\xA4";
- char *transbuf = malloc (20), *trans = transbuf;
- iconv_t cd;
- size_t from_len = strlen (from), utf8_len = 20;
@@ -29,7 +29,7 @@ Index: trunk/configure.in
- exit (1);
-#endif
-
-- cd = iconv_open ("UTF-8", "ISO_8859-15");
+- cd = iconv_open ("UTF-8", "ISO_8859-1");
- if (cd == (iconv_t) -1)
- exit (1);
- if (iconv (cd, &from, &from_len, &trans, &utf8_len) == -1 || from_len != 0)