summaryrefslogtreecommitdiff
path: root/openembedded/packages/irda-utils/irda-utils_0.9.16.bb
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages/irda-utils/irda-utils_0.9.16.bb')
-rw-r--r--openembedded/packages/irda-utils/irda-utils_0.9.16.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/openembedded/packages/irda-utils/irda-utils_0.9.16.bb b/openembedded/packages/irda-utils/irda-utils_0.9.16.bb
new file mode 100644
index 000000000..d99846f8c
--- /dev/null
+++ b/openembedded/packages/irda-utils/irda-utils_0.9.16.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Provides common files needed to use IrDA. \
+IrDA allows communication over Infrared with other devices \
+such as phones and laptops."
+SECTION = "base"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/irda/irda-utils-${PV}.tar.gz \
+ file://configure.patch;patch=1 \
+ file://m4.patch;patch=1 \
+ file://init"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "irattach"
+INITSCRIPT_PARAMS = "defaults 20"
+
+do_compile () {
+ oe_runmake -e -C irattach
+ oe_runmake -e -C irdaping
+}
+
+do_install () {
+ install -d ${D}${sbindir}
+ oe_runmake -C irattach ROOT="${D}" install
+ oe_runmake -C irdaping ROOT="${D}" install
+
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/irattach
+}