summaryrefslogtreecommitdiff
path: root/openembedded/packages/libxcursor/libxcursor_1.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages/libxcursor/libxcursor_1.1.2.bb')
-rw-r--r--openembedded/packages/libxcursor/libxcursor_1.1.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/openembedded/packages/libxcursor/libxcursor_1.1.2.bb b/openembedded/packages/libxcursor/libxcursor_1.1.2.bb
new file mode 100644
index 000000000..d948ff50d
--- /dev/null
+++ b/openembedded/packages/libxcursor/libxcursor_1.1.2.bb
@@ -0,0 +1,23 @@
+SECTION = "x11/libs"
+LICENSE= "BSD-X"
+PRIORITY = "optional"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+DESCRIPTION = "X Cursor library"
+DEPENDS = "libxfixes"
+PR = "r2"
+
+SRC_URI = "${XLIBS_MIRROR}/libXcursor-${PV}.tar.bz2 \
+ file://autofoo.patch;patch=1"
+S = "${WORKDIR}/libXcursor-${PV}"
+FILES_${PN} += "${libdir}/libXcursor.so"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_runmake install prefix=${STAGING_DIR} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR} \
+ mandir=${STAGING_DIR}/man
+}