summaryrefslogtreecommitdiff
path: root/openembedded/packages/matchbox-poky
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages/matchbox-poky')
-rwxr-xr-xopenembedded/packages/matchbox-poky/matchbox-poky/etc/matchbox/session43
-rw-r--r--openembedded/packages/matchbox-poky/matchbox-poky_0.1.bb20
2 files changed, 0 insertions, 63 deletions
diff --git a/openembedded/packages/matchbox-poky/matchbox-poky/etc/matchbox/session b/openembedded/packages/matchbox-poky/matchbox-poky/etc/matchbox/session
deleted file mode 100755
index fede9e44b..000000000
--- a/openembedded/packages/matchbox-poky/matchbox-poky/etc/matchbox/session
+++ /dev/null
@@ -1,43 +0,0 @@
-#!/bin/sh
-
-module_id() {
- awk 'BEGIN { FS=": " } /Hardware/ { print $2 } ' </proc/cpuinfo
-}
-
-SHOWCURSOR="no"
-
-## Start up machine specific input devices. Really needs to go in its own session
-case `module_id` in
- "SHARP Shepherd" | "SHARP Husky" | "SHARP Corgi" | "SHARP Spitz" | "SHARP Akita" | "SHARP Borzoi")
- chkhinge26 /dev/input/event0 hinge-handler &
- ;;
- "Generic OMAP1510/1610/1710")
- /usr/bin/mbinputmgr &
- ;;
- "ARM-IntegratorCP")
- /usr/bin/mbinputmgr &
- SHOWCURSOR="yes"
- ;;
-esac
-
-## All this should be done by themeing/xsettings.. ##
-matchbox-desktop --icon-size 48 \
- --icon-padding 64 \
- --font sans-8:bold \
- --titlefont sans-8:bold &
-
-# let theme set it
-# --bg /usr/share/themes/Clearlooks/background/default.png \
-
-mb-applet-startup-monitor &
-
-matchbox-panel --orientation east \
- --padding 4 \
- --no-menu \
- --no-session \
- --default-apps mb-applet-home,mb-applet-clock,mb-applet-battery &
-
-## eek ugly no cursor hack - transparent theme should do this
-exec matchbox-window-manager -theme Clearlooks -use_cursor $SHOWCURSOR $@
-
-
diff --git a/openembedded/packages/matchbox-poky/matchbox-poky_0.1.bb b/openembedded/packages/matchbox-poky/matchbox-poky_0.1.bb
deleted file mode 100644
index 041a6ea90..000000000
--- a/openembedded/packages/matchbox-poky/matchbox-poky_0.1.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-DESCRIPTION = "Custom MB session files for poky"
-LICENSE = "GPL"
-SECTION = "x11"
-RDEPENDS = "matchbox matchbox-applet-startup-monitor gtk-theme-clearlooks"
-PR = "r15"
-
-SRC_URI = "file://etc"
-S = ${WORKDIR}
-
-do_install() {
- cp -R ${S}/etc ${D}/etc
- rm -fR ${D}/etc/.svn
- rm -fR ${D}/etc/matchbox/.svn
- chmod -R 755 ${D}/etc
-}
-
-pkg_postinst_matchbox-poky () {
-#!/bin/sh -e
-gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/theme Clearlooks
-}