summaryrefslogtreecommitdiff
path: root/openembedded/packages/python/python-2.4.3/fix-tkinter-detection.patch
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages/python/python-2.4.3/fix-tkinter-detection.patch')
-rw-r--r--openembedded/packages/python/python-2.4.3/fix-tkinter-detection.patch39
1 files changed, 0 insertions, 39 deletions
diff --git a/openembedded/packages/python/python-2.4.3/fix-tkinter-detection.patch b/openembedded/packages/python/python-2.4.3/fix-tkinter-detection.patch
deleted file mode 100644
index 602aa8e02..000000000
--- a/openembedded/packages/python/python-2.4.3/fix-tkinter-detection.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- Python-2.4.1/setup.py~fix-tkinter-detection
-+++ Python-2.4.1/setup.py
-@@ -999,7 +999,7 @@
- dotversion = dotversion[:-1] + '.' + dotversion[-1]
- tcl_include_sub = []
- tk_include_sub = []
-- for dir in inc_dirs:
-+ for dir in [os.getenv("STAGING_INCDIR")]:
- tcl_include_sub += [dir + os.sep + "tcl" + dotversion]
- tk_include_sub += [dir + os.sep + "tk" + dotversion]
- tk_include_sub += tcl_include_sub
-@@ -1018,22 +1018,6 @@
- if dir not in include_dirs:
- include_dirs.append(dir)
-
-- # Check for various platform-specific directories
-- if platform == 'sunos5':
-- include_dirs.append('/usr/openwin/include')
-- added_lib_dirs.append('/usr/openwin/lib')
-- elif os.path.exists('/usr/X11R6/include'):
-- include_dirs.append('/usr/X11R6/include')
-- added_lib_dirs.append('/usr/X11R6/lib64')
-- added_lib_dirs.append('/usr/X11R6/lib')
-- elif os.path.exists('/usr/X11R5/include'):
-- include_dirs.append('/usr/X11R5/include')
-- added_lib_dirs.append('/usr/X11R5/lib')
-- else:
-- # Assume default location for X11
-- include_dirs.append('/usr/X11/include')
-- added_lib_dirs.append('/usr/X11/lib')
--
- # If Cygwin, then verify that X is installed before proceeding
- if platform == 'cygwin':
- x11_inc = find_file('X11/Xlib.h', [], include_dirs)