summaryrefslogtreecommitdiff
path: root/openembedded/packages/xext
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages/xext')
-rw-r--r--openembedded/packages/xext/files/autofoo.patch18
-rw-r--r--openembedded/packages/xext/xext-native_cvs.bb4
-rw-r--r--openembedded/packages/xext/xext_cvs.bb21
3 files changed, 43 insertions, 0 deletions
diff --git a/openembedded/packages/xext/files/autofoo.patch b/openembedded/packages/xext/files/autofoo.patch
new file mode 100644
index 000000000..c00688452
--- /dev/null
+++ b/openembedded/packages/xext/files/autofoo.patch
@@ -0,0 +1,18 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- Xext/configure.ac~autofoo
++++ Xext/configure.ac
+@@ -8,9 +8,8 @@
+ libXext)
+
+ AC_CONFIG_SRCDIR([Makefile.am])
+-AM_INIT_AUTOMAKE([dist-bzip2])
+-
+ AC_CONFIG_AUX_DIR(.)
++AM_INIT_AUTOMAKE([dist-bzip2])
+
+ AM_MAINTAINER_MODE
+
diff --git a/openembedded/packages/xext/xext-native_cvs.bb b/openembedded/packages/xext/xext-native_cvs.bb
new file mode 100644
index 000000000..6be231f15
--- /dev/null
+++ b/openembedded/packages/xext/xext-native_cvs.bb
@@ -0,0 +1,4 @@
+SECTION = "unknown"
+include xext_${PV}.bb
+inherit native
+DEPENDS = "x11-native xextensions-native"
diff --git a/openembedded/packages/xext/xext_cvs.bb b/openembedded/packages/xext/xext_cvs.bb
new file mode 100644
index 000000000..e9f330120
--- /dev/null
+++ b/openembedded/packages/xext/xext_cvs.bb
@@ -0,0 +1,21 @@
+PV = "0.0cvs${CVSDATE}"
+PR = "r1"
+LICENSE= "MIT"
+DESCRIPTION = "X Server Extension library"
+SECTION = "x11/libs"
+PRIORITY = "optional"
+DEPENDS = "xproto x11 xextensions"
+
+SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xlibs;module=Xext"
+S = "${WORKDIR}/Xext"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_runmake install prefix=${STAGING_DIR} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR} \
+ mandir=${STAGING_DATADIR}/man
+}