summaryrefslogtreecommitdiff
path: root/openembedded/packages
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages')
-rw-r--r--openembedded/packages/avahi/avahi_0.6.10.bb (renamed from openembedded/packages/avahi/avahi_0.6.3.bb)16
1 files changed, 11 insertions, 5 deletions
diff --git a/openembedded/packages/avahi/avahi_0.6.3.bb b/openembedded/packages/avahi/avahi_0.6.10.bb
index 3253b1197..2b12d91c8 100644
--- a/openembedded/packages/avahi/avahi_0.6.3.bb
+++ b/openembedded/packages/avahi/avahi_0.6.10.bb
@@ -1,11 +1,13 @@
DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
+SECTION = "network"
+PRIORITY = "optional"
+AUTHOR = "Lennart Poettering <lennart@poettering.net>"
HOMEPAGE = "http://avahi.org"
+MAINTAINER = "Philipp Zabel <philipp.zabel@gmail.com>"
LICENSE= "GPL"
+
DEPENDS = "expat libdaemon dbus"
RRECOMMENDS = "libnss-mdns"
-SECTION = "net"
-PRIORITY = "optional"
-PR = "r0"
SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz"
@@ -15,6 +17,7 @@ FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
FILES_avahi-daemon = "${sbindir}/avahi-daemon \
${sysconfdir}/avahi/avahi-daemon.conf \
+ ${sysconfdir}/avahi/hosts \
${sysconfdir}/avahi/services \
${sysconfdir}/dbus-1 \
${sysconfdir}/init.d/avahi-daemon \
@@ -31,8 +34,7 @@ FILES_avahi-utils = "${bindir}/avahi-*"
CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
EXTRA_OECONF = "--with-distro=debian --disable-gdbm --disable-gtk --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 --disable-python"
-inherit autotools
-inherit update-rc.d
+inherit autotools pkgconfig update-rc.d
INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
@@ -41,6 +43,10 @@ INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
pkg_postinst_avahi-daemon () {
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+
grep avahi /etc/group || addgroup avahi
grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
/etc/init.d/dbus-1 force-reload