summaryrefslogtreecommitdiff
path: root/openembedded/packages
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages')
-rw-r--r--openembedded/packages/matchbox-keyboard/matchbox-keyboard_svn.bb19
-rw-r--r--openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.desktop7
-rwxr-xr-xopenembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.sh9
-rw-r--r--openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr.pngbin0 -> 1651 bytes
-rw-r--r--openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb18
-rw-r--r--openembedded/packages/matchbox-panel-manager/matchbox-panel-manager_0.1.bb12
-rw-r--r--openembedded/packages/matchbox-stroke/matchbox-stroke_svn.bb19
-rw-r--r--openembedded/packages/matchbox-themes-extra/matchbox-themes-extra_0.3.bb25
-rw-r--r--openembedded/packages/matchbox-themes-gtk/files/gtkrc1
-rw-r--r--openembedded/packages/matchbox-themes-gtk/matchbox-themes-gtk.bb15
10 files changed, 125 insertions, 0 deletions
diff --git a/openembedded/packages/matchbox-keyboard/matchbox-keyboard_svn.bb b/openembedded/packages/matchbox-keyboard/matchbox-keyboard_svn.bb
new file mode 100644
index 000000000..d45b01657
--- /dev/null
+++ b/openembedded/packages/matchbox-keyboard/matchbox-keyboard_svn.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Matchbox keyboard"
+LICENSE = "GPL"
+DEPENDS = "libfakekey expat libxft"
+SECTION = "x11/wm"
+PV = "0.0+svn${CVSDATE}"
+PR="r1"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http"
+
+
+S = ${WORKDIR}/${PN}
+
+inherit autotools pkgconfig gettext
+
+FILES_${PN} = "${bindir} \
+ ${datadir}/applications \
+ ${datadir}/pixmaps \
+ ${datadir}/matchbox-keyboard"
+
diff --git a/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.desktop b/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.desktop
new file mode 100644
index 000000000..512e3771e
--- /dev/null
+++ b/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Screen Rotator
+Comment=Panel based Rotation tool.
+Exec=mb-applet-launcher -na -l --title "Screen Rotator" /usr/share/pixmaps/xrandr.png xrandr-panelapp.sh
+Type=PanelApp
+Icon=xrandr.png
+Categories=Panel;Utility;MB
diff --git a/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.sh b/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.sh
new file mode 100755
index 000000000..d17c805ff
--- /dev/null
+++ b/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.sh
@@ -0,0 +1,9 @@
+#!/bin/sh
+if [ -n "$(xrandr | grep rotation | grep left)" ]
+then
+xrandr -o normal
+xmodmap /etc/X11/xmodmap-portrait
+else
+xrandr -o left
+xmodmap /etc/X11/xmodmap-left
+fi
diff --git a/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr.png b/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr.png
new file mode 100644
index 000000000..08cd476e8
--- /dev/null
+++ b/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr.png
Binary files differ
diff --git a/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb b/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
new file mode 100644
index 000000000..e7c1b4e64
--- /dev/null
+++ b/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Simple dockapps created with monolaunch and shell script"
+DEPENDS = "matchbox xmodmap"
+SRC_URI = "file://xrandr-panelapp.sh \
+ file://xrandr-panelapp.desktop \
+ file://xrandr.png"
+SECTION = "x11/wm"
+PRIORITY = "optional"
+PR = "r4"
+LICENSE = "MIT"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/applications
+ install -d ${D}${datadir}/pixmaps
+ install -m 0755 ${WORKDIR}/xrandr-panelapp.sh ${D}${bindir}/
+ install -m 0644 ${WORKDIR}/xrandr-panelapp.desktop ${D}${datadir}/applications/
+ install -m 0644 ${WORKDIR}/xrandr.png ${D}${datadir}/pixmaps/
+}
diff --git a/openembedded/packages/matchbox-panel-manager/matchbox-panel-manager_0.1.bb b/openembedded/packages/matchbox-panel-manager/matchbox-panel-manager_0.1.bb
new file mode 100644
index 000000000..1023a6aa7
--- /dev/null
+++ b/openembedded/packages/matchbox-panel-manager/matchbox-panel-manager_0.1.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "Matchbox Panel Manager"
+LICENSE = "GPL"
+DEPENDS = "gtk+"
+SECTION = "x11/wm"
+
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/${PN}/${PV}/${PN}-${PV}.tar.bz2"
+S = "${WORKDIR}/${PN}-${PV}"
+
+inherit autotools pkgconfig
+
+FILES_${PN} = "${bindir} ${datadir}/applications ${datadir}/pixmaps"
+
diff --git a/openembedded/packages/matchbox-stroke/matchbox-stroke_svn.bb b/openembedded/packages/matchbox-stroke/matchbox-stroke_svn.bb
new file mode 100644
index 000000000..99473397b
--- /dev/null
+++ b/openembedded/packages/matchbox-stroke/matchbox-stroke_svn.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Matchbox keyboard"
+LICENSE = "GPL"
+DEPENDS = "libfakekey expat libxft"
+SECTION = "x11/wm"
+PV = "0.0+svn${CVSDATE}"
+PR="r1"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http"
+
+
+S = ${WORKDIR}/${PN}
+
+inherit autotools pkgconfig gettext
+
+FILES_${PN} = "${bindir} \
+ ${datadir}/applications \
+ ${datadir}/pixmaps \
+ ${datadir}/matchbox-stroke"
+
diff --git a/openembedded/packages/matchbox-themes-extra/matchbox-themes-extra_0.3.bb b/openembedded/packages/matchbox-themes-extra/matchbox-themes-extra_0.3.bb
new file mode 100644
index 000000000..ac00978c4
--- /dev/null
+++ b/openembedded/packages/matchbox-themes-extra/matchbox-themes-extra_0.3.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Matchbox window manager extra themes"
+LICENSE = "GPL"
+DEPENDS = "matchbox-wm"
+SECTION = "x11/wm"
+
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-themes-extra/${PV}/matchbox-themes-extra-${PV}.tar.bz2"
+S = "${WORKDIR}/matchbox-themes-extra-${PV}"
+
+inherit autotools pkgconfig
+
+# split into several packages plus one meta package
+PACKAGES = "${PN} ${PN}-industrial ${PN}-expose ${PN}-mbcrystal"
+
+ALLOW_EMPTY_${PN} = 1
+FILES_${PN} = ""
+RDEPENDS_${PN} = "${PN}-industrial ${PN}-expose ${PN}-mbcrystal"
+
+FILES_${PN}-industrial = "${datadir}/themes/Industrial \
+ ${datadir}/icons/Industrial"
+
+FILES_${PN}-expose = "${datadir}/themes/expose \
+ ${datadir}/icons/expose"
+
+FILES_${PN}-mbcrystal = "${datadir}/themes/mbcrystal \
+ ${datadir}/icons/mbcrystal"
diff --git a/openembedded/packages/matchbox-themes-gtk/files/gtkrc b/openembedded/packages/matchbox-themes-gtk/files/gtkrc
new file mode 100644
index 000000000..b22b9972c
--- /dev/null
+++ b/openembedded/packages/matchbox-themes-gtk/files/gtkrc
@@ -0,0 +1 @@
+include "/usr/share/themes/Angelistic/gtk-2.0/gtkrc"
diff --git a/openembedded/packages/matchbox-themes-gtk/matchbox-themes-gtk.bb b/openembedded/packages/matchbox-themes-gtk/matchbox-themes-gtk.bb
new file mode 100644
index 000000000..769aeecb1
--- /dev/null
+++ b/openembedded/packages/matchbox-themes-gtk/matchbox-themes-gtk.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Gtk2 theme files to accompany default Matchbox themes"
+LICENSE = "GPL"
+RDEPENDS = "matchbox-wm gtk2-theme-angelistic"
+SECTION = "x11/base"
+
+SRC_URI = "file://gtkrc"
+
+FILES_${PN} = "${datadir}/themes"
+
+do_install() {
+ install -d ${D}${datadir}/themes/blondie/gtk-2.0
+ install -d ${D}${datadir}/themes/MBOpus/gtk-2.0
+ install -m 644 ${WORKDIR}/gtkrc ${D}${datadir}/themes/blondie/gtk-2.0/
+ install -m 644 ${WORKDIR}/gtkrc ${D}${datadir}/themes/MBOpus/gtk-2.0/
+}