summaryrefslogtreecommitdiff
path: root/openembedded
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/initscripts/initscripts-1.0/openslug/alignment.sh20
-rw-r--r--openembedded/packages/initscripts/initscripts-1.0/openslug/banner4
-rw-r--r--openembedded/packages/initscripts/initscripts-1.0/openslug/device_table.txt169
-rw-r--r--openembedded/packages/initscripts/initscripts-1.0/openslug/devices.patch52
-rw-r--r--openembedded/packages/initscripts/initscripts-1.0/openslug/domainname.sh5
-rw-r--r--openembedded/packages/initscripts/initscripts-1.0/openslug/rootopts.patch15
-rw-r--r--openembedded/packages/initscripts/initscripts-1.0/openslug/umountfs43
-rw-r--r--openembedded/packages/initscripts/initscripts-1.0/openslug/umountnfs.sh40
-rw-r--r--openembedded/packages/initscripts/initscripts-1.0/tosa/keymap-2.4.map20
-rw-r--r--openembedded/packages/initscripts/initscripts_1.0.bb6
10 files changed, 13 insertions, 361 deletions
diff --git a/openembedded/packages/initscripts/initscripts-1.0/openslug/alignment.sh b/openembedded/packages/initscripts/initscripts-1.0/openslug/alignment.sh
deleted file mode 100644
index bf193cb01..000000000
--- a/openembedded/packages/initscripts/initscripts-1.0/openslug/alignment.sh
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh
-#
-# How to handle alignment faults on the ARM
-#
-# 0 - ignore, the value will probably be rotated
-# 1 - warn, a log message will be output
-# 2 - fixup, the kernel will do an expensive aligned read
-# 3 - fixup+warn
-# 4 - signal, the process will get an illegal instruction fault
-# 5 - signal+warn
-# 6 - invalid (has no effect)
-# 7 - invalid (has no effect)
-#
-# Set ALIGN in /etc/default/rcS to override (do not edit this
-# file!) Set ALIGN to empty to avoid changing the kernel
-# default (currently '0').
-ALIGN=1
-. /etc/default/rcS
-test -e /proc/cpu/alignment -a -n "$ALIGN" -a "$ALIGN" -ge 0 -a "$ALIGN" -lt 6 &&
- echo "$ALIGN" >/proc/cpu/alignment
diff --git a/openembedded/packages/initscripts/initscripts-1.0/openslug/banner b/openembedded/packages/initscripts/initscripts-1.0/openslug/banner
deleted file mode 100644
index d80fb19fe..000000000
--- a/openembedded/packages/initscripts/initscripts-1.0/openslug/banner
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-#NOTE: this script may execute with absolutely nothing
-# in /dev
-echo "OpenSlug booting..."
diff --git a/openembedded/packages/initscripts/initscripts-1.0/openslug/device_table.txt b/openembedded/packages/initscripts/initscripts-1.0/openslug/device_table.txt
deleted file mode 100644
index ae3cb7991..000000000
--- a/openembedded/packages/initscripts/initscripts-1.0/openslug/device_table.txt
+++ /dev/null
@@ -1,169 +0,0 @@
-#/dev/ d 775 0 0 - - - - -
-#/dev/msys d 775 0 0 - - - - -
-#/dev/pts d 775 0 0 - - - - -
-#/var d 775 0 0 - - - - -
-/boot/var/empty d 755 0 3 - - - -
-/dev/apm_bios c 660 0 46 10 134 - - -
-/dev/audio c 660 0 29 14 4 - - -
-/dev/audio1 c 660 0 29 14 20 - - -
-/dev/audio2 c 660 0 29 14 36 - - -
-/dev/audio3 c 660 0 29 14 52 - - -
-#/dev/bty c 644 0 0 60 0 0 1 5
-/dev/buzzer c 660 0 0 62 0 - - -
-#/dev/sharp_fl c 640 0 44 254 0 - - -
-/dev/console c 662 0 5 5 1 - -
-/dev/cusa0 c 640 0 0 205 5 - - -
-/dev/cusa1 c 640 0 0 205 6 - - -
-/dev/cusa2 c 640 0 0 205 7 - - -
-/dev/dsp c 660 0 29 14 3 - - -
-/dev/dsp1 c 660 0 29 14 19 - - -
-/dev/dsp2 c 660 0 29 14 35 - - -
-/dev/dsp3 c 660 0 29 14 51 - - -
-/dev/fb c 660 0 44 29 0 0 32 2
-/dev/fb0autodetect c 660 0 44 29 1 - - -
-/dev/fb0current c 660 0 44 29 0 - - -
-#/dev/fb1 c 660 0 44 29 32 - - -
-/dev/fb1autodetect c 660 0 44 29 33 - - -
-/dev/fb1current c 660 0 44 29 32 - - -
-/dev/full c 666 0 7 - - -
-/dev/hda b 660 0 6 3 0 - - -
-/dev/hda b 660 0 6 3 1 1 1 20
-/dev/hdb b 660 0 6 3 64 - - -
-/dev/hdb b 660 0 6 3 65 1 1 20
-/dev/hdc b 660 0 6 22 0 - - -
-/dev/hdc b 660 0 6 22 1 1 1 20
-/dev/initctl p 600 0 0 - - - -
-/dev/i2c0 c 660 0 0 89 0 - - -
-/dev/inportbm c 660 0 0 10 2 - - -
-/dev/input/event c 660 0 0 13 64 0 1 20
-/dev/ircomm0 c 640 0 0 161 0 - - -
-/dev/jbm c 660 0 0 10 4 - - -
-/dev/kmem c 640 0 15 1 2 - - -
-/dev/leds c 660 0 0 126 0 - - -
-#/dev/lirc c 660 0 5 61 0 - - -
-/dev/logibm c 660 0 0 10 0 - - -
-/dev/loop0 b 660 0 11 7 0 - - -
-/dev/loop1 b 660 0 11 7 1 - - -
-/dev/mem c 640 0 15 1 1 - - -
-/dev/mixer c 666 0 0 14 0 - - -
-/dev/mixer1 c 666 0 0 14 16 - - -
-/dev/mixer2 c 666 0 0 14 32 - - -
-/dev/mixer3 c 666 0 0 14 48 - - -
-/dev/mmcda b 640 0 0 60 0 - - -
-/dev/mmcda1 b 640 0 0 60 1 - - -
-/dev/mmcda2 b 640 0 0 60 2 - - -
-/dev/msys/fla b 660 0 11 100 0 - - -
-/dev/msys/fla1 b 660 0 11 100 1 - - -
-/dev/msys/fla2 b 660 0 11 100 2 - - -
-/dev/msys/fla3 b 660 0 11 100 3 - - -
-/dev/msys/fla4 b 660 0 11 100 4 - - -
-/dev/msys/flb b 660 0 11 100 64 - - -
-/dev/msys/flb1 b 660 0 11 100 65 - - -
-/dev/msys/flb2 b 660 0 11 100 66 - - -
-/dev/msys/flb3 b 660 0 11 100 67 - - -
-/dev/msys/flb4 b 660 0 11 100 68 - - -
-/dev/mtd c 660 0 6 90 0 0 2 8
-/dev/mtdblock b 640 0 0 31 0 0 1 8
-/dev/nst0 c 664 0 11 9 128 - - -
-/dev/nst0a c 664 0 11 9 224 - - -
-/dev/nst0l c 664 0 11 9 160 - - -
-/dev/nst0m c 664 0 11 9 192 - - -
-/dev/nst1 c 664 0 11 9 129 - - -
-/dev/nst1a c 664 0 11 9 225 - - -
-/dev/nst1l c 664 0 11 9 161 - - -
-/dev/nst1m c 664 0 11 9 193 - - -
-/dev/null c 666 0 0 1 3 - - -
-/dev/par0 c 660 0 7 6 0 - - -
-/dev/par1 c 660 0 7 6 1 - - -
-/dev/par2 c 660 0 7 6 2 - - -
-/dev/pbuttons c 660 0 0 61 0 - - -
-/dev/port c 640 0 15 1 4 - - -
-/dev/ppp c 640 0 0 108 0 - - -
-/dev/psaux c 660 0 0 10 1 - - -
-/dev/ptmx c 666 0 5 5 2 - - -
-/dev/ptya0 c 660 0 5 2 176 - - -
-/dev/ptya1 c 660 0 5 2 177 - - -
-/dev/ptya2 c 660 0 5 2 178 - - -
-/dev/ptya3 c 660 0 5 2 179 - - -
-/dev/ptya4 c 660 0 5 2 180 - - -
-/dev/ptya5 c 660 0 5 2 181 - - -
-/dev/ptya6 c 660 0 5 2 182 - - -
-/dev/ptya7 c 660 0 5 2 183 - - -
-/dev/ptya8 c 660 0 5 2 184 - - -
-/dev/ptya9 c 660 0 5 2 185 - - -
-/dev/ptyaa c 660 0 5 2 186 - - -
-/dev/ptyab c 660 0 5 2 187 - - -
-/dev/ptyac c 660 0 5 2 188 - - -
-/dev/ptyad c 660 0 5 2 189 - - -
-/dev/ptyae c 660 0 5 2 190 - - -
-/dev/ptyaf c 660 0 5 2 191 - - -
-/dev/ram b 640 0 0 1 0 0 1 4
-/dev/random c 444 0 0 1 8 - - -
-/dev/rbuttons c 660 0 0 60 0 - - -
-/dev/rfcomm c 666 0 0 216 0 0 1 4
-/dev/rmidi0 c 660 0 0 35 64 - - -
-/dev/rmidi1 c 660 0 0 35 65 - - -
-/dev/rmidi2 c 660 0 0 35 66 - - -
-/dev/rmidi3 c 660 0 0 35 67 - - -
-/dev/rtc c 660 0 47 10 135 - - -
-/dev/scd0 b 660 0 6 11 0 - - -
-/dev/scd1 b 660 0 6 11 1 - - -
-/dev/sda b 660 0 6 8 0 - - -
-/dev/sda1 b 660 0 6 8 1 - - -
-/dev/sda2 b 660 0 6 8 2 - - -
-/dev/sda3 b 660 0 6 8 3 - - -
-/dev/sda4 b 660 0 6 8 4 - - -
-/dev/sda5 b 660 0 6 8 5 - - -
-/dev/sda6 b 660 0 6 8 6 - - -
-/dev/sda7 b 660 0 6 8 7 - - -
-/dev/sda8 b 660 0 6 8 8 - - -
-/dev/sda9 b 660 0 6 8 9 - - -
-/dev/sdb b 660 0 6 8 16 - - -
-/dev/sdb1 b 660 0 6 8 17 - - -
-/dev/sdb2 b 660 0 6 8 18 - - -
-/dev/sdb3 b 660 0 6 8 19 - - -
-/dev/sdb4 b 660 0 6 8 20 - - -
-/dev/sdb5 b 660 0 6 8 21 - - -
-/dev/sdb6 b 660 0 6 8 22 - - -
-/dev/sdb7 b 660 0 6 8 23 - - -
-/dev/sdb8 b 660 0 6 8 24 - - -
-/dev/sdb9 b 660 0 6 8 25 - - -
-/dev/sdc b 660 0 6 8 32 - - -
-/dev/sdc1 b 660 0 6 8 33 - - -
-/dev/sdc2 b 660 0 6 8 34 - - -
-/dev/sdc3 b 660 0 6 8 35 - - -
-/dev/sdc4 b 660 0 6 8 36 - - -
-/dev/sdc5 b 660 0 6 8 37 - - -
-/dev/sdc6 b 660 0 6 8 38 - - -
-/dev/sdc7 b 660 0 6 8 39 - - -
-/dev/sdc8 b 660 0 6 8 40 - - -
-/dev/sdc9 b 660 0 6 8 41 - - -
-/dev/sd_slotstat c 660 0 6 10 240 - - -
-#/dev/sharp_audioctl c 660 0 29 10 213 - - -
-#/dev/sharp_buz c 660 0 29 10 211 - - -
-#/dev/sharp_kbdctl c 660 0 45 10 214 - - -
-#/dev/sharp_led c 660 0 48 10 210 - - -
-#/dev/sharp_ts c 640 0 45 11 0 - - -
-/dev/smtpe0 c 640 0 0 35 128 - - -
-/dev/smtpe1 c 640 0 0 35 129 - - -
-/dev/smtpe2 c 640 0 0 35 130 - - -
-/dev/smtpe3 c 640 0 0 35 131 - - -
-/dev/sndstat c 660 0 29 14 6 - - -
-/dev/st0 c 660 0 11 9 0 - - -
-/dev/st0a c 660 0 11 9 96 - - -
-/dev/st0l c 660 0 11 9 32 - - -
-/dev/st0m c 660 0 11 9 64 - - -
-/dev/st1 c 660 0 11 9 1 - - -
-/dev/st1a c 660 0 11 9 97 - - -
-/dev/st1l c 660 0 11 9 33 - - -
-/dev/st1m c 660 0 11 9 65 - - -
-/dev/tty c 666 0 5 5 0 - - -
-/dev/tty c 666 0 5 4 0 0 1 9
-/dev/ttyS c 640 0 5 4 64 0 1 4
-/dev/ttySA c 640 0 5 204 5 0 1 4
-/dev/ttyUSB c 660 0 5 188 0 0 1 2
-/dev/urandom c 644 0 0 1 9 - - -
-/dev/usbmouse c 640 0 45 10 32 - - -
-/dev/video c 644 0 0 81 0 0 1 4
-/dev/zero c 644 0 0 1 5 - - -
-/dev/input/mice c 660 0 0 13 63 - - -
diff --git a/openembedded/packages/initscripts/initscripts-1.0/openslug/devices.patch b/openembedded/packages/initscripts/initscripts-1.0/openslug/devices.patch
deleted file mode 100644
index 26b1841d5..000000000
--- a/openembedded/packages/initscripts/initscripts-1.0/openslug/devices.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-#
-# Patch to allow /dev to reside permanently in the file
-# system.
-#
---- old/devices 2005-05-28 21:51:39.012078699 -0700
-+++ new/devices 2005-06-12 00:16:29.222686303 -0700
-@@ -6,7 +6,7 @@
- . /etc/default/rcS
-
- # exit without doing anything if udev is active
--if test -e /dev/.udevdb; then
-+if test -e /dev/.udevdb -o -e /dev/.permanent; then
- exit 0
- fi
-
-@@ -37,12 +37,20 @@
- mknod /dev/ppp c 108 0
- if test "$VERBOSE" != "no"; then echo "done"; fi
- else
-- if test "$VERBOSE" != "no"; then echo -n "Mounting /dev ramdisk: "; fi
-- mount -t ramfs ramfs /dev || mount -t tmpfs ramfs /dev
-- if test $? -ne 0; then
-- if test "$VERBOSE" != "no"; then echo "failed"; fi
-+ if test -e /dev/.noram
-+ then
-+ # There should be no files, any files will damage the
-+ # makedevs script below.
-+ rm $(find /dev -type f -print)
-+ :>/dev/.noram
- else
-- if test "$VERBOSE" != "no"; then echo "done"; fi
-+ if test "$VERBOSE" != "no"; then echo -n "Mounting /dev ramdisk: "; fi
-+ mount -t ramfs ramfs /dev || mount -t tmpfs ramfs /dev
-+ if test $? -ne 0; then
-+ if test "$VERBOSE" != "no"; then echo "failed"; fi
-+ else
-+ if test "$VERBOSE" != "no"; then echo "done"; fi
-+ fi
- fi
- if test "$VERBOSE" != "no"; then echo -n "Populating /dev: "; fi
- cd /
-@@ -60,6 +68,10 @@
- if test "$VERBOSE" != "no"; then echo "failed"; fi
- else
- if test "$VERBOSE" != "no"; then echo "done"; fi
-+ if test -e /dev/.noram
-+ then
-+ :>/dev/.permanent
-+ fi
- fi
- fi
-
diff --git a/openembedded/packages/initscripts/initscripts-1.0/openslug/domainname.sh b/openembedded/packages/initscripts/initscripts-1.0/openslug/domainname.sh
deleted file mode 100644
index 7113467d8..000000000
--- a/openembedded/packages/initscripts/initscripts-1.0/openslug/domainname.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#
-# domainname.sh Set the domainname.
-#
-test -r /etc/defaultdomain &&
- cat /etc/defaultdomain >/proc/sys/kernel/domainname
diff --git a/openembedded/packages/initscripts/initscripts-1.0/openslug/rootopts.patch b/openembedded/packages/initscripts/initscripts-1.0/openslug/rootopts.patch
deleted file mode 100644
index 3f2a92587..000000000
--- a/openembedded/packages/initscripts/initscripts-1.0/openslug/rootopts.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-#
-# Ensure that the root file system is remounted with the correct
-# options from fstab
-#
---- old/checkroot.sh 2005-05-28 19:30:55.488975598 -0700
-+++ new/checkroot.sh 2005-05-28 19:31:32.334390450 -0700
-@@ -149,7 +149,7 @@
- # is on a ro fs until the remount succeeded. Then clean up old mtabs
- # and finally write the new mtab.
- #
--mount -n -o remount,$rootmode /
-+mount -n -o remount,$rootopts /
- if test "$rootmode" = rw
- then
- if test ! -L /etc/mtab
diff --git a/openembedded/packages/initscripts/initscripts-1.0/openslug/umountfs b/openembedded/packages/initscripts/initscripts-1.0/openslug/umountfs
deleted file mode 100644
index d6f432dbd..000000000
--- a/openembedded/packages/initscripts/initscripts-1.0/openslug/umountfs
+++ /dev/null
@@ -1,43 +0,0 @@
-#! /bin/sh
-#
-# umountfs Turn off swap and unmount all local filesystems.
-#
-
-PATH=/sbin:/bin:/usr/sbin:/usr/bin
-
-# Ensure /proc is mounted
-test -r /proc/mounts || mount -t proc proc /proc
-
-echo "Deactivating swap..."
-swapoff -a
-
-# We leave /proc mounted, the umount of /dev/devpts seems to fail
-# quite frequently, the busybox umount apparently gives up at the
-# first failure, so it is necessary to go file system by file
-# system. It is necessary to go backward in the /proc list, because
-# later things may have been mounted on earlier mounts.
-devfs=
-unmount() {
- local dev mp type opts
- if read dev mp type opts
- then
- # recurse - unmount later items
- unmount
- # skip /proc and /dev but not the sub-directories
- case "$mp" in
- /|/proc)return 0;;
- /dev) devfs=1
- return 0;;
- esac
- # then unmount this, if possible, otherwise make
- # it read-only
- umount -f -r "$mp"
- fi
-}
-
-echo "Unmounting local filesystems..."
-unmount </proc/mounts
-
-# now /dev and read-only / (halt/reboot may need /proc!)
-test -n "$devfs" && umount -f -r /dev
-mount -o remount,ro /
diff --git a/openembedded/packages/initscripts/initscripts-1.0/openslug/umountnfs.sh b/openembedded/packages/initscripts/initscripts-1.0/openslug/umountnfs.sh
deleted file mode 100644
index 994a91922..000000000
--- a/openembedded/packages/initscripts/initscripts-1.0/openslug/umountnfs.sh
+++ /dev/null
@@ -1,40 +0,0 @@
-#! /bin/sh
-#
-# umountnfs.sh Unmount all network filesystems.
-#
-PATH=/sbin:/bin:/usr/sbin:/usr/bin
-
-# Write a reboot record to /var/log/wtmp before unmounting
-halt -w
-
-# Ensure /proc is mounted
-test -r /proc/mounts || mount -t proc proc /proc
-
-echo "Unmounting remote filesystems..."
-
-#
-# Read the list of mounted file systems and -f umount the
-# known network file systems. -f says umount it even if
-# the server is unreachable. Do not attempt to umount
-# the root file system. Unmount in reverse order from
-# that given by /proc/mounts (otherwise it may not work).
-#
-unmount() {
- local dev mp type opts
- if read dev mp type opts
- then
- # recurse - unmount later items
- unmount
- # skip /, /proc and /dev
- case "$mp" in
- /|/proc)return 0;;
- /dev) return 0;;
- esac
- # then unmount this, if nfs
- case "$type" in
- nfs|smbfs|ncpfs) umount -f "$mp";;
- esac
- fi
-}
-
-unmount </proc/mounts
diff --git a/openembedded/packages/initscripts/initscripts-1.0/tosa/keymap-2.4.map b/openembedded/packages/initscripts/initscripts-1.0/tosa/keymap-2.4.map
index b27f21e32..31ca75b66 100644
--- a/openembedded/packages/initscripts/initscripts-1.0/tosa/keymap-2.4.map
+++ b/openembedded/packages/initscripts/initscripts-1.0/tosa/keymap-2.4.map
@@ -42,16 +42,16 @@ keycode 38 = Right
altgr keycode 38 = Incr_Console
keycode 39 = Return
keycode 40 = F12
-keycode 41 = one exclam
-keycode 42 = two quotedbl
-keycode 43 = three numbersign
-keycode 44 = four dollar
-keycode 45 = five percent
-keycode 46 = six ampersand
-keycode 47 = seven apostrophe
-keycode 48 = eight parenleft
-keycode 49 = nine parenright
-keycode 50 = zero asciitilde
+keycode 41 = one exclam one
+keycode 42 = two quotedbl two
+keycode 43 = three numbersign three
+keycode 44 = four dollar four
+keycode 45 = five percent five
+keycode 46 = six ampersand six
+keycode 47 = seven apostrophe seven
+keycode 48 = eight parenleft eight
+keycode 49 = nine parenright nine
+keycode 50 = zero asciitilde zero
keycode 51 = minus equal
keycode 52 = asciicircum asciitilde
keycode 53 = backslash bar
diff --git a/openembedded/packages/initscripts/initscripts_1.0.bb b/openembedded/packages/initscripts/initscripts_1.0.bb
index 4e11097f8..d9b93005f 100644
--- a/openembedded/packages/initscripts/initscripts_1.0.bb
+++ b/openembedded/packages/initscripts/initscripts_1.0.bb
@@ -6,7 +6,7 @@ DEPENDS = "makedevs"
DEPENDS_openzaurus = "makedevs virtual/kernel"
RDEPENDS = "makedevs"
LICENSE = "GPL"
-PR = "r67"
+PR = "r69"
SRC_URI = "file://halt \
file://ramdisk \
@@ -127,14 +127,14 @@ do_install () {
ln -sf ../init.d/sendsigs ${D}${sysconfdir}/rc6.d/S20sendsigs
# ln -sf ../init.d/urandom ${D}${sysconfdir}/rc6.d/S30urandom
ln -sf ../init.d/umountnfs.sh ${D}${sysconfdir}/rc6.d/S31umountnfs.sh
-# ln -sf ../init.d/umountfs ${D}${sysconfdir}/rc6.d/S40umountfs
+ ln -sf ../init.d/umountfs ${D}${sysconfdir}/rc6.d/S40umountfs
# udev will run at S55 if installed
ln -sf ../init.d/ramdisk ${D}${sysconfdir}/rcS.d/S30ramdisk
ln -sf ../init.d/reboot ${D}${sysconfdir}/rc6.d/S90reboot
ln -sf ../init.d/sendsigs ${D}${sysconfdir}/rc0.d/S20sendsigs
# ln -sf ../init.d/urandom ${D}${sysconfdir}/rc0.d/S30urandom
ln -sf ../init.d/umountnfs.sh ${D}${sysconfdir}/rc0.d/S31umountnfs.sh
-# ln -sf ../init.d/umountfs ${D}${sysconfdir}/rc0.d/S40umountfs
+ ln -sf ../init.d/umountfs ${D}${sysconfdir}/rc0.d/S40umountfs
# udev will run at S55 if installed
ln -sf ../init.d/halt ${D}${sysconfdir}/rc0.d/S90halt
ln -sf ../init.d/banner ${D}${sysconfdir}/rcS.d/S02banner