summaryrefslogtreecommitdiff
path: root/openembedded
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/gcc/gcc3-build.inc3
-rw-r--r--openembedded/packages/gcc/gcc_4.0.2.bb2
2 files changed, 3 insertions, 2 deletions
diff --git a/openembedded/packages/gcc/gcc3-build.inc b/openembedded/packages/gcc/gcc3-build.inc
index b7523c42f..8048b45fb 100644
--- a/openembedded/packages/gcc/gcc3-build.inc
+++ b/openembedded/packages/gcc/gcc3-build.inc
@@ -10,11 +10,12 @@ S = "${WORKDIR}/gcc-${PV}"
B = "${S}/build.${HOST_SYS}.${TARGET_SYS}"
BINV ?= "${PV}"
-# gcj doesn't work on arm
+# gcj doesn't work on some architectures
JAVA = ",java"
JAVA_arm = ""
JAVA_armeb = ""
JAVA_mipsel = ""
+JAVA_sh3 = ""
# gcc4-build sets this to f95
FORTRAN ?= "f77"
LANGUAGES ?= "c,c++,${FORTRAN}${JAVA}"
diff --git a/openembedded/packages/gcc/gcc_4.0.2.bb b/openembedded/packages/gcc/gcc_4.0.2.bb
index 4f64e7cc9..f4eeb9bde 100644
--- a/openembedded/packages/gcc/gcc_4.0.2.bb
+++ b/openembedded/packages/gcc/gcc_4.0.2.bb
@@ -1,10 +1,10 @@
-PR = "r1"
DESCRIPTION = "The GNU cc and gcc C compilers."
HOMEPAGE = "http://www.gnu.org/software/gcc/"
SECTION = "devel"
LICENSE = "GPL"
MAINTAINER = "Gerald Britton <gbritton@doomcom.org>"
DEPENDS = "mpfr gmp"
+PR = "r1"
inherit autotools gettext