summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2012-05-11 11:30:22 +0200
committerTrygve Laugstøl <trygvis@inamo.no>2012-05-11 11:30:22 +0200
commit5a93d5c34e2688b70434ecc3d5ea5e1423043dc8 (patch)
tree2b8dd5160773659ef17b3d2dcf057e3ea318fd22
parentde8ddb00cbf32ef72d959a1d2e8bf8a38c802c56 (diff)
downloadopenembedded-olinuxino-trygvis-5a93d5c34e2688b70434ecc3d5ea5e1423043dc8.tar.gz
openembedded-olinuxino-trygvis-5a93d5c34e2688b70434ecc3d5ea5e1423043dc8.tar.bz2
openembedded-olinuxino-trygvis-5a93d5c34e2688b70434ecc3d5ea5e1423043dc8.tar.xz
openembedded-olinuxino-trygvis-5a93d5c34e2688b70434ecc3d5ea5e1423043dc8.zip
o Initial import of my own OpenEmbedded distribution.
-rw-r--r--.gitignore9
-rw-r--r--.gitmodules3
-rw-r--r--.vimrc1
-rw-r--r--build/conf/bblayers.conf11
-rw-r--r--build/conf/local.conf205
-rw-r--r--meta-trygvis/conf/layer.conf10
-rw-r--r--meta-trygvis/recipes-core/images/trygvis-bare.bb12
-rw-r--r--meta-trygvis/recipes-core/images/trygvis-console.bb22
-rw-r--r--meta-trygvis/recipes-core/netbase/files/olinuxino/interfaces15
-rw-r--r--meta-trygvis/recipes-core/netbase/netbase_4.47.bbappend1
m---------oe-deptools0
-rw-r--r--source-me8
12 files changed, 297 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..eea72fe
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+build/bitbake.lock
+build/conf/sanity_info
+build/downloads
+build/pseudodone
+build/sstate-cache
+build/tmp-*/
+build/*.dot
+
+*.un~
diff --git a/.gitmodules b/.gitmodules
index 45adcce..4a4834b 100644
--- a/.gitmodules
+++ b/.gitmodules
@@ -10,3 +10,6 @@
[submodule "meta-olinuxino"]
path = meta-olinuxino
url = git://github.com/radolin/meta-olinuxino.git
+[submodule "oe-deptools"]
+ path = oe-deptools
+ url = https://github.com/scottellis/oe-deptools.git
diff --git a/.vimrc b/.vimrc
new file mode 100644
index 0000000..1560c9f
--- /dev/null
+++ b/.vimrc
@@ -0,0 +1 @@
+set wildignore+=build
diff --git a/build/conf/bblayers.conf b/build/conf/bblayers.conf
new file mode 100644
index 0000000..ea9f2c2
--- /dev/null
+++ b/build/conf/bblayers.conf
@@ -0,0 +1,11 @@
+# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
+# changes incompatibly
+LCONF_VERSION = "4"
+
+BBFILES ?= ""
+BBLAYERS ?= " \
+ /home/trygvis/dev/com.github/trygvis/olinuxino-oe/openembedded-core/meta \
+ /home/trygvis/dev/com.github/trygvis/olinuxino-oe/openembedded-core/meta-fsl-arm \
+ /home/trygvis/dev/com.github/trygvis/olinuxino-oe/openembedded-core/meta-olinuxino \
+ /home/trygvis/dev/com.github/trygvis/olinuxino-oe/openembedded-core/meta-trygvis \
+ "
diff --git a/build/conf/local.conf b/build/conf/local.conf
new file mode 100644
index 0000000..1c623ec
--- /dev/null
+++ b/build/conf/local.conf
@@ -0,0 +1,205 @@
+#
+# This file is your local configuration file and is where all local user settings
+# are placed. The comments in this file give some guide to the options a new user
+# to the system might want to change but pretty much any configuration option can
+# be set in this file. More adventurous users can look at local.conf.extended
+# which contains other examples of configuration which can be placed in this file
+# but new users likely won't need any of them initially.
+#
+# Lines starting with the '#' character are commented out and in some cases the
+# default values are provided as comments to show people example syntax. Enabling
+# the option is a question of removing the # character and making any change to the
+# variable as required.
+
+#
+# Parallelism Options
+#
+# These two options control how much parallelism BitBake should use. The first
+# option determines how many tasks bitbake should run in parallel:
+#
+BB_NUMBER_THREADS = "8"
+#
+# The second option controls how many processes make should run in parallel when
+# running compile tasks:
+#
+PARALLEL_MAKE = "-j 8"
+#
+# For a quad-core machine, BB_NUMBER_THREADS = "4", PARALLEL_MAKE = "-j 4" would
+# be appropriate for example.
+
+#
+# Machine Selection
+#
+# You need to select a specific machine to target the build with. There are a selection
+# of emulated machines available which can boot and run in the QEMU emulator:
+#
+#MACHINE ?= "qemuarm"
+#MACHINE ?= "qemumips"
+#MACHINE ?= "qemuppc"
+#MACHINE ?= "qemux86"
+#MACHINE ?= "qemux86-64"
+MACHINE = "olinuxino"
+#
+# This sets the default machine to be qemux86 if no other machine is selected:
+MACHINE ??= "qemux86"
+
+#
+# Where to place downloads
+#
+# During a first build the system will download many different source code tarballs
+# from various upstream projects. This can take a while, particularly if your network
+# connection is slow. These are all stored in DL_DIR. When wiping and rebuilding you
+# can preserve this directory to speed up this part of subsequent builds. This directory
+# is safe to share between multiple builds on the same machine too.
+#
+# The default is a downloads directory under TOPDIR which is the build directory.
+#
+#DL_DIR ?= "${TOPDIR}/downloads"
+
+#
+# Where to place shared-state files
+#
+# BitBake has the capability to accelerate builds based on previously built output.
+# This is done using "shared state" files which can be thought of as cache objects
+# and this option determines where those files are placed.
+#
+# You can wipe out TMPDIR leaving this directory intact and the build would regenerate
+# from these files if no changes were made to the configuration. If changes were made
+# to the configuration, only shared state files where the state was still valid would
+# be used (done using checksums).
+#
+# The default is a sstate-cache directory under TOPDIR.
+#
+#SSTATE_DIR ?= "${TOPDIR}/sstate-cache"
+
+#
+# Where to place the build output
+#
+# This option specifies where the bulk of the building work should be done and
+# where BitBake should place its temporary files and output. Keep in mind that
+# this includes the extraction and compilation of many applications and the toolchain
+# which can use Gigabytes of hard disk space.
+#
+# The default is a tmp directory under TOPDIR.
+#
+#TMPDIR = "${TOPDIR}/tmp"
+
+
+#
+# Package Management configuration
+#
+# This variable lists which packaging formats to enable. Multiple package backends
+# can be enabled at once and the first item listed in the variable will be used
+# to generate the root filesystems.
+# Options are:
+# - 'package_deb' for debian style deb files
+# - 'package_ipk' for ipk files are used by opkg (a debian style embedded package manager)
+# - 'package_rpm' for rpm style packages
+# E.g.: PACKAGE_CLASSES ?= "package_rpm package_deb package_ipk"
+# We default to ipk:
+PACKAGE_CLASSES ?= "package_ipk"
+
+#
+# SDK/ADT target architecture
+#
+# This variable specified the architecture to build SDK/ADT items for and means
+# you can build the SDK packages for architectures other than the machine you are
+# running the build on (i.e. building i686 packages on an x86_64 host._
+# Supported values are i686 and x86_64
+#SDKMACHINE ?= "i686"
+
+#
+# Extra image configuration defaults
+#
+# The EXTRA_IMAGE_FEATURES variable allows extra packages to be added to the generated
+# images. Some of these options are added to certain image types automatically. The
+# variable can contain the following options:
+# "dbg-pkgs" - add -dbg packages for all installed packages
+# (adds symbol information for debugging/profiling)
+# "dev-pkgs" - add -dev packages for all installed packages
+# (useful if you want to develop against libs in the image)
+# "tools-sdk" - add development tools (gcc, make, pkgconfig etc.)
+# "tools-debug" - add debugging tools (gdb, strace)
+# "tools-profile" - add profiling tools (oprofile, exmap, lttng valgrind (x86 only))
+# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
+# "debug-tweaks" - make an image suitable for development
+# e.g. ssh root access has a blank password
+# There are other application targets that can be used here too, see
+# meta/classes/image.bbclass and meta/classes/core-image.bbclass for more details.
+# We default to enabling the debugging tweaks.
+EXTRA_IMAGE_FEATURES = "debug-tweaks"
+
+#
+# Additional image features
+#
+# The following is a list of additional classes to use when building images which
+# enable extra features. Some available options which can be included in this variable
+# are:
+# - 'buildstats' collect build statistics
+# - 'image-mklibs' to reduce shared library files size for an image
+# - 'image-prelink' in order to prelink the filesystem image
+# - 'image-swab' to perform host system intrusion detection
+# NOTE: if listing mklibs & prelink both, then make sure mklibs is before prelink
+# NOTE: mklibs also needs to be explicitly enabled for a given image, see local.conf.extended
+USER_CLASSES ?= "buildstats image-mklibs image-prelink"
+
+#
+# Runtime testing of images
+#
+# The build system can test booting virtual machine images under qemu (an emulator)
+# after any root filesystems are created and run tests against those images. To
+# enable this uncomment this line
+#IMAGETEST = "qemu"
+#
+# This variable controls which tests are run against virtual images if enabled
+# above. The following would enable bat, boot the test case under the sanity suite
+# and perform toolchain tests
+#TEST_SCEN = "sanity bat sanity:boot toolchain"
+#
+# Because of the QEMU booting slowness issue (see bug #646 and #618), the
+# autobuilder may suffer a timeout issue when running sanity tests. We introduce
+# the variable TEST_SERIALIZE here to reduce the time taken by the sanity tests.
+# It is set to 1 by default, which will boot the image and run cases in the same
+# image without rebooting or killing the machine instance. If it is set to 0, the
+# image will be copied and tested for each case, which will take longer but be
+# more precise.
+#TEST_SERIALIZE = "1"
+
+#
+# Interactive shell configuration
+#
+# Under certain circumstances the system may need input from you and to do this it
+# can launch an interactive shell. It needs to do this since the build is
+# multithreaded and needs to be able to handle the case where more than one parallel
+# process may require the user's attention. The default is iterate over the available
+# terminal types to find one that works.
+#
+# Examples of the occasions this may happen are when resolving patches which cannot
+# be applied, to use the devshell or the kernel menuconfig
+#
+# Supported values are auto, gnome, xfce, rxvt, screen, konsole (KDE 3.x only), none
+# Note: currently, Konsole support only works for KDE 3.x due to the way
+# newer Konsole versions behave
+#OE_TERMINAL = "auto"
+# By default disable interactive patch resolution (tasks will just fail instead):
+PATCHRESOLVE = "noop"
+
+#
+# Shared-state files from other locations
+#
+# As mentioned above, shared state files are prebuilt cache data objects which can
+# used to accelerate build time. This variable can be used to configure the system
+# to search other mirror locations for these objects before it builds the data itself.
+#
+# This can be a filesystem directory, or a remote url such as http or ftp. These
+# would contain the sstate-cache results from previous builds (possibly from other
+# machines). This variable works like fetcher MIRRORS/PREMIRRORS and points to the
+# cache locations to check for the shared objects.
+#SSTATE_MIRRORS ?= "\
+#file://.* http://someserver.tld/share/sstate/ \n \
+#file://.* file:///some/local/dir/sstate/"
+
+# CONF_VERSION is increased each time build/conf/ changes incompatibly and is used to
+# track the version of this file when it was generated. This can safely be ignored if
+# this doesn't mean anything to you.
+CONF_VERSION = "1"
diff --git a/meta-trygvis/conf/layer.conf b/meta-trygvis/conf/layer.conf
new file mode 100644
index 0000000..1d163e5
--- /dev/null
+++ b/meta-trygvis/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH := "${BBPATH}:${LAYERDIR}"
+
+# We have a packages directory, add to BBFILES
+BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "trygvis"
+BBFILE_PATTERN_trygvis := "^${LAYERDIR}/"
+BBFILE_PRIORITY_trygvis = "6"
diff --git a/meta-trygvis/recipes-core/images/trygvis-bare.bb b/meta-trygvis/recipes-core/images/trygvis-bare.bb
new file mode 100644
index 0000000..54ffdc5
--- /dev/null
+++ b/meta-trygvis/recipes-core/images/trygvis-bare.bb
@@ -0,0 +1,12 @@
+require recipes-core/images/core-image-minimal.bb
+
+DESCRIPTION = "Trygvis, yeah."
+
+PR = "r1"
+
+# IMAGE_FEATURES += "apps-console-core"
+
+# fsck.ext2
+IMAGE_INSTALL += "e2fsprogs"
+
+export IMAGE_BASENAME = "trygvis"
diff --git a/meta-trygvis/recipes-core/images/trygvis-console.bb b/meta-trygvis/recipes-core/images/trygvis-console.bb
new file mode 100644
index 0000000..c663304
--- /dev/null
+++ b/meta-trygvis/recipes-core/images/trygvis-console.bb
@@ -0,0 +1,22 @@
+require trygvis-bare.bb
+
+DESCRIPTION += "Console version."
+
+PR = "r1"
+
+IMAGE_FEATURES += "apps-console-core"
+IMAGE_FEATURES += "tools-sdk"
+IMAGE_FEATURES += "tools-debug"
+IMAGE_FEATURES += "tools-profile"
+IMAGE_FEATURES += "tools-testapps"
+IMAGE_FEATURES += "ssh-server-dropbear"
+IMAGE_FEATURES += "debug-tweaks"
+# IMAGE_FEATURES += "${X11_IMAGE_FEATURES}"
+
+IMAGE_INSTALL += "alsa-utils alsa-tools"
+
+IMAGE_INSTALL += "dhcp"
+
+IMAGE_INSTALL += "bluez-hcidump bluez4"
+
+export IMAGE_BASENAME = "trygvis"
diff --git a/meta-trygvis/recipes-core/netbase/files/olinuxino/interfaces b/meta-trygvis/recipes-core/netbase/files/olinuxino/interfaces
new file mode 100644
index 0000000..adffef9
--- /dev/null
+++ b/meta-trygvis/recipes-core/netbase/files/olinuxino/interfaces
@@ -0,0 +1,15 @@
+# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
+
+# The loopback interface
+auto lo
+iface lo inet loopback
+
+# Wireless interfaces
+iface wlan0 inet dhcp
+ wireless_mode managed
+ wireless_essid any
+ wpa-driver wext
+ wpa-conf /etc/wpa_supplicant.conf
+
+auto usb0
+iface usb0 inet dhcp
diff --git a/meta-trygvis/recipes-core/netbase/netbase_4.47.bbappend b/meta-trygvis/recipes-core/netbase/netbase_4.47.bbappend
new file mode 100644
index 0000000..81fe7b7
--- /dev/null
+++ b/meta-trygvis/recipes-core/netbase/netbase_4.47.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
diff --git a/oe-deptools b/oe-deptools
new file mode 160000
+Subproject 49829397973c0cceefeece7ade4ceafec90e49f
diff --git a/source-me b/source-me
new file mode 100644
index 0000000..000a280
--- /dev/null
+++ b/source-me
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+if [ ! -h openembedded-core/bitbake ]
+then
+ ln -s ../bitbake openembedded-core/bitbake
+fi
+
+. openembedded-core/oe-init-build-env