summaryrefslogtreecommitdiff
path: root/meta-trygvis/recipes-core/images
diff options
context:
space:
mode:
Diffstat (limited to 'meta-trygvis/recipes-core/images')
-rw-r--r--meta-trygvis/recipes-core/images/trygvis-bare.bb12
-rw-r--r--meta-trygvis/recipes-core/images/trygvis-console.bb22
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-trygvis/recipes-core/images/trygvis-bare.bb b/meta-trygvis/recipes-core/images/trygvis-bare.bb
new file mode 100644
index 0000000..54ffdc5
--- /dev/null
+++ b/meta-trygvis/recipes-core/images/trygvis-bare.bb
@@ -0,0 +1,12 @@
+require recipes-core/images/core-image-minimal.bb
+
+DESCRIPTION = "Trygvis, yeah."
+
+PR = "r1"
+
+# IMAGE_FEATURES += "apps-console-core"
+
+# fsck.ext2
+IMAGE_INSTALL += "e2fsprogs"
+
+export IMAGE_BASENAME = "trygvis"
diff --git a/meta-trygvis/recipes-core/images/trygvis-console.bb b/meta-trygvis/recipes-core/images/trygvis-console.bb
new file mode 100644
index 0000000..c663304
--- /dev/null
+++ b/meta-trygvis/recipes-core/images/trygvis-console.bb
@@ -0,0 +1,22 @@
+require trygvis-bare.bb
+
+DESCRIPTION += "Console version."
+
+PR = "r1"
+
+IMAGE_FEATURES += "apps-console-core"
+IMAGE_FEATURES += "tools-sdk"
+IMAGE_FEATURES += "tools-debug"
+IMAGE_FEATURES += "tools-profile"
+IMAGE_FEATURES += "tools-testapps"
+IMAGE_FEATURES += "ssh-server-dropbear"
+IMAGE_FEATURES += "debug-tweaks"
+# IMAGE_FEATURES += "${X11_IMAGE_FEATURES}"
+
+IMAGE_INSTALL += "alsa-utils alsa-tools"
+
+IMAGE_INSTALL += "dhcp"
+
+IMAGE_INSTALL += "bluez-hcidump bluez4"
+
+export IMAGE_BASENAME = "trygvis"