aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2015-02-15 23:29:17 +0100
committerTrygve Laugstøl <trygvis@inamo.no>2015-02-15 23:35:36 +0100
commit0d0543e4daeb1c6b01d4799736026b6f3aef9779 (patch)
tree0f14cac6264710700c70f18c79e41a8aaa6a8cfd /CMakeLists.txt
parent60d5440dd3514e71b87948ff5ed30ee38445b8a5 (diff)
downloadble-toys-0d0543e4daeb1c6b01d4799736026b6f3aef9779.tar.gz
ble-toys-0d0543e4daeb1c6b01d4799736026b6f3aef9779.tar.bz2
ble-toys-0d0543e4daeb1c6b01d4799736026b6f3aef9779.tar.xz
ble-toys-0d0543e4daeb1c6b01d4799736026b6f3aef9779.zip
valgrind tests
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1220f20..1098415 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,7 +27,10 @@ target_link_libraries(ble_toys ble)
enable_testing()
find_package(Boost COMPONENTS unit_test_framework REQUIRED)
+
+# If we can change directory here add_definition and test-specific stuff could be moved to the test directory
file(GLOB TEST_SRCS RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} test/*.cpp)
+add_definitions(-DBOOST_TEST_DYN_LINK)
foreach(testSrc ${TEST_SRCS})
#Extract the filename without an extension (NAME_WE)