aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2015-02-17 07:58:36 +0100
committerTrygve Laugstøl <trygvis@inamo.no>2015-02-17 07:58:36 +0100
commit360fd8567545253f680ea544ce7313ab1ef43d14 (patch)
tree06fb409ddee9b370a4d0a76884b433e8e93f0de2 /CMakeLists.txt
parent60d5440dd3514e71b87948ff5ed30ee38445b8a5 (diff)
downloadble-toys-360fd8567545253f680ea544ce7313ab1ef43d14.tar.gz
ble-toys-360fd8567545253f680ea544ce7313ab1ef43d14.tar.bz2
ble-toys-360fd8567545253f680ea544ce7313ab1ef43d14.tar.xz
ble-toys-360fd8567545253f680ea544ce7313ab1ef43d14.zip
o Passing tests.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1220f20..0f2cbf2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,7 +26,7 @@ target_link_libraries(ble_toys ${Boost_LIBRARIES})
target_link_libraries(ble_toys ble)
enable_testing()
-find_package(Boost COMPONENTS unit_test_framework REQUIRED)
+find_package(Boost COMPONENTS log unit_test_framework REQUIRED)
file(GLOB TEST_SRCS RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} test/*.cpp)
foreach(testSrc ${TEST_SRCS})
@@ -39,8 +39,9 @@ foreach(testSrc ${TEST_SRCS})
include_directories(${PROJECT_SOURCE_DIR})
#link to Boost libraries AND your targets and dependencies
- target_link_libraries(${testName} ${Boost_LIBRARIES})
target_link_libraries(${testName} ble)
+ target_link_libraries(${testName} pthread)
+ target_link_libraries(${testName} ${Boost_LIBRARIES})
#I like to move testing binaries into a testBin directory
set_target_properties(${testName} PROPERTIES