aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2015-02-23 23:04:38 +0100
committerTrygve Laugstøl <trygvis@inamo.no>2015-02-23 23:04:38 +0100
commit4671571c93db7f083db21cfca526ac382cdfc7ad (patch)
tree834d24e1e59ab9ace06d15fd9abf149470ca20e3 /CMakeLists.txt
parentd0fb1850606ce003887259675e271a9aade4fda0 (diff)
downloadble-toys-4671571c93db7f083db21cfca526ac382cdfc7ad.tar.gz
ble-toys-4671571c93db7f083db21cfca526ac382cdfc7ad.tar.bz2
ble-toys-4671571c93db7f083db21cfca526ac382cdfc7ad.tar.xz
ble-toys-4671571c93db7f083db21cfca526ac382cdfc7ad.zip
Major improvement in the sm-get-value utility:
o Adding command line option parsing through boost::program_option Current options: --device, --sensor --format selects between CSV and JSON output. --sleep controls single reads vs continuous reads. o Adding JSON output. o Adding support for Release builds without debugging info. Needs improvement.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0cf3b20..0d48449 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,6 +4,14 @@ find_package(PkgConfig)
# Use Clang by default: http://stackoverflow.com/a/7031553/245614
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++14")
+set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DDEBUG")
+set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DDEBUG")
+
+IF(NOT CMAKE_BUILD_TYPE)
+ SET(CMAKE_BUILD_TYPE Debug CACHE STRING
+ "Choose the type of build, options are: None Debug Release RelWithDebInfo MinSizeRel."
+ FORCE)
+ENDIF(NOT CMAKE_BUILD_TYPE)
# Boost
set(Boost_USE_STATIC_LIBS OFF)