aboutsummaryrefslogtreecommitdiff
path: root/apps/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2015-03-03 23:11:26 +0100
committerTrygve Laugstøl <trygvis@inamo.no>2015-03-03 23:11:26 +0100
commit1cf0d4c224b32e31d9cd9ba3a4719f57118321fb (patch)
tree3c935d94883207ded67e30a888a1844bfb676e76 /apps/CMakeLists.txt
parent8c5aad737561837f0b8d616cc03130b7546e45a9 (diff)
downloadble-toys-1cf0d4c224b32e31d9cd9ba3a4719f57118321fb.tar.gz
ble-toys-1cf0d4c224b32e31d9cd9ba3a4719f57118321fb.tar.bz2
ble-toys-1cf0d4c224b32e31d9cd9ba3a4719f57118321fb.tar.xz
ble-toys-1cf0d4c224b32e31d9cd9ba3a4719f57118321fb.zip
o An app to read the serial port and parse its values. Not very useful yet.
Diffstat (limited to 'apps/CMakeLists.txt')
-rw-r--r--apps/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/apps/CMakeLists.txt b/apps/CMakeLists.txt
index ab9c529..7fa9443 100644
--- a/apps/CMakeLists.txt
+++ b/apps/CMakeLists.txt
@@ -2,16 +2,16 @@ set(APPS
ble-inspect-device
sm-db-insert
sm-db-select
- sm-get-value)
+ sm-get-value
+ sm-serial-read)
-set(APPS ${APPS} log4cplus-test)
+list(APPEND APPS log4cplus-test)
-set(shared_sources
- SoilMoisture.cpp
- apps.cpp)
+list(APPEND shared_sources SoilMoisture.cpp)
+list(APPEND shared_sources apps.cpp)
# Boost
-find_package(Boost COMPONENTS system program_options REQUIRED)
+find_package(Boost COMPONENTS regex system program_options REQUIRED)
# Bluez
pkg_check_modules(BLUEZ bluez REQUIRED)