aboutsummaryrefslogtreecommitdiff
path: root/apps/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2015-03-22 16:57:09 +0100
committerTrygve Laugstøl <trygvis@inamo.no>2015-03-22 16:57:09 +0100
commitaad1eaa291460509a5cf94092609ae22ebef5494 (patch)
tree72d6308a84449e85b00de84f27f0a613b46ef669 /apps/CMakeLists.txt
parent0dc2cc6503386c809266ad6564ba675803cf8cc7 (diff)
downloadble-toys-aad1eaa291460509a5cf94092609ae22ebef5494.tar.gz
ble-toys-aad1eaa291460509a5cf94092609ae22ebef5494.tar.bz2
ble-toys-aad1eaa291460509a5cf94092609ae22ebef5494.tar.xz
ble-toys-aad1eaa291460509a5cf94092609ae22ebef5494.zip
o Renaming SoilMoistureIo to SensorSample, moving to its own library.
Diffstat (limited to 'apps/CMakeLists.txt')
-rw-r--r--apps/CMakeLists.txt11
1 files changed, 6 insertions, 5 deletions
diff --git a/apps/CMakeLists.txt b/apps/CMakeLists.txt
index 3891d79..15a1f0b 100644
--- a/apps/CMakeLists.txt
+++ b/apps/CMakeLists.txt
@@ -11,7 +11,6 @@ list(APPEND APPS sm-serial-read-all)
add_library(trygvis-apps
SoilMoisture.cpp
- SoilMoistureIo.cpp
apps.cpp)
# Boost
@@ -35,18 +34,20 @@ if(LOG4CPLUS_LIBRARIES MATCHES NOTFOUND)
message(FATAL_ERROR "Could not find log4cplus library files")
endif()
-foreach(app ${APPS})
- include_directories("${PROJECT_SOURCE_DIR}/include")
- include_directories("${PROJECT_SOURCE_DIR}/json/src")
+include_directories("${PROJECT_SOURCE_DIR}/include")
+include_directories("${PROJECT_SOURCE_DIR}/json/src")
+include_directories("${PROJECT_SOURCE_DIR}/sensor/include")
+include_directories("${LOG4CPLUS_INCLUDE_DIRECTORIES}")
+foreach(app ${APPS})
add_executable(${app} ${app}.cpp)
target_link_libraries(${app} ble)
target_link_libraries(${app} trygvis-apps)
+ target_link_libraries(${app} trygvis-sensor)
target_link_libraries(${app} ${Boost_LIBRARIES})
target_link_libraries(${app} ${BLUEZ_LIBRARIES})
target_link_libraries(${app} ${PQXX_LIBRARIES})
- include_directories("${LOG4CPLUS_INCLUDE_DIRECTORIES}")
target_link_libraries(${app} ${LOG4CPLUS_LIBRARIES})
target_link_libraries(${app} ${CMAKE_THREAD_LIBS_INIT})
endforeach(app)