aboutsummaryrefslogtreecommitdiff
path: root/apps/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2015-03-14 17:33:43 +0100
committerTrygve Laugstøl <trygvis@inamo.no>2015-03-14 17:33:43 +0100
commitefa1825dd6d16e7901e9620c31796b27b6c84ee9 (patch)
tree7ce8e6b4728dfaa853bb9d67f53c1a50eafb2231 /apps/CMakeLists.txt
parent46cd1838255712cc599a30a81098121aa26d80f5 (diff)
downloadble-toys-efa1825dd6d16e7901e9620c31796b27b6c84ee9.tar.gz
ble-toys-efa1825dd6d16e7901e9620c31796b27b6c84ee9.tar.bz2
ble-toys-efa1825dd6d16e7901e9620c31796b27b6c84ee9.tar.xz
ble-toys-efa1825dd6d16e7901e9620c31796b27b6c84ee9.zip
o Creating a tool to calculate an absolute timestamp from a relative timestamp.
o Using git submodules instead of CMake's external project.
Diffstat (limited to 'apps/CMakeLists.txt')
-rw-r--r--apps/CMakeLists.txt13
1 files changed, 2 insertions, 11 deletions
diff --git a/apps/CMakeLists.txt b/apps/CMakeLists.txt
index e2082e1..5510cb3 100644
--- a/apps/CMakeLists.txt
+++ b/apps/CMakeLists.txt
@@ -1,6 +1,7 @@
list(APPEND APPS log4cplus-test)
list(APPEND APPS ble-inspect-device)
list(APPEND APPS sample-convert)
+list(APPEND APPS sample-timestamp)
list(APPEND APPS sm-db-insert)
list(APPEND APPS sm-db-select)
list(APPEND APPS sm-get-value)
@@ -32,19 +33,9 @@ if(LOG4CPLUS_LIBRARIES MATCHES NOTFOUND)
message(FATAL_ERROR "Could not find log4cplus library files")
endif()
-include(ExternalProject)
-ExternalProject_Add(
- JSON
- PREFIX json
- GIT_REPOSITORY https://github.com/nlohmann/json.git
- GIT_TAG ec42245951fceb7594bfb24746c7449986c3c2a4
- CONFIGURE_COMMAND ""
- BUILD_COMMAND ""
- INSTALL_COMMAND "")
-
foreach(app ${APPS})
include_directories("${PROJECT_SOURCE_DIR}/include")
- include_directories("${CMAKE_BINARY_DIR}/apps/json/src/JSON/src")
+ include_directories("${PROJECT_SOURCE_DIR}/json/src")
add_executable(${app} ${app}.cpp)