aboutsummaryrefslogtreecommitdiff
path: root/sensor/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2015-03-22 16:57:09 +0100
committerTrygve Laugstøl <trygvis@inamo.no>2015-03-22 16:57:09 +0100
commitaad1eaa291460509a5cf94092609ae22ebef5494 (patch)
tree72d6308a84449e85b00de84f27f0a613b46ef669 /sensor/CMakeLists.txt
parent0dc2cc6503386c809266ad6564ba675803cf8cc7 (diff)
downloadble-toys-aad1eaa291460509a5cf94092609ae22ebef5494.tar.gz
ble-toys-aad1eaa291460509a5cf94092609ae22ebef5494.tar.bz2
ble-toys-aad1eaa291460509a5cf94092609ae22ebef5494.tar.xz
ble-toys-aad1eaa291460509a5cf94092609ae22ebef5494.zip
o Renaming SoilMoistureIo to SensorSample, moving to its own library.
Diffstat (limited to 'sensor/CMakeLists.txt')
-rw-r--r--sensor/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/sensor/CMakeLists.txt b/sensor/CMakeLists.txt
new file mode 100644
index 0000000..5d7612f
--- /dev/null
+++ b/sensor/CMakeLists.txt
@@ -0,0 +1,8 @@
+add_library(trygvis-sensor
+ main/SensorSample.cpp)
+
+include_directories("${PROJECT_SOURCE_DIR}/json/src")
+include_directories(include)
+
+# Boost
+find_package(Boost COMPONENTS regex system program_options REQUIRED)