aboutsummaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2015-03-17 21:29:40 +0100
committerTrygve Laugstøl <trygvis@inamo.no>2015-03-17 21:29:40 +0100
commit5d6e4c971857b5e05d7c277e7eafcb9d64dbc6a7 (patch)
treef6ff4bf95a3a81b9a98ca09bc4d980147346fe3a /test/CMakeLists.txt
parent2a7ffd694cfa3493ef1b83a69878322b8ca97670 (diff)
downloadble-toys-5d6e4c971857b5e05d7c277e7eafcb9d64dbc6a7.tar.gz
ble-toys-5d6e4c971857b5e05d7c277e7eafcb9d64dbc6a7.tar.bz2
ble-toys-5d6e4c971857b5e05d7c277e7eafcb9d64dbc6a7.tar.xz
ble-toys-5d6e4c971857b5e05d7c277e7eafcb9d64dbc6a7.zip
o An improved KeyDictionary.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index e9f217f..e8dc219 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,4 +1,4 @@
-find_package(Boost COMPONENTS log unit_test_framework REQUIRED)
+find_package(Boost COMPONENTS log regex unit_test_framework REQUIRED)
# If we can change directory here add_definition and test-specific stuff could be moved to the test directory
file(GLOB TEST_SRCS RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *Test.cpp)
@@ -18,6 +18,9 @@ foreach(testSrc ${TEST_SRCS})
target_link_libraries(${testName} pthread)
target_link_libraries(${testName} ${Boost_LIBRARIES})
+ include_directories("${PROJECT_SOURCE_DIR}/apps")
+ target_link_libraries(${testName} trygvis-apps)
+
#I like to move testing binaries into a testBin directory
set_target_properties(${testName} PROPERTIES
RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/test)