aboutsummaryrefslogtreecommitdiff
path: root/apps/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'apps/CMakeLists.txt')
-rw-r--r--apps/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/apps/CMakeLists.txt b/apps/CMakeLists.txt
index 01252cf..8ba5a0a 100644
--- a/apps/CMakeLists.txt
+++ b/apps/CMakeLists.txt
@@ -69,5 +69,11 @@ target_link_libraries(launcher ${CMAKE_THREAD_LIBS_INIT})
foreach(app ${APPS})
add_custom_command(
TARGET launcher POST_BUILD
- COMMAND ln -sf launcher ${app})
+ COMMAND ln -sf ../libexec/launcher ${app})
+
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${app} DESTINATION bin)
endforeach()
+
+set_target_properties(launcher PROPERTIES INSTALL_RPATH "\\$ORIGIN/../lib/trygvis")
+install(TARGETS launcher
+ RUNTIME DESTINATION libexec)