aboutsummaryrefslogtreecommitdiff
path: root/sensor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sensor/CMakeLists.txt')
-rw-r--r--sensor/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/sensor/CMakeLists.txt b/sensor/CMakeLists.txt
index 7cee42b..14804f1 100644
--- a/sensor/CMakeLists.txt
+++ b/sensor/CMakeLists.txt
@@ -1,11 +1,12 @@
-file(GLOB INCLUDES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} include/*.h)
+file(GLOB_RECURSE INCLUDES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} include/*.h)
add_library(trygvis-sensor
- main/SensorSample.cpp
+ main/sensor.cpp
+ main/io.cpp
${INCLUDES})
include_directories("${PROJECT_SOURCE_DIR}/json/src")
include_directories(include)
# Boost
-find_package(Boost COMPONENTS regex system program_options REQUIRED)
+find_package(Boost COMPONENTS regex system REQUIRED)