aboutsummaryrefslogtreecommitdiff
path: root/sensor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sensor/CMakeLists.txt')
-rw-r--r--sensor/CMakeLists.txt18
1 files changed, 13 insertions, 5 deletions
diff --git a/sensor/CMakeLists.txt b/sensor/CMakeLists.txt
index d571e38..c814687 100644
--- a/sensor/CMakeLists.txt
+++ b/sensor/CMakeLists.txt
@@ -1,14 +1,22 @@
file(GLOB_RECURSE INCLUDES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} include/*.h)
add_library(trygvis-sensor
- main/sensor.cpp
- main/io.cpp
- ${INCLUDES})
+ STATIC
+ main/sensor.cpp
+ main/io.cpp
+ ${INCLUDES})
-include_directories("${PROJECT_SOURCE_DIR}/json/src")
-include_directories(include)
+target_include_directories(trygvis-sensor PUBLIC "${PROJECT_SOURCE_DIR}/json/src")
+target_include_directories(trygvis-sensor PUBLIC include)
# Boost
find_package(Boost COMPONENTS regex system REQUIRED)
add_subdirectory(test)
+
+install(TARGETS trygvis-sensor
+ RUNTIME DESTINATION bin
+ LIBRARY DESTINATION lib/trygvis
+ ARCHIVE DESTINATION lib/trygvis)
+
+install(DIRECTORY include/trygvis DESTINATION include)