aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 878abf9..9c379c5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,11 +1,14 @@
cmake_minimum_required(VERSION 3.2)
project(mqtt_cassandra_bridge)
-include(ExternalProject)
+find_package(Boost COMPONENTS regex system program_options REQUIRED)
add_executable(mqtt_cassandra_bridge main.cpp)
+target_link_libraries(mqtt_cassandra_bridge PUBLIC ${Boost_LIBRARIES})
target_compile_options(mqtt_cassandra_bridge PUBLIC "-std=c++14")
+include(ExternalProject)
+
# Cassandra
set(CPP_DRIVER ${CMAKE_CURRENT_BINARY_DIR}/cpp-driver)
ExternalProject_Add(cpp-driver