aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2015-12-18 21:19:35 +0100
committerTrygve Laugstøl <trygvis@inamo.no>2015-12-18 21:19:35 +0100
commit022daa0619f7d571db6e81c09ab5c0f0af389c18 (patch)
treea2b1c7f6d36f1f3ddfd109bc28ddbf71a9f85196 /CMakeLists.txt
parent7bc66b8b61d818f0beaaf9a944abd6e086e0fae6 (diff)
downloadstm32f103-playground-022daa0619f7d571db6e81c09ab5c0f0af389c18.tar.gz
stm32f103-playground-022daa0619f7d571db6e81c09ab5c0f0af389c18.tar.bz2
stm32f103-playground-022daa0619f7d571db6e81c09ab5c0f0af389c18.tar.xz
stm32f103-playground-022daa0619f7d571db6e81c09ab5c0f0af389c18.zip
o Functional initialization of .data and .bss.
o Adding a minimal printf library
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0834db0..8a8ef4d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,8 @@ project(teensy-playground C CXX ASM)
#include(cmake/Teensy.cmake)
add_executable(test1.elf test1.cpp init.s include/stm32f10x_conf.h
+ # http://www.sparetimelabs.com/tinyprintf/tinyprintf.php
+ tmp/printf/printf.h tmp/printf/printf.c
tmp/STM32F10x_StdPeriph_Lib_V3.5.0/Libraries/CMSIS/CM3/CoreSupport/core_cm3.c
tmp/STM32F10x_StdPeriph_Lib_V3.5.0/Libraries/CMSIS/CM3/DeviceSupport/ST/STM32F10x/system_stm32f10x.c
tmp/STM32F10x_StdPeriph_Lib_V3.5.0/Libraries/STM32F10x_StdPeriph_Driver/src/stm32f10x_rcc.c