aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2015-12-21 00:16:57 +0100
committerTrygve Laugstøl <trygvis@inamo.no>2015-12-21 00:16:57 +0100
commitaf5b3792973e876a860dae5dc7b7f9140f0e3a24 (patch)
tree764c85b96e9d6070902b4a5d2676a7dc3bf03929 /CMakeLists.txt
parentacf22f18828595a0731d3558b7e2d2ba321c926d (diff)
downloadstm32f103-playground-af5b3792973e876a860dae5dc7b7f9140f0e3a24.tar.gz
stm32f103-playground-af5b3792973e876a860dae5dc7b7f9140f0e3a24.tar.bz2
stm32f103-playground-af5b3792973e876a860dae5dc7b7f9140f0e3a24.tar.xz
stm32f103-playground-af5b3792973e876a860dae5dc7b7f9140f0e3a24.zip
o Moving more init code to C.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 99b97dd..7c09d38 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,7 +26,7 @@ target_include_directories(tinyprintf PUBLIC tinyprintf)
#########################################################################################################
# test1
-add_executable(test1.elf test1.cpp init_low.s init_high.cpp include/stm32f10x_conf.h
+add_executable(test1.elf test1.cpp init_low.s init_high.cpp init_high.h include/stm32f10x_conf.h
# http://www.sparetimelabs.com/tinyprintf/tinyprintf.php
tinyprintf/tinyprintf.c tinyprintf/tinyprintf.h
tmp/STM32F10x_StdPeriph_Lib_V3.5.0/Libraries/CMSIS/CM3/CoreSupport/core_cm3.c
@@ -50,7 +50,7 @@ add_extra_commands(test1.elf)
#########################################################################################################
# serial1
-add_executable(serial1.elf serial1.cpp init_low.s init_high.cpp include/stm32f10x_conf.h
+add_executable(serial1.elf serial1.cpp init_low.s init_high.cpp init_high.h include/stm32f10x_conf.h
debug.cpp debug.h
# http://www.sparetimelabs.com/tinyprintf/tinyprintf.php
tinyprintf/tinyprintf.c tinyprintf/tinyprintf.h
@@ -74,7 +74,7 @@ add_extra_commands(serial1.elf)
#########################################################################################################
# serial2
-add_executable(serial2.elf serial2.cpp init_low.s init_high.cpp include/stm32f10x_conf.h
+add_executable(serial2.elf serial2.cpp init_low.s init_high.cpp init_high.h include/stm32f10x_conf.h
debug.cpp debug.h
tmp/STM32F10x_StdPeriph_Lib_V3.5.0/Libraries/CMSIS/CM3/CoreSupport/core_cm3.c
tmp/STM32F10x_StdPeriph_Lib_V3.5.0/Libraries/CMSIS/CM3/DeviceSupport/ST/STM32F10x/system_stm32f10x.c